Cisco Openpeak 2 Ubuntu-XP USB installation

Discussion for non Joggler hardware / software including software for devices that share similarities with the O2 Joggler Hardware. This section has been opened for discussion of things like the settings up the EMGD drivers on other hardware using Ubuntu, as discussion of this has been banned at the official Ubuntu Forums.
Post Reply
User avatar
Posts: 2955
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Cisco Openpeak 2 Ubuntu-XP USB installation

Post by pete »

Here have had one Cisco Openpeak 2 from a peer for over a year and returning it.

Basically I bricked it when first playing with it. It had a Cisco EFI boot bios.

Doing the blind typing thing got it to boot and replaced Cisco EFI boot bios with Seabios.

Initially with Seabios wrote a Realtek bios to the built in NIC.

Tried XP (did this before) and had IRQ issues with the sound and built in NIC.

As to not want to deal with this returning it to an Avaya EFI boot rom.

From here creating an Ubuntu boot USB stick and an XP EFI boot stick.

I am pretty sure that I will still have issues in Windows with drivers for the audio and NIC.

The above written I would lean on only utilizing Buzz's Ubuntu on this device. Historically wrote KODI on the 2 GB built in MMC and used a Crystal Broadcom HD mini pcie HD card on it. It did work but ran out of space within a week or two on the build.

I also added one extra USB port using the traces for USB port on the top of the device.
Note that this taking apart the Openpeak 2 device.
This was not a plug n play solution and I do not recommend it.
May try to add a USB on top soldering wires to top connector. It is only 4 wires that I need.

Step 1 -

1 - Connect the Cisco Seabios USB port to a USB hub with a combo wireless Logitech keyboard/mousepad.
2 - create a fat32 USB stick and copy over the Avaya ROM. Rename the Avaya ROM to what upgrade.rom such that Seabios F7 boot will recognize the Avaya ROM file. Boot up Cisco Openpeak 2 and hit the F7 key while booting. Takes a bit of time. Wait until completion then hit a key to reboot.

Interruption of said write will brick you Cisco Openpeak 2 device and the ROM chip is soldered in to place such that there is no fix if you brick it.

Will attach pictures of the update to Avaya. At this time thinking that the 2Gb MMC was trashed and personally reformatted it with no OS. Leaving it like this for now.
Step - 2 Ubuntu Boot USB stick

1 - write Buzz's Ubuntu image to a new 16Gb mini USB stick.
Downloaded from here ==> Xubuntu 14.04 LTS (Trusty) via Linux. It is a tar file.
2 - Expanded it to an image file and wrote said image to USB stick.
Issues booting to Ubuntu due to a trashed 2Gb mmc. Created a new boot USB stick to update 2Gb MMC with current Openpeak image.
3 - Then was able to boot to a mini USB stick with Ubuntu just fine.
4 - expanded os to 16Gb running the new Ubuntu via installed Gparted.
5 - Updating and changing regional stuff to the US. Working well now.
6 - The Openpeak 2 does have a battery in it so checking the hardware clock to see of the battery is any good right now. It is and works with a cold boot to correct time.
7 - fixed it such that NIC mac is newly configured in rom Realtek NIC.
8 - It is suggested to plug the USB mini stick to the back and utilize a combo Bluetooth wireless keyboard / mouse.
9 - will compress and save image.

Step - 3 XP Boot EFI USB stick
1 - wrote last working image that I had for XP EFI - old image
2 - boots fine in USB port. Very slow if I use a hub. Last working XP build I used an SSD inside of a little mini case with a USB. Worked much better.
3 - I am going to stop for now with this endeavor. XP works better with Seabios except for the NIC and sound drivers.
4 - It is not worth the effort to making a USB stick XP. That and the only working sort of OK way in EFI mode was to use an SSD to USB device or ZIF SSD or Seabios with all of the above.
- Pete
O2 Jogglers running EFI Ubuntu / Squeezeplayer
OpenPeak Voip Telephony / Zigbee tabletops hardware modded with Seabios / RTC / Ethernet ROM edits / SSD drives running XPe for automation screens

Auto mater
Post Reply