SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
Man in a van
Posts: 315
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by Man in a van »

This is now a stable release but unlikely to receive updates, replacing v7.9.2 and v7.7.7

http://downloads.slimdevices.com/Logite ... er_v7.9.3/

This is the new nightly, which will receive occasional updates

http://downloads.slimdevices.com/nightly/?ver=7.9

This is the development branch which is beta and requires updating on a regular basis

http://downloads.slimdevices.com/nightly/?ver=8.0
gegs
Posts: 1146
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by gegs »

I'm running 8 on a raspberry Pi. I have to make sure that the Pi is connected to 2.4 GHz wi-fi or LMS won't recognise the Joggler.

Once both are on 2.4 GHz, if you choose the player drop-down on LMS, you should see the player, but probably connected to Squeezebox.com. Select the player and it will ask if you want to connect to this server. Say yes and your Joggler should be connected to LMS.

I discovered this solution today. I had the LMS problem after changing to Amazon Eero mesh wi-fi, which was painless, other than losing LMS connectivity to my Joggler. Devices choose their own connection frequency (2.4 GHz or 5 GHz) but they all appear as the same network, and it's not easily distinguishable which band is being used. The Eero app on my phone allows me to turn off 5 GHz for 10 mins. My Pi was on 5 GHz but once I'd deactivated that frequency and connected the Pi to the network again, now only broadcasting in 2.4 GHz, I followed the steps in the previous paragraph.

Now sorted and very happy.
gegs
Posts: 1146
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by gegs »

BTW, my Raspberry Pi and Joggler only need to be on 2.4 GHz for discovery and initial connection. My Pi is now on 5 GHz and LMS still recognises the Joggler.
gegs wrote: Sun Oct 11, 2020 12:23 am I'm running 8 on a raspberry Pi. I have to make sure that the Pi is connected to 2.4 GHz wi-fi or LMS won't recognise the Joggler.

Once both are on 2.4 GHz, if you choose the player drop-down on LMS, you should see the player, but probably connected to Squeezebox.com. Select the player and it will ask if you want to connect to this server. Say yes and your Joggler should be connected to LMS.

I discovered this solution today. I had the LMS problem after changing to Amazon Eero mesh wi-fi, which was painless, other than losing LMS connectivity to my Joggler. Devices choose their own connection frequency (2.4 GHz or 5 GHz) but they all appear as the same network, and it's not easily distinguishable which band is being used. The Eero app on my phone allows me to turn off 5 GHz for 10 mins. My Pi was on 5 GHz but once I'd deactivated that frequency and connected the Pi to the network again, now only broadcasting in 2.4 GHz, I followed the steps in the previous paragraph.

Now sorted and very happy.
gegs
Posts: 1146
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by gegs »

The new BBC Sounds plugin on LMS works well with the Joggler and a USB soundcard, but not before editing /etc/asound.conf - if you don't, you'll get an unsupported sample rate error. BBC Sounds broadcasts at 320kbps and 48kHz.

Change the sample rate in /etc/asound.conf from 44100 to 48000 (44.1kHz to 48kHz) and it works wonderfully.
Man in a van
Posts: 315
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by Man in a van »

Thanks for the tip gegs ;)

and here is another

viewtopic.php?p=32469#p32469
User avatar
mickchip
Posts: 408
Joined: Thu Apr 14, 2011 7:06 am
Location: Handforth, Cheshire, UK

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by mickchip »

Should this still be working.
wget https://birdslikewires.net/download/ope ... install.sh
chmod +x ./sqpinstall.sh
sudo ./sqpinstall.sh

I get
PS C:\Users\mickc> ssh joggler@192.168.1.246
joggler@192.168.1.246's password:
Linux joggletop 2.6.31-20-generic #58 SMP Wed Apr 14 02:29:59 CEST 2010 i686

To access official Ubuntu documentation, please visit:
http://help.ubuntu.com/

Last login: Tue May 4 01:18:09 2010 from ascs-computer.config
joggler@joggletop:~$ wget http://birdslikewires.net/download/open ... install.sh
--2020-11-28 12:04:59-- http://birdslikewires.net/download/open ... install.sh
Resolving birdslikewires.net... 5.135.163.72, 2001:41d0:8:e648::1
Connecting to birdslikewires.net|5.135.163.72|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://birdslikewires.net/download/ope ... install.sh [following]
--2020-11-28 12:04:59-- https://birdslikewires.net/download/ope ... install.sh
Connecting to birdslikewires.net|5.135.163.72|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2020-11-28 12:05:02 ERROR 404: Not Found.

joggler@joggletop:~$
Jogglermaniac
Post Reply