24/96 Squeezeplay and External USB DAC

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
bencat
Posts: 24
Joined: Wed Jun 11, 2014 7:47 am

Re: 24/96 Squeezeplay and External USB DAC

Post by bencat »

Just to update I tried a passive hub which worked as an extender on my PC but doe not show up using the joggler . On the Musical Fidelity it shows that there is power and that it has a lock on the device but it still shows as (info) item with the following showing on the page (would attach a photo of the screens but not able to make the files small enough to be accepted.

Top Line - USB AUDIO - Musical Fidelity V-Link 192

Status : Stop
Speed : High
Connection : Via Hub
Type : Async
Format :S32_LE
Rates : 44100,48000,88200,96000,176400,192000

Does anyone have an idea how I can get this to work ? I did try a clean install of Squeezeplay and used the Audio Setting / Interface / External Direct but that failed as it kept saying no response on USB 4 there were other lines but they moved off the page too quick to read . So I have reloaded Squeezeplayer and EDO but still getting the same issue .
Man in a van
Posts: 341
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: 24/96 Squeezeplay and External USB DAC

Post by Man in a van »

Which Squeezeplay install are you using Andrew ?
bencat
Posts: 24
Joined: Wed Jun 11, 2014 7:47 am

Re: 24/96 Squeezeplay and External USB DAC

Post by bencat »

Hi Ronnie as I use Max2play Distro they have their own which is showing as the following

Squeezelite Max2Play v1.0.3 based on 1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph
Man in a van
Posts: 341
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: 24/96 Squeezeplay and External USB DAC

Post by Man in a van »

Which Squeezeplay version on the Joggler, Andrew?
bencat
Posts: 24
Joined: Wed Jun 11, 2014 7:47 am

Re: 24/96 Squeezeplay and External USB DAC

Post by bencat »

According to the player it is 7.7.2-r9710
Man in a van
Posts: 341
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: 24/96 Squeezeplay and External USB DAC

Post by Man in a van »

Sorry :oops:

I meant, is it
sqpos 303
bionic 5.4
or
bionic 3.16


ronnie
bencat
Posts: 24
Joined: Wed Jun 11, 2014 7:47 am

Re: 24/96 Squeezeplay and External USB DAC

Post by bencat »

Okay Ronnie bionic 5.4 but to be honest I am not able to get this working at all so may well be reverting to bionic 3.16
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: 24/96 Squeezeplay and External USB DAC

Post by Heuer »

Just updated my Joggler to Bionic 5.4 and Squeezeplay all works. I then installed the EDO patch which was succesful but the Joggler reboots to squeezeplay@openframe:/$ and I can't get it to move on from there.

Any idea?
Man in a van
Posts: 341
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: 24/96 Squeezeplay and External USB DAC

Post by Man in a van »

bencat wrote: Wed Mar 31, 2021 4:26 pm Okay Ronnie bionic 5.4 but to be honest I am not able to get this working at all so may well be reverting to bionic 3.16
OK Andrew, thanks
Man in a van
Posts: 341
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: 24/96 Squeezeplay and External USB DAC

Post by Man in a van »

Heuer wrote: Wed Mar 31, 2021 5:59 pm Just updated my Joggler to Bionic 5.4 and Squeezeplay all works. I then installed the EDO patch which was succesful but the Joggler reboots to squeezeplay@openframe:/$ and I can't get it to move on from there.

Any idea?
I think it's a bug, or just doesn't work, I get the same

I mean to check if the target is at the end of the same install path as in SQPOS-303

ronnie
bencat
Posts: 24
Joined: Wed Jun 11, 2014 7:47 am

Re: 24/96 Squeezeplay and External USB DAC

Post by bencat »

Ronnie thanks for your help I have as I put on the Wam reverted to SQPOS-303 and used EDO . With a passive Hub I have managed to get it working and there is now music through the MF unit and it sounds really good . Have updated the second player in the same way and will keep that safe in case there are any issues.

@Wilberforce if you are reading any of this and you have the time and inclination it would be nice if the EDO could be made to work with the Bionic Ubuntu set ups as they are the ones that will be updated etc going forward. I know it only audiofools such as myself that are bothered but it is nice to have as an option .

So as always lots of head scratching , brilliant help and advice and another Joggler back in harness and still working .
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: 24/96 Squeezeplay and External USB DAC

Post by Heuer »

Yes, SQPOS-303 works with EDO but not if you are using the latest version of LMS, unless you edit a file. If you use the (very buggy IMHO) Bionic images they cause all sorts of problems. I have had a Bionic Joggler kill LMS twice after trying to connect and that requires a Win10 reboot to fix. EDO causes the drop back to command prompt, certainly when I connect/re-connect an ethernet cable. Unable to get WiFi working and for some reason I cannot edit the /boot/network.yaml file as permission is refused even after CHMOD command. I gave up and installed the Jivelite for Joggler image which works as a SB controller or you can switch on Squeezelite and USB to a DAC. Primetime ready and never falls over, superb work by Chill! Anyone know whether EDO works with Squeezelite on the Joggler?

On another note I compared a Joggler/Squeezelite/Topping E30 DAC to an SB3/Topping DAC E30 and the sound of the latter was much better than the former which was more subdued, and frankly I will stick with the SB3 and use Joggler as control/artwork.
Post Reply