PnP III v3.50: Enhance the standard OS - DOWNLOAD HERE!

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
Post Reply
sharpharp
Posts: 13
Joined: Sat Aug 13, 2011 11:14 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by sharpharp » Sat May 19, 2012 4:35 pm

Hi all,

First of all, managed to get PnPIII on my joggler.

But after everything has loaded I cannot get on the internet via Wired ethernet, anyone else have this problem?
Any ideas? Was working fine when I flashed the original o2 image onto it via the birdsonawire links.

Tried rebooting the joggler a few times, still no joy,

pukington
Posts: 37
Joined: Fri Aug 12, 2011 10:53 pm
Contact:

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by pukington » Sat May 19, 2012 5:39 pm

Read this thread, its been mentioned many times, you need to manually setup your network and disable dhcp.

Edit:

Or read the thread below the one your reading now:

http://www.jogglerwiki.com/forum/viewto ... ?f=2&t=571

Sherbet66
Posts: 6
Joined: Sat May 19, 2012 8:46 am

Re: Telnet/SSH connection issue (post PnP III)

Post by Sherbet66 » Sat May 19, 2012 6:09 pm

psul wrote:
Sherbet66 wrote:Hi,

I've upgraded to PnP II and although network connection is up and running and I'm able to connect to the web server I've found that Telnet is not working and SSH halts at the password prompt (will not allow password input at all, although it accepts user name, I'm using Putty). Can anyone advise on how to connect via SSH?

Many thanks

Dave

Had the same thing myself.
Thought I was going mad but after about 5 goes it accepted the password. I'm convinced I wasn't entering it incorrectly yet each time I typed the password and pressed enter it just asked for password again.


By the way connect and play now working perfect again.
really think PnP III has made joggler better than ever!
Figured this out,

" SSH, SCP (username: letmeinssh password: joggler1234) will be enabled in addition to Telnet (username: root)."

I tried the Telnet login "root" on the SSH connection and it worked, not sure why but if the letmeinssh doesn't work give the Telnet on a try.

danjog2
Posts: 60
Joined: Fri Mar 04, 2011 12:01 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by danjog2 » Sat May 19, 2012 6:35 pm

offbeatdave wrote:
danjog2 wrote:Thanks Dave, just upgraded two jogglers to PnP III without very much fuss. I got confused by the absence of an internet connection at first, but setting a fixed IP sorted it all out. Connect & Play which is the primary use of the Jogglers is now working nicely.

How tricky is it to create an image of one of my jogglers so I can use that instead of the Birdslikewires image to reflash if I have problems later?
This has worked well for me in the past. http://www.jogglerwiki.com/wiki/Frequen ... _System.3F
Many thanks - should have looked in the wiki :shame

sharpharp
Posts: 13
Joined: Sat Aug 13, 2011 11:14 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by sharpharp » Sat May 19, 2012 6:55 pm

Tried the manual settings and can get this:

"Somethings gone wrong. You have successfully obtained an IP address but cannot connect to the Internet...."

Any ideas? Any settings, wireless name, IP, password, dns, gateway all correct and even connects ok with excellent signal. But when running up Opera or any web type app, no joy...

My wireless router is setup as wpa2-psk, would that have anything to do with it? the joggler has options to pick wpa2, but only TYPES available are AES or TKIP, would that be the problem????

User avatar
offbeatdave
Posts: 1037
Joined: Wed Mar 09, 2011 10:43 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by offbeatdave » Sat May 19, 2012 7:24 pm

Mine is running with wpa2. I sometimes get that message setting up, but a reboot usually does the trick..
"EVERY DAY I'M JOGGLERING!"
Jogglering since Dec '09;
Tinkering with Jogglers since Feb '10 thanks to PMJ, Jogtools, PnP & sqpOS;
Gave something back Feb '12 to Apr '14 with PnP Mk II & PnP III;
Finally 'completed' PnP III Apr '15!

Sherbet66
Posts: 6
Joined: Sat May 19, 2012 8:46 am

SSH & Telnet not working

Post by Sherbet66 » Sun May 20, 2012 10:00 am

I've installed version 3.032 and lost SSH & Telnet now, this is generating a connection refused error with Putty. I've tried a variety of ports but no joy. Anyone else experiencing this or can offer a fix?

Cheers,

Dave

paddymcn
Posts: 1
Joined: Sun May 20, 2012 3:42 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by paddymcn » Sun May 20, 2012 3:46 pm

Installed v3.030 and loving it, thanks everyone especially offbeatdave and pukington, excellent work :-)

User avatar
offbeatdave
Posts: 1037
Joined: Wed Mar 09, 2011 10:43 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by offbeatdave » Sun May 20, 2012 4:55 pm

paddymcn wrote:Installed v3.030 and loving it, thanks everyone especially offbeatdave and pukington, excellent work :-)
Glad to hear it!
"EVERY DAY I'M JOGGLERING!"
Jogglering since Dec '09;
Tinkering with Jogglers since Feb '10 thanks to PMJ, Jogtools, PnP & sqpOS;
Gave something back Feb '12 to Apr '14 with PnP Mk II & PnP III;
Finally 'completed' PnP III Apr '15!

julzgeraghty
Posts: 11
Joined: Tue May 01, 2012 7:41 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by julzgeraghty » Sun May 20, 2012 5:33 pm

Hi,
Just to say thanks, I got my 2 jogglers working on PNP3 quite easily once I worked out the DHCP issue.
Thanks for pulling all this together.
Julian

User avatar
offbeatdave
Posts: 1037
Joined: Wed Mar 09, 2011 10:43 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by offbeatdave » Sun May 20, 2012 5:37 pm

julzgeraghty wrote:Hi,
Just to say thanks, I got my 2 jogglers working on PNP3 quite easily once I worked out the DHCP issue.
Thanks for pulling all this together.
Julian
No problem!
"EVERY DAY I'M JOGGLERING!"
Jogglering since Dec '09;
Tinkering with Jogglers since Feb '10 thanks to PMJ, Jogtools, PnP & sqpOS;
Gave something back Feb '12 to Apr '14 with PnP Mk II & PnP III;
Finally 'completed' PnP III Apr '15!

darrenkellum
Posts: 35
Joined: Thu May 19, 2011 11:40 am

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by darrenkellum » Sun May 20, 2012 6:08 pm

Hi
Whenever I user this on a cleaned (non updated) joggler, the joggler reboots but only has a few icons displayed. Do you know why or how I can make them all display without having to do a full clean again. I've tried twice now.

thanks
Darren

User avatar
offbeatdave
Posts: 1037
Joined: Wed Mar 09, 2011 10:43 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by offbeatdave » Sun May 20, 2012 6:11 pm

If it's a non-updated one (i.e. blue o2 icons) are you booting with the USB stick in (you should be)? What icons are you left with?
"EVERY DAY I'M JOGGLERING!"
Jogglering since Dec '09;
Tinkering with Jogglers since Feb '10 thanks to PMJ, Jogtools, PnP & sqpOS;
Gave something back Feb '12 to Apr '14 with PnP Mk II & PnP III;
Finally 'completed' PnP III Apr '15!

darrenkellum
Posts: 35
Joined: Thu May 19, 2011 11:40 am

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by darrenkellum » Sun May 20, 2012 6:15 pm

offbeatdave wrote:If it's a non-updated one (i.e. blue o2 icons) are you booting with the USB stick in (you should be)? What icons are you left with?
Hi
Well i put all the files on the memory stick for pnpIII, stuck it in the joggler and booted. It did its stuff, then rebooted only with a few icons displayed. left with games, tools, dilbert, maps (on page 1) then Checkers, five in a row and swf launcher on page 2

User avatar
offbeatdave
Posts: 1037
Joined: Wed Mar 09, 2011 10:43 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by offbeatdave » Sun May 20, 2012 6:21 pm

weird. Can only suggest to try again from scratch.
"EVERY DAY I'M JOGGLERING!"
Jogglering since Dec '09;
Tinkering with Jogglers since Feb '10 thanks to PMJ, Jogtools, PnP & sqpOS;
Gave something back Feb '12 to Apr '14 with PnP Mk II & PnP III;
Finally 'completed' PnP III Apr '15!

darrenkellum
Posts: 35
Joined: Thu May 19, 2011 11:40 am

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by darrenkellum » Sun May 20, 2012 6:23 pm

yeah its weird, ok will just try again, thanks

papaiannis
Posts: 63
Joined: Tue May 15, 2012 9:53 pm

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by papaiannis » Sun May 20, 2012 10:06 pm

I need to mount a remote share on my Joggler running the native OS + PnP III.
Unfortunately I am not able to mount neither NFS shares nor samba/cifs shares.
I tried to install the nfs-common package but, with surprise, I found that apt-get and dpkg are not available.

How can I mount a NFS (or samba) share on my Joggler?

Sherbet66
Posts: 6
Joined: Sat May 19, 2012 8:46 am

Re: SSH & Telnet not working

Post by Sherbet66 » Mon May 21, 2012 7:06 am

Sherbet66 wrote:I've installed version 3.032 and lost SSH & Telnet now, this is generating a connection refused error with Putty. I've tried a variety of ports but no joy. Anyone else experiencing this or can offer a fix?

Cheers,

Dave
I take it that the update in May prevented scripts running from usb? If so then I'm stumped on how to connect to the joggler.....

Pandobear
Posts: 1
Joined: Mon May 21, 2012 7:48 am

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by Pandobear » Mon May 21, 2012 7:52 am

I updated a number of my Jogglers with the 3.032 yesterday, all working fine without DHCP. this morning two of them are sat at the O2 screen, and will not boot. The other two are still running fine. Have O2 pushed another update? Is the 'anti-update' patch installed with Pnp III? and if not, is it worthwhile including?

I should say, I have install the last Open peak patched software as a base from the flash image that they supplied (now taken down), before it was taken down, and then the Pnp III from telnet, so all Jogglers should be the same

Much appreciated, thanks

njogglern
Posts: 1
Joined: Mon May 21, 2012 9:16 am

Re: PnP III for pre/post OpenPeak update Jogglers - Get it h

Post by njogglern » Mon May 21, 2012 9:24 am

Hi - I've just registered and wanted to say thanks for the PnP III. I finally decided to go for it yesterday evening and am glad I did. At one point, it looked like everything stalled but then the script started moving again.....at the end, there was another scare where it mentioned it had lost connection. But I just sat watching the clock for what seemed like a few minutes before it rebooted.....and voila, everything was there - thanks!

I also had the same problem with date and time, but I set up my ip address as advised and changed the clock server address (forgot the correct name for this as I type) and as soon as I did that, the correct time was picked up. Internet connectivity is present and the connect and play works great with my NAS drive too. Oh and everyone is happy to see the o2 clock back again, and I do like the bbc 2 black and orange clock...so cool, only if it had a date on it somewhere.

The only thing we now miss, is the texting capability which we used often, but that aside, this is a great update you have made, much appreciated!!!

Post Reply