Debian Bookworm for OpenFrame

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
stripwax
Posts: 19
Joined: Sun Dec 29, 2019 12:51 pm

Re: Debian Bookworm for OpenFrame

Post by stripwax »

Paul Webster wrote: Wed Oct 18, 2023 5:10 pm I couldn't reboot from there because of the issue that the Polkit update has resolved and I didn't want to simply pull the plug ... so I ssh'd in and did a reboot from there.
In any case - I think it would be useful to have Relaunch in SqueezePlay again.
You could make the polkit change yourself (its just a file you can create, after ssh'ing in). But that would enable Reboot and Shutdown (not Relaunch; but Reboot is probably just as good as Relaunch?)
Paul Webster
Posts: 155
Joined: Mon Jul 18, 2011 7:56 am

Re: Debian Bookworm for OpenFrame

Post by Paul Webster »

Yep - have just done it and it works.
Paul Webster
Posts: 155
Joined: Mon Jul 18, 2011 7:56 am

Re: Debian Bookworm for OpenFrame

Post by Paul Webster »

Ah ... nearly works ...
reboot works great - but SqueezePlay or OS has not saved its settings change so when it reboots I am still on the previous audio setting.

All very odd.
On reboot SqueezePlay UI said that it was set to External Direct - but audio was still coming out from the audio socket and nothing from USB.

So I changed it to Internal Direct and then back to External Direct ... then from ssh did a couple of "sync" (just in case) and then initiated a reboot from SqueezePlay ... and this time USB audio was working.
Man in a van
Posts: 483
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bookworm for OpenFrame

Post by Man in a van »

@Paul Webster

This may be useful?


viewtopic.php?p=33585#p33585

ronnie
Paul Webster
Posts: 155
Joined: Mon Jul 18, 2011 7:56 am

Re: Debian Bookworm for OpenFrame

Post by Paul Webster »

I think I read that someone had been using Squeezeplay and after a while it dropped back to command line on Joggler screen.
I now have this after a few minutes of playing one particular radio station (Pepper 96.6 in Greece).
I'll do some more digging to try to find out what is going on.
First thing to note - it drops me into an interactive terminal session that is logged in as squeezeplay
I plugged in a keyboard via USB hub and can use it.

So I tried initiating X from a different terminal session to see if an errors appear and started playing the station again.
After about 5 minutes it went down again and I saw this at the other terminal session

"double free or corruption (out)
/opt/squeezeplay/bin/squeezeplay.sh: line 87: 19920 Aborted ./jive"
Man in a van
Posts: 483
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bookworm for OpenFrame

Post by Man in a van »

I have experienced the
First thing to note - it drops me into an interactive terminal session that is logged in as squeezeplay
This mostly seems to happen when I try to configure a dac as "External [Direct] and Squeezeplay does not recognise the dac.

Changing the dac resolves the issue.


I don't (IIrc) have any issues with installing Ralphy's Squeezeplay (which saves a lot of space on the memory).

This would be my default Squeezeplay but I can not (no matter what I have tried) get Album Art to appear in a consistent manner.

This means I return to building Jivelite :) :roll:

ronnie
Paul Webster
Posts: 155
Joined: Mon Jul 18, 2011 7:56 am

Re: Debian Bookworm for OpenFrame

Post by Paul Webster »

I have been able to make it exit a lot ... too many times to be able to switch to SqueezePlay on Bookworm - this is because I am using it on my desktop as the primary test player when I am adding new stations to "Radio Now Playing".

Can someone else confirm that it exists for them as well?

If it does not ... then maybe we can work out what the differences are in configuration to try to narrow down on the underlying problem and then, hopefully fix it.
Stream to try (remove the spaces)
h t t p s : / / n 1 3 . r a d i o j a r . c o m / p e p p e r . m 4 a
Man in a van
Posts: 483
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bookworm for OpenFrame

Post by Man in a van »

Paul Webster wrote: Fri Oct 20, 2023 11:46 am I have been able to make it exit a lot ... too many times to be able to switch to SqueezePlay on Bookworm - this is because I am using it on my desktop as the primary test player when I am adding new stations to "Radio Now Playing".

Can someone else confirm that it exists for them as well?

If it does not ... then maybe we can work out what the differences are in configuration to try to narrow down on the underlying problem and then, hopefully fix it.
Stream to try (remove the spaces)
h t t p s : / / n 1 3 . r a d i o j a r . c o m / p e p p e r . m 4 a
Joggler connected via wireless to the network Bookworm

Playback through a usb dac into headphones [External Direct]


Logitech Media Server Version: 8.4.0 - 1697730330 @ Thu 19 Oct 2023 06:00:47 PM CEST

Streaming mode for HTTP(S) Persistent mode


File Format: AAC
Sample Rate: 44.1 kHz
URL: https://n12.radiojar.com/pepper.m4a?rj- ... EMHFPQu7iw
Date Modified: Friday, October 20, 2023, 1:00 PM
Title: PEPPER 966
Played for 35 minutes with just a slight pause at 3/4 minutes for rebuffering

No other problems; I enjoyed the advert for University of Central Lancashire (campus in Larnaca, Cyprus, apparently :) )

Will try again tomorrow

ronnie
Paul Webster
Posts: 155
Joined: Mon Jul 18, 2011 7:56 am

Re: Debian Bookworm for OpenFrame

Post by Paul Webster »

One big difference then ... I have added that station into RNP ... so when it plays here there are also track titles and cover art.
However, other stations that RNP provides info for do work.

If you have the beta of RNP then would be good if you could try it via that. I will include it in the next beta build tomorrow.

Edit:
beta 0.0.39f now available with this station included
Man in a van
Posts: 483
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bookworm for OpenFrame

Post by Man in a van »

Early days yet :)

One brief rebuffer but seems quite good, some tracks have album art, some dont (might just be an early streaming glitch)

Image

Image

Image


File Format: AAC
Sample Rate: 44.1 kHz
URL: https://n07.radiojar.com/pepper.m4a?rj- ... SnqeDBkobA
Date Modified: Saturday, October 21, 2023, 1:43 PM
Title: Blades
ronnie
Man in a van
Posts: 483
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bookworm for OpenFrame

Post by Man in a van »

@Paul Webster

There was another rebuffer during a Station advert / promotion

During this time, the screen retained the image of the last played track

After the station info the next track played through but the displayed info did not change

There was another Station ident, then the next track commenced and the meta date and album art updated

hope that helps

ronnie

I can't listen for very long today, will try again tomoorow, Display stuck on previous track info whilst playing new track

I will change the Network setting to "Cache", restart LMS and try tommorow
Paul Webster
Posts: 155
Joined: Mon Jul 18, 2011 7:56 am

Re: Debian Bookworm for OpenFrame

Post by Paul Webster »

Mine crashes out after a few seconds and yours hasn’t at all … so even if a couple of glitches I don’t think we are facing the same issue.

I’ll experiment with other LMS settings that I might have tweaked long ago.

I have a suspicion that it is not crashing for me when I play stations using MP3.
stripwax
Posts: 19
Joined: Sun Dec 29, 2019 12:51 pm

Re: Debian Bookworm for OpenFrame

Post by stripwax »

(From the Bullseye thread - about restarting startx.service - referring to the unit you get when doing the "of-install squeezeplay")
stripwax wrote: Thu Oct 12, 2023 12:15 am
Man in a van wrote: Wed Oct 11, 2023 12:10 pm I just hit Ctrl+C and it pops back :)
Yup, I spotted that too :-) seems ok. Glad the reboot/shutdown thing works for you too.
Ok so I think this is due to a mistake in the startx.service (and seeing the same on Bookworm).
The clue here was this:

Code: Select all

of@openframe:~$ sudo systemd-analyze
Bootup is not yet finished (org.freedesktop.systemd1.Manager.FinishTimestampMonotonic=0).
Please try again later.
Hint: Use 'systemctl list-jobs' to see active jobs
of@openframe:~$ sudo systemctl list-jobs
JOB UNIT                                 TYPE  STATE
90  systemd-update-utmp-runlevel.service start waiting
2   multi-user.target                    start waiting
114 getty@tty1.service                   start waiting
1   graphical.target                     start waiting
112 startx.service                       start running
111 getty.target                         start waiting
This is some time after bootup :-) nothing was waiting for anything, Squeezeplay was running fine at this point.
I think the service type is incorrect:

Code: Select all

# /usr/lib/systemd/system/startx.service
[Service]
Type=oneshot # <- change this to Type=simple instead
With that change:

Code: Select all

of@openframe:~$ sudo systemd-analyze
[sudo] password for of:
Startup finished in 4.914s (kernel) + 9.415s (userspace) = 14.329s
graphical.target reached after 9.049s in userspace.
And, of course, this now works without requiring Ctrl+C:

Code: Select all

sudo systemctl restart startx.service
Man in a van
Posts: 483
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bookworm for OpenFrame

Post by Man in a van »

@Paul Webster

I have changed the LMS Streaming mode for HTTP(S) to Normal streaming

I also changed the Joggler output to the buld in speaker "internal [Direct]"

I have been playing it for about an hour or so now, with just a couple of short pauses for a little rebuffer.

The following behavior is observed on the joggler screen when there is a long Station ident/promo/advert break

Track playing ceases at count up 3:34 > advert/promo > 6:25 new track > a second or two > station ID > then album art and new count up begins

That's it for today :)

ronnie
Man in a van
Posts: 483
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bookworm for OpenFrame

Post by Man in a van »

@stripwax

Thanks for tip, can confirm it works

of@openframe:~$ sudo nano /usr/lib/systemd/system/startx.service
[sudo] password for of:
of@openframe:~$ sudo systemctl restart startx.service
Warning: The unit file, source configuration file or drop-ins of startx.service changed on di sk. Run 'systemctl daemon-reload' to reload units.
^C
of@openframe:~$ sudo systemctl daemon-reload
of@openframe:~$ sudo systemctl restart startx.service
of@openframe:~$

ronnie
Paul Webster
Posts: 155
Joined: Mon Jul 18, 2011 7:56 am

Re: Debian Bookworm for OpenFrame

Post by Paul Webster »

Man in a van wrote:@Paul Webster

I have changed the LMS Streaming mode for HTTP(S) to Normal streaming

I also changed the Joggler output to the buld in speaker "internal [Direct]"

I have been playing it for about an hour or so now, with just a couple of short pauses for a little rebuffer.

The following behavior is observed on the joggler screen when there is a long Station ident/promo/advert break

Track playing ceases at count up 3:34 > advert/promo > 6:25 new track > a second or two > station ID > then album art and new count up begins

That's it for today :)

ronnie
Thanks Ronnie. Please do resume your normal listening. I’m still trying to work out why mine exits. I think I’ll work out how to enable logging in SqueezePlay to see if I can spot something.
fanshawe
Posts: 13
Joined: Fri Jul 29, 2022 9:40 am

Re: Debian Bookworm for OpenFrame

Post by fanshawe »

Hi all - I reinstalled Debian on my joggler today using the new (to me) Bookworm image. I'm happy to report that it worked with hardly any manual intervention from me, CLI wise. The only thing I had to do was to reinstall the 'passwd' package in order to change the password, as it was failing with the 'Authentication token manipulation error'. I also added a swap file although I'm not sure that's really necessary.
Thanks to all involved for making this such a great OS for the Joggler!
Paul Webster
Posts: 155
Joined: Mon Jul 18, 2011 7:56 am

Re: Debian Bookworm for OpenFrame

Post by Paul Webster »

I just did a update & upgrade & reboot ...
and now Joggler boots into login prompt rather than automatic load of X and Squeezeplay.

Any clues about where I should look to fix it?

Edit:
sudo systemctl status startx.service
shows
/usr/lib/xorg/Xorg.wrap: Only console users are allowed to run the X server
xinit: giving up

Edit2:
I worked around it by editing
/etc/X11/Xwrapper.config

and changing
allowed_users=console
to
allowed_users=anybody

however, I suspect that this is not the correct solution as, for now at least, while I do have the interface up and touch screen working ... I have no audio.

Edit3:
changed audio setting from "Internal (Direct)" to "Internal (Mixer)" then reboot .... and I have audio again.
So I assume something else had grabbed that audio and now have to share it.
golvellius
Posts: 5
Joined: Sat Sep 03, 2011 9:57 pm
Location: SPAIN ( Castellon )

Re: Debian Bookworm for OpenFrame

Post by golvellius »

Hi ..

I have installed latest version of Debian Bookworm + Xfce4 + firefox. I am trying to use it as a homeassistant screen controller .. everything works perfect. To install Xfce4 i have to wait a lot , also to install firefox... It was amazing to use my old joggler to control homeassistant lights ...

The question is .. I want to have in xfc4 control of the screen, i mean when the screen is 5 minutes without using it .. screen should be switched off .. How can i enable this ..?
I have tried to install Xfce4 Power Management, but is not working ...

Best regards.
golvellius
Posts: 5
Joined: Sat Sep 03, 2011 9:57 pm
Location: SPAIN ( Castellon )

Re: Debian Bookworm for OpenFrame

Post by golvellius »

Update ..
I see that the screen after a period of time it will be switch off.
What i do not know if this happens in the basic installation or after i have installed squeezeplay..(with parameter of-install) .
I have installed Xfce4 manually with apt ..

i have attached image of my system...
Homeassistant image
Homeassistant image
Now i have a screen to control all my lights with homeassistant.

Thanks and sorry.

golvellius wrote: Sat Dec 30, 2023 2:57 am Hi ..

I have installed latest version of Debian Bookworm + Xfce4 + firefox. I am trying to use it as a homeassistant screen controller .. everything works perfect. To install Xfce4 i have to wait a lot , also to install firefox... It was amazing to use my old joggler to control homeassistant lights ...

The question is .. I want to have in xfc4 control of the screen, i mean when the screen is 5 minutes without using it .. screen should be switched off .. How can i enable this ..?
I have tried to install Xfce4 Power Management, but is not working ...

Best regards.
Post Reply