SqueezePlay for OpenFrame

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
proddick
Posts: 11
Joined: Fri Feb 22, 2013 10:59 am

Re: SqueezePlay for OpenFrame

Post by proddick »

I decided (at last!) to upgrade a few of my Jogglers to this and am having major issues running it on internal storage with any of them - crashes, disk errors, etc.

Is it likely that *all* have failed or could it be something else? It works fine from USB, but not as convenient.

Also, is there any way to check wireless signal? I tried installing a few packages but most ended up crashing the system - I guess not compatible?
proddick
Posts: 11
Joined: Fri Feb 22, 2013 10:59 am

Re: SqueezePlay for OpenFrame

Post by proddick »

I think the OS updates broke my previous attempts with 3.16 so have tried again...

I built a new USB stick with 3.16 and installed Squeezeplay but no updates. I had it connected on Ethernet and it worked for an hour or so and then Squeezeplay crashed to the CLI. Testing again now...
jogglerhase
Posts: 172
Joined: Wed Aug 08, 2012 3:02 pm

Re: SqueezePlay for OpenFrame

Post by jogglerhase »

proddick wrote: Mon Sep 20, 2021 6:02 pm I think the OS updates broke my previous attempts with 3.16 so have tried again...

I built a new USB stick with 3.16 and installed Squeezeplay but no updates. I had it connected on Ethernet and it worked for an hour or so and then Squeezeplay crashed to the CLI. Testing again now...
I see something similar - see my earlier post:
"I experienced some rare random crashes of the Jogglers GUI & Squeezeplay (no, sound, screen shows no Gui, only the std. promt; screen still reacts on touch and the access point functionality I set up for my Joggler also still works). Crashes mostly happend when listening to a playlist and one song ends and the next starts. I 1st thought its the aging USB drive, but error replicates on different USB stick as well.
I am not sure what causes this, however, since reverting back from LMS8.3 to LMS8.2 (and changing LMS settings to proxied streaming for the Joggler) seems to have fixed it"
-> Try LMS8.2 and / or proxied streaming for the Joggler (LMS settings - Player Tab - Joggler - Audio - Streaming method)
User avatar
roobarb!
Posts: 1724
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: SqueezePlay for OpenFrame

Post by roobarb! »

proddick wrote: Mon Sep 20, 2021 6:02 pmI built a new USB stick with 3.16 and installed Squeezeplay but no updates.
Do you mean updates to SqueezePlay itself? No, since compiling that last version there've been no other changes.

I must revisit the 3.16 image and update the packages though; as new kernels are no longer being released under that branch it no longer generates fresh image files. In the meantime you could try a good, old-fashioned:

Code: Select all

sudo apt update && sudo apt upgrade
That'll take a while on internal memory. Those flash ICs must be a little on the twitchy side as I've lost one recently too. Luckily it didn't need wifi, so I've just left a USB stick inside the Joggler which is much faster and more spacious.
birdslikewires.net - Upgrade your OpenFrame to Debian Bullseye with the latest 5.10 kernel! 8-)
Post Reply