Cannot connect to WiFi on SqueezePlay OS, please help!

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
JonB
Posts: 35
Joined: Fri Mar 04, 2011 12:17 pm

Cannot connect to WiFi on SqueezePlay OS, please help!

Post by JonB » Fri Apr 08, 2016 3:41 pm

Hi all

Per the title, I am not able to connect my Joggler to my wireless network in SqueezePlay OS. I keep getting the "No network address has been assigned to the Wireless interface (wlan0)" error.

I have followed the advice given in the SqueezeOS thread but none of it seems to work. My passphrase is long and randomly generated, contains many special characters and takes forever to enter, but I have done it repeatedly and got nowhere.

Some things I know:
  • I have the latest version of the OS (download as of today 8th April 2016). The website says it is "v3.03 for OpenFrame 1 Internal Memory".
  • No problems reflashing / booting
  • My Joggler can connect to my network (had it running one of the other distros before)
  • I am sure I have entered the SSID and passphrase correctly (and double checked them)
  • I am entering them in order and selecting "Accept changes and reboot"
Is there a way I can verify what SSID/passphrase I am using? Are they held in a config file somewhere? Can I enter them without using the touchscreen (into a config file)?
I am currently connected via wired ethernet and will try wireless again (roobarb said this usually works but I'm not hopeful - I did this before).
Anything else I can try?

Thanks
jonB

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Cannot connect to WiFi on SqueezeplayOS, please help!

Post by castalla » Fri Apr 08, 2016 3:47 pm

My advice - change your wifi password to something simple to enter - test. That way you can discover if it's a pass related issue.

You can always switch the router pass back to your 'paranoia' version!

You can edit the network interfaces file - do you know how to use winSCP ?

Man in a van
Posts: 284
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Cannot connect to WiFi on SqueezeplayOS, please help!

Post by Man in a van » Fri Apr 08, 2016 5:21 pm

castalla wrote:My advice - change your wifi password to something simple to enter - test. That way you can discover if it's a pass related issue.

You can always switch the router pass back to your 'paranoia' version!

You can edit the network interfaces file - do you know how to use winSCP ?
Plus 1 on keeping it simple.

I have had a similar problem this last week.

Re-flashed with OpenPeake and tested the wireless connection-everything fine.

Flashed the internal with SqPos and only the Ethernet would connect to my LMS.

Bizarrely, wireless would connect to Mysqueezebox.com without a problem.

I tried several new flashes before giving up and going to bed.

The next day I restarted the router and away we went with the wireless, no problem.

So my recommendation is to try the Openpeake and then re-start or reset the router.

atb

Ronnie.

JonB
Posts: 35
Joined: Fri Mar 04, 2011 12:17 pm

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by JonB » Fri Apr 08, 2016 6:10 pm

I have been using OpenPeak up till now, that's how I know it is working. But I suspect that the special characters in my passphrase are causing a problem (especially if there are shell scripts involved). I guess that is the question, is the OS coded to use shell scripts to update the <whatever file it is that stores the passphrase>? And can I configure it myself from the shell? Or, as I asked previously, what are the config files?

(PS, yes I can SSH into it when wired and I am competent with bash). :)

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by castalla » Fri Apr 08, 2016 6:32 pm

You can edit the following file:

/etc/network/interfaces

Mine only has wifi data for static (never use wired) :-

---------------------

auto lo
iface lo inet loopback

#auto wlan0


auto wlan0
iface wlan0 inet static
address 192.168.0.20
netmask 255.255.255.0
gateway 192.168.0.1
wpa-ssid SSID
wpa-psk passphrase

------------------------------------

The file has owner root group root. So best to edit it as root

User avatar
hawsey
Posts: 1938
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by hawsey » Fri Apr 08, 2016 6:55 pm

I have just set up 3 Jogglers (thanks guys :-) all would not initially connect to wireless until I first plugged in to Ethernet and selected wired in the menus after first inputting the wireless details , give it 5 mins , switch to wireless in settings , re boot and give it a minute to connect , you are done , it will work now , this has been the case for every one and once done it works every time wirelessly ...hope this helps ,

Sent by SlimKat FirePhone
Happy Joggling

JonB
Posts: 35
Joined: Fri Mar 04, 2011 12:17 pm

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by JonB » Sat Apr 09, 2016 8:34 am

Thanks Hawsey

I tried it but no luck.

Have you got any special characters in your PSK like . ^ ~ { } [ ] ( ) ! , ?

Meanwhile, using instructions here http://askubuntu.com/questions/16584/ho ... n-terminal, I have manually enabled the wireless adapter, invoked wpa_supplicant and connected to my wireless network. The Joggler has two IP addresses in this setup, one for eth0 and the other for wlan0. This proves that the router and Joggler can connect (I am even SSH-ed into it via wireless and wired simultaneously).

But what next? How can I make this configuration stick? I suppose I could follow the "configure static IP address" approach linked to on birdslikewires.co.uk but I would really prefer it to work natively from the SqueezePlayer interface.

[EDIT: I tried configuring a static IP but it didn't work :( ]

User avatar
hawsey
Posts: 1938
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by hawsey » Sat Apr 09, 2016 9:43 am

No I've no special characters ,I would try again , plug in Ethernet , get connected ,then input your wireless details , save and reboot still on wired then on reboot switch to wireless and reboot again , having unplugged your Ethernet cable , it took me ages to get wireless connection and I suspect yours is the same issue ,
Good luck :-)

Sent by SlimKat FirePhone
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by castalla » Sat Apr 09, 2016 10:15 am

The only time I've seen a similar situation was when the Joggler was too far from the router, and the signal was weak.

Just a point - how far is the Joggler from the router ?

Also, if the terminal approach gets you running, why bother with the screen?

[I don't want to suggest that your typing skills are deficient, but if your pass is as complicated & as long as you say, then the occasionally 'sticky' screen can easily create a mis-type. ]

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by castalla » Sat Apr 09, 2016 10:19 am

@hawsey

Just noticed you're in N'land ..... It's my home county, too!

JonB
Posts: 35
Joined: Fri Mar 04, 2011 12:17 pm

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by JonB » Sat Apr 09, 2016 10:22 am

Hmm, I wonder if this could be the problem?

Code: Select all

-- the wpa supplicant won't tell you the keys, we need to parse them from the config file
function _readPSK(self, ssid)
        local param = _readWpaConfig(self, ssid)
        local psk = assert(param["psk"])

        -- remove quotes
        psk = string.match(psk, '^"(.*)"$') or psk
        return psk
end
This code is in SetupSqueezeboxApplet.lua appears to be reading the content of /etc/wpa_supplicant.conf, but stripping out some special characters from the PSK (which means - if I'm reading this code correctly - I will never, ever get it to work with my key and the native setup). So why is it removing special characters? My guess is it's invoking setup commands via the shell.

I can't be the only person using special characters in a PSK...

To answer your questions: Joggler is in range, that's why manual setup is successful. As to not using the screen to set it up, sure, but I don't know how to make my (manually configured) setup stick between boots (as I said before). Any advice?

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by castalla » Sat Apr 09, 2016 10:38 am

No idea about the applet.lua.

The easiest way is to change the router pass to something simple, eg. abcdefgh, or aaabbbcc, get connected,

Change the passphrase in /etc/network/interfaces

Reset router pass back to original

JonB
Posts: 35
Joined: Fri Mar 04, 2011 12:17 pm

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by JonB » Sat Apr 09, 2016 10:56 am

No chance, there are too many devices to update.

But I think I have succeeded by following these instructions: https://www.thefanclub.co.za/how-to/how ... ts-startup. The Squeezeplayer UI still thinks it is connected to the wired network, but the cable's not plugged in and it is working from WiFi.

:D

User avatar
hawsey
Posts: 1938
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by hawsey » Sat Apr 09, 2016 11:10 am

castalla wrote:@hawsey

Just noticed you're in N'land ..... It's my home county, too!
Success :-) that's great.
Castalla , where abouts ? I live in Bedlington now ( home of the strangely lamb like dog :-))

Sent by SlimKat FirePhone
Happy Joggling

JonB
Posts: 35
Joined: Fri Mar 04, 2011 12:17 pm

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by JonB » Sat Apr 09, 2016 11:16 am

Tip: To set the AirPlay name of your joggler (which comes up on the iOS device Airplay list), SSH to the Joggler and edit the file

Code: Select all

.squeezeplay/userpath/settings/Playback.lua
You are looking to change the value of the playerinit name setting as shown in bold below.

settings = {enableAudio=1,squeezeNetwork=false,serverUuid="c2e23096-8982-4327-b413-69fd2333633c",powerState="on",volume=40,serverInit={mac="00:08:9b:8c:52:f6",ip="10.0.1.2",},serverName="ChavNAS",playerInit={name="SqueezePlay",model="squeezeplay",},captureVolume=40,}

Alter "SqueezePlay" to your preferred name and reboot. This is handy if you have more than one Joggler on your network and you want to use Airplay.

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by castalla » Sat Apr 09, 2016 11:17 am

Well done.

I was only suggesting to change the router pass temporarily - this would only affect the Joggler - while you set it up.

But, you've found another way, so all's good!

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by castalla » Sat Apr 09, 2016 11:18 am

hawsey wrote:
castalla wrote:@hawsey

Just noticed you're in N'land ..... It's my home county, too!
Success :-) that's great.
Castalla , where abouts ? I live in Bedlington now ( home of the strangely lamb like dog :-))

Sent by SlimKat FirePhone
Originally ... Shiremoor

Man in a van
Posts: 284
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by Man in a van » Sat Apr 09, 2016 11:46 am

castalla wrote:
hawsey wrote:
castalla wrote:@hawsey

Just noticed you're in N'land ..... It's my home county, too!
Success :-) that's great.
Castalla , where abouts ? I live in Bedlington now ( home of the strangely lamb like dog :-))

Sent by SlimKat FirePhone
Originally ... Shiremoor

Spare me please!!!!!!!!!! :roll:

It'll be all whippets, clogs and flat 'ats from now on ;)

Ronnie who lives in Staffordshire, where the mugs come from :)

User avatar
hawsey
Posts: 1938
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by hawsey » Sat Apr 09, 2016 4:17 pm

Ha ha Ronnie , you are right , there are still a few flat cap and whippet men about , a dying breed now .
Shiremoor just down the road from me :-).

Sent by SlimKat FirePhone
Happy Joggling

joggly
Posts: 25
Joined: Wed Jun 26, 2013 3:59 pm

Re: Cannot connect to WiFi on SqueezePlay OS, please help!

Post by joggly » Sun Apr 10, 2016 10:17 pm

JonB wrote:No chance, there are too many devices to update.

But I think I have succeeded by following these instructions: https://www.thefanclub.co.za/how-to/how ... ts-startup. The Squeezeplayer UI still thinks it is connected to the wired network, but the cable's not plugged in and it is working from WiFi.

:D

interesting....what router do you have and how's DHCP set up? MAC filtering turned on?

Post Reply