Plex Media Server on the joggler

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Fri Apr 22, 2016 11:13 pm

I guess you are referring to

echo 'deb http://plex.r.worldssl.net/PlexMediaServer/ubuntu-repo lucid main' >> /etc/apt/sources.list.d/plexmediaserver.list

From what I can tell, the plex.r. server isn't working or doesn't exist !

On fact, I've no idea why his line is necessary

Did the dpkg line go okay - no errors

If so try the service start line

User avatar
hawsey
Posts: 1936
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Plex Media Server on the joggler

Post by hawsey » Fri Apr 22, 2016 11:20 pm

Sorry yes but it didn't work , so I backtracked and I noticed I hadn't re named my sources file to take the .txt off and rename to .list , I've done that now and ran the update and its worked now .
Thx

Sent by SlimKat FirePhone
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Fri Apr 22, 2016 11:23 pm

So - it seems to have installed okay?

I sthere an easy way to test it's working?

User avatar
hawsey
Posts: 1936
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Plex Media Server on the joggler

Post by hawsey » Fri Apr 22, 2016 11:40 pm

Not quite there yet ,using the link i previously posted it seemed to be installing but unfortunately i got an error "dependancy problems prevent installation of plexmediaserver " then something about avahi utils which i thought i already installed ....
Tomorrow is anouther day ;-)
Fresh head in the morning .
Thanks for all the help .
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Sat Apr 23, 2016 12:01 am

Hmm ... the old dependency hunt!

You could end up chasing your tail as you resolve one issue as another appears!

I tried a simulated install of avahi-utils - went okay, no errors.

I suspect it's all bound up with that huge package list - which you may need to install.

Nothng to lose - I'd copy that list carefully, then paste into putty and hit the return key. Wait until it finishes. Then run the dpkg again.

User avatar
hawsey
Posts: 1936
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Plex Media Server on the joggler

Post by hawsey » Sat Apr 23, 2016 8:25 am

SUCCESS 8-)

Thanks again everyone who has had input with this , you know who you are ...

So I did the avahi utils thing then went back to try and install plex using these instructions

Image

The mistake (or one of them ) I was making was the # at the front of each instruction was already there and I was just copy and pasting so once I dropped the # all went well .

I logged in to the newly installed PMS via the web server on my tablet and skipped sign in , my already mounted music folder came up and I pointed it to that .
At this point I left it working and went for some zzzzz .

This morning I installed the trial version of Plex app on my Android phone and all seems to be good , no skipping or freezing up of tracks .
One of the first things it said on my phone was plex server needs updated for certain features to work so this will probably be because of the old guide I used ; I will try and update that today if I can work out how , would the update all thing we did earlier work ?
I do need to try and access my stuff outside the house though , and will do that before buying the full version of the app .
Oh and the Squeeze play Os is still working on the same Joggler , I just checked that .

All looking good :-)

Cheers


Sent by SlimKat FirePhone
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Sat Apr 23, 2016 9:12 am

Excellent!

Oops I didn't even see the hash - it really just means 'type the following at the command line', that convention is not commonly used.

It's also used to indicate comment lines in scripts.

-----------------------------------------------------------

Updating - it should just work. To update you need a later plex file - see below for instructions, each on a new line

-----------------------------------------------------------

Code: Select all


service plexmediaserver stop

wget https://downloads.plex.tv/plex-media-server/0.9.16.4.1911-ee6e505/plexmediaserver_0.9.16.4.1911-ee6e505_i386.deb

dpkg - i plexmediaserver_0.9.16.4.1911-ee6e505_i386.deb

service plexmediaserver restart

-----------------------------------------------------------

The plex above is the latest (22 april 2016)

User avatar
hawsey
Posts: 1936
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Plex Media Server on the joggler

Post by hawsey » Sat Apr 23, 2016 9:56 am

Cheers :-)
painting kitchen today , will try at some point , thank you kindly sir .

Sent by SlimKat FirePhone
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Sat Apr 23, 2016 10:15 am

Enjoy! Need to do the same, but ......

User avatar
hawsey
Posts: 1936
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Plex Media Server on the joggler

Post by hawsey » Sat Apr 23, 2016 4:20 pm

It says I need 9.12.3 or newer so that will be fine :-)

A couple of photos of what's kept me from Joggling ...
My little helper ,
There's a Joggler in the kitchen , what am a gonna do ....
Revo corner

ImageImageImageImage
Back to Joggling

Sent by SlimKat FirePhone
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Sat Apr 23, 2016 4:26 pm

Yay! Good Job!

User avatar
hawsey
Posts: 1936
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Plex Media Server on the joggler

Post by hawsey » Sat Apr 23, 2016 9:05 pm

Chilling now .... when i do the update above , it works great until i get to the
dpkg - i plexmediaserver_0.9.16.4.1911-ee6e505_i386.deb
then i get

root@openframe:~# dpkg - i plexmediaserver_0.9.16.4.1911-ee6e505_i386.deb
dpkg: error: need an action option

Type dpkg --help for help about installing and deinstalling packages [*];
Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
root@openframe:~# dpkg - i plexmediaserver_0.9.16.4.1911-ee6e505_i386.deb
dpkg: error: need an action option

Type dpkg --help for help about installing and deinstalling packages [*];
Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
root@openframe:~#

did i mess up ?
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Sat Apr 23, 2016 10:12 pm

It should be: (you put a space after the - )


dpkg -i plexmediaserver_0.9.16.4.1911-ee6e505_i386.deb

----------------------------
Linux, eh!

----------------------------

Just got back from animal hospital .... knackered (problem solved)

User avatar
hawsey
Posts: 1936
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Plex Media Server on the joggler

Post by hawsey » Sat Apr 23, 2016 10:28 pm

Oh no ,I hope all is ok , was it your pet ?
That was it with the space :-) I just copy and pasted ha ha ;-) it must be obvious what I've done wrong to an expert , but I have not much of a clue with this stuff ..
Thanks

Sent by SlimKat FirePhone
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Sat Apr 23, 2016 10:38 pm

No - not an expert! Just spent hours fiddling. If things go really wrong then I'm clueless - usually start again from scratch.

So, are you all set up with Plex? Does it start automatically if you reboot?

-------------------------------------------------------------------------------------------

Pet dog (spaniel called Turron - which means marzipan in Spanish) had a sudden ear problem - needed to check it wasn't a grass spike down the ear (which can be difficult to extract if left). Seems it was a normal inflammation. Have to say vets here are more sympathetic than most of the doctors!

User avatar
hawsey
Posts: 1936
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Plex Media Server on the joggler

Post by hawsey » Sat Apr 23, 2016 10:51 pm

Hmmm I thought it had updated fine but now when I play a track I know worked before , I get . Media player error , re setting .
So I tried to stop then start plex media server using what I did before and it says .
plexmediaserver start/running ,process 3220.

Does that mean its still updating ? If so how do I know when its finished .

Thanks

Sent by SlimKat FirePhone
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Sat Apr 23, 2016 10:58 pm

No - it must have updated when you did the dpkg thing (no errors?). The message means it's working.

what does this do:


service plexmediaserver stop

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Sat Apr 23, 2016 11:03 pm

Could be that the latest plex is incompatble with ubuntu 14.

May need to try a earlier version.

User avatar
hawsey
Posts: 1936
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Plex Media Server on the joggler

Post by hawsey » Sat Apr 23, 2016 11:13 pm

It says
plexmediaserver stop/waiting
I will have a Google about and see if the latest is compatible .

Sent by SlimKat FirePhone
Happy Joggling

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: Plex Media Server on the joggler

Post by castalla » Sat Apr 23, 2016 11:17 pm

Try a reboot of Joggler.

That message seems a common error from mainly android users.

I suggest a new install of an earlier version - hang on I'll find a link

Post Reply