Android 4.04 build - now fully working!

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
User avatar
hawsey
Posts: 1877
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Android 4.04 build - now fully working!

Post by hawsey » Fri Sep 18, 2015 11:43 pm

He heh , I agree , that would be crazy :-)
, I think I have four on the go at the moment , kitchen , bedroom , summer house , plus a SeaBiosed betting shop one for pulling apart and generally abusing .
Happy Joggling

jaydee999
Posts: 47
Joined: Thu Oct 04, 2012 1:40 pm

Re: Android 4.04 build - now fully working!

Post by jaydee999 » Fri Sep 18, 2015 11:45 pm

Just tried booting android after installing OpenPeak internally. Loaded fine!

User avatar
hawsey
Posts: 1877
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Android 4.04 build - now fully working!

Post by hawsey » Sat Sep 19, 2015 8:21 am

Problem solved then ( sort of ) , so its the Sqpos internal install that is stopping the efi boot on the external USB .
Happy Joggling

jaydee999
Posts: 47
Joined: Thu Oct 04, 2012 1:40 pm

Re: Android 4.04 build - now fully working!

Post by jaydee999 » Sat Sep 19, 2015 4:12 pm

jaydee999 wrote:Just tried booting android after installing OpenPeak internally. Loaded fine!
OK, it loaded fine, and all seems well until I try to download any apps, whereupon I get the message "this browser is no longer supported", or "the website might be temporarily down or has been moved".

Any ideas what might have gone wrong?

jaydee999
Posts: 47
Joined: Thu Oct 04, 2012 1:40 pm

Re: Android 4.04 build - now fully working!

Post by jaydee999 » Sat Sep 19, 2015 5:16 pm

hawsey wrote:Problem solved then ( sort of ) , so its the Sqpos internal install that is stopping the efi boot on the external USB .
It would seem so.

gegs
Posts: 1142
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: Android 4.04 build - now fully working!

Post by gegs » Sat Sep 19, 2015 6:28 pm

jaydee999 wrote:
jaydee999 wrote:OK, it loaded fine, and all seems well until I try to download any apps, whereupon I get the message "this browser is no longer supported", or "the website might be temporarily down or has been moved".

Any ideas what might have gone wrong?
How are you trying to download your apps? I think the Google Play store is an old version at first, but it should update to the new one. Only apps compatible with the Joggler version of Android will appear in the Play store.

jaydee999
Posts: 47
Joined: Thu Oct 04, 2012 1:40 pm

Re: Android 4.04 build - now fully working!

Post by jaydee999 » Sat Sep 19, 2015 7:11 pm

gegs wrote:
jaydee999 wrote:
jaydee999 wrote:OK, it loaded fine, and all seems well until I try to download any apps, whereupon I get the message "this browser is no longer supported", or "the website might be temporarily down or has been moved".

Any ideas what might have gone wrong?
How are you trying to download your apps? I think the Google Play store is an old version at first, but it should update to the new one. Only apps compatible with the Joggler version of Android will appear in the Play store.
The only way I can see/know how to. Clicking on the browser "globe" icon. I works fine until I try to download any android apps, then I get those error messages.

User avatar
hawsey
Posts: 1877
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Android 4.04 build - now fully working!

Post by hawsey » Sat Sep 19, 2015 9:05 pm

You need to sign in to the play store which comes pre installed using a Google email address then it will update to the latest play store :-)
You can also install Aptoide app store but use this at your own risk lol .
Happy Joggling

User avatar
dwl99
Posts: 750
Joined: Fri Mar 04, 2011 7:38 am
Location: Glasgow

Re: Android 4.04 build - now fully working!

Post by dwl99 » Sun Sep 20, 2015 12:19 am

The preinstalled browser is rubbish and unfortunately Dolphin & Firefox aren't compatible with the Joggler. As Hawsey said just make sure you use Google Play to install any apps.

User avatar
hawsey
Posts: 1877
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Android 4.04 build - now fully working!

Post by hawsey » Sun Sep 20, 2015 8:39 am

I seem to remember apps showing up as not compatible is something to do with the build .prop or something like that , so the play store saying its not compatible isn't always true , there is also a site where previous versions of apps are available so you can try these too , I'll post back if I find the site .
Happy Joggling

gegs
Posts: 1142
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: Android 4.04 build - now fully working!

Post by gegs » Sun Sep 20, 2015 10:28 am

hawsey wrote:I seem to remember apps showing up as not compatible is something to do with the build .prop or something like that...
Does anybody have a working build.prop file for greater app compatibility? Android tweaking isn't something I'm familiar with and it would be good to use something proven to work.

jaydee999
Posts: 47
Joined: Thu Oct 04, 2012 1:40 pm

Re: Android 4.04 build - now fully working!

Post by jaydee999 » Sun Sep 20, 2015 10:34 am

Therein lies the problem. It says browser not supported, but when I click on the link that says use the Google Play Store app, that's when I get the error message about the site being down. I cant find any pre-installed app, either..........

User avatar
hawsey
Posts: 1877
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Android 4.04 build - now fully working!

Post by hawsey » Sun Sep 20, 2015 3:45 pm

I would re do your stick , and make sure you sign in at the start with a Google email, the built in app is called Market I believe but it will update to Play Store as soon as you use it .
Happy Joggling

User avatar
dwl99
Posts: 750
Joined: Fri Mar 04, 2011 7:38 am
Location: Glasgow

Re: Android 4.04 build - now fully working!

Post by dwl99 » Sun Sep 20, 2015 6:39 pm

hawsey wrote:I seem to remember apps showing up as not compatible is something to do with the build .prop or something like that , so the play store saying its not compatible isn't always true , there is also a site where previous versions of apps are available so you can try these too , I'll post back if I find the site .
That's right but even if you install some apps from a downloaded apk file they still crash, e.g Firefox, Chrome

User avatar
hawsey
Posts: 1877
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Android 4.04 build - now fully working!

Post by hawsey » Sun Sep 20, 2015 6:47 pm

Ahaa right Dave , I just found that out , so even if the build .prop was altered do you think they would still crash ?
I found this to edit it and it looks really easy but haven't tried it yet

https://m.reddit.com/r/Android/comments ... ke_netflix

Well I tried to do the above and messed up he heh , now I have no build . Prop file on my Joggler but funny enough Play store is still working even after re boots WTF so what does it do ? I've deffo deleted it ( don't ask lol)
Happy Joggling

User avatar
dwl99
Posts: 750
Joined: Fri Mar 04, 2011 7:38 am
Location: Glasgow

Re: Android 4.04 build - now fully working!

Post by dwl99 » Sun Sep 20, 2015 10:54 pm

Hmmm, you're probably going to have to do a reinstall - Google Play won't know what device you have without a build.prop file. You could copy the file from an existing installation (I could email you mine) but you would need to fix permissions for it to work. However, you've no doubt made a backup of your USB drive with Win32diskimager?

User avatar
hawsey
Posts: 1877
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Android 4.04 build - now fully working!

Post by hawsey » Mon Sep 21, 2015 11:15 am

Dwl99 , without the file there seems no difference , last night I was able to download apps , and they worked fine , the ones previously marked not compatible are just the same .
If things start going funny , I might need the file off you :-) .
No I didn't back up because I'm just messing at the moment ha.
Happy Joggling

gegs
Posts: 1142
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: Android 4.04 build - now fully working!

Post by gegs » Mon Sep 21, 2015 12:35 pm

hawsey wrote:No I didn't back up because I'm just messing at the moment ha.
I recommend backing up using Win32DiskImager when you get things to your liking (especially if you've resized partitions using Gparted.) I've had a stick fail on me because it had been abused, trashed and rewritten many times; I wrote the Android backup image to another stick and was up and running again in no time, with only some app updates to apply.

User avatar
dwl99
Posts: 750
Joined: Fri Mar 04, 2011 7:38 am
Location: Glasgow

Re: Android 4.04 build - now fully working!

Post by dwl99 » Mon Sep 21, 2015 1:32 pm

Yes, it's quite a smug feeling when you've done that! It has certainly saved my bacon a good few times.

mikeywilliams
Posts: 75
Joined: Fri Mar 04, 2011 5:23 pm

Re: Android 4.04 build - now fully working!

Post by mikeywilliams » Wed Sep 23, 2015 9:22 am

The joggler Android is working really well now the boot problem has been solved.
Using it as a baby monitor with Dlink and as a picture frame accessing my NAS.

Now a question about extending the partitions.
When I connect to my PC the 4Gb usb stick shows up as a 499Mb drive that I can access in Windows and send pictures etc to.
Looking at the usb with minitool partition wizard:

droid-user 499Mb FAT
droid boot 50Mb FAT
Android System 450Mb Ext4
Android data 1.02Gb Ext4
1.75Gb Unallocated

What is the best way to enlarge the droid-user partition?
The partition wizard has options for moving/resizing etc.
Would gparted be better and if so any tips for a linux noob please.

Post Reply