SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
User avatar
roobarb!
Posts: 1558
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by roobarb! »

goodlife wrote:
Fri Nov 02, 2018 11:29 pm
Should this still be working?
It should indeed. I'll need to check the paths being used.
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

Man in a van
Posts: 290
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by Man in a van »

Without more detail of your set up (plugin used, etc) perhaps this may help.

https://forums.slimdevices.com/showthre ... post937084

proddick
Posts: 8
Joined: Fri Feb 22, 2013 10:59 am

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by proddick »

I have eventually got round to fitting a Netgear WNDA3200 to one of my Squeezeplay Jogglers. Opening it up and fitting went far easier than I expected so I should have done a long time ago :-)

It works fine connecting to a 2.4Ghz WIFI (better than stock interface) but I can't connect to a 5Ghz one. Is this possible? Do I need to edit a file or something to enable dual-band?

plm
Posts: 14
Joined: Thu May 03, 2012 3:50 am

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by plm »

roobarb! wrote:
Mon Jan 23, 2017 11:55 pm
plm wrote:Is there an issue with the SqueezePlay repository at the moment? I just used the Update menu within SqueezePlay on a Joggler to see if there'd been any updates and it told me I was on version 1.60 but that version E.rr was available.

For anyone that thinks it's a good idea to try it - don't! I had a fat-finger moment and ended up inadvertently trying to install something that isn't there, and had to re-image my Joggler as a consequence.
This has been fixed now - turns out that when we moved the server, I didn't update the location of the database in the update script. Oops! It would only have affected people attempting to perform an update (as you describe) or if somebody was trying to install from scratch using the installation script.

Anyway, everything's back working properly now, so far as I can see!
Is this broken again? I just tried an update on a freshly-imaged Joggler and it couldn't connect to the update server.

User avatar
roobarb!
Posts: 1558
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by roobarb! »

plm wrote:
Sun Aug 04, 2019 12:29 am
roobarb! wrote:
Mon Jan 23, 2017 11:55 pm
plm wrote:Is there an issue with the SqueezePlay repository at the moment? I just used the Update menu within SqueezePlay on a Joggler to see if there'd been any updates and it told me I was on version 1.60 but that version E.rr was available.

For anyone that thinks it's a good idea to try it - don't! I had a fat-finger moment and ended up inadvertently trying to install something that isn't there, and had to re-image my Joggler as a consequence.
This has been fixed now - turns out that when we moved the server, I didn't update the location of the database in the update script. Oops! It would only have affected people attempting to perform an update (as you describe) or if somebody was trying to install from scratch using the installation script.

Anyway, everything's back working properly now, so far as I can see!
Is this broken again? I just tried an update on a freshly-imaged Joggler and it couldn't connect to the update server.
Probably. I've not looked at it in quite some time, but I can promise you there have been no updates. ;)

I'm working on something on that server at the moment, if I get chance I'll image up a frame and take a look.
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

User avatar
roobarb!
Posts: 1558
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by roobarb! »

Okay, turns out that quite some time ago the update code on the website broke. It's now fixed, but I'm not going to get chance to look at this again for a bit. Hopefully there's enough back in action for the installation script to work again now - it's certainly generating the correct versions again now.
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

User avatar
pete
Posts: 2826
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by pete »

Great news roobarb!

Here went off to tinkering with HA, Docker, Alexa show et al and these new "el cheapo" smart cam boards....(cheap 5MP ONVIF and Hikvision compatible)...I am impressed with all of this new technology...
- Pete

Auto mater

ARJunior
Posts: 49
Joined: Fri Aug 05, 2011 2:28 pm

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by ARJunior »

Hi roobarb!

Any chance to add support for the Realtek 8821CU combined 5 GHz WiFi and Bluetooth 4.2 module in Squeezeplay OS ?

Thank you.

castalla
Posts: 857
Joined: Wed May 29, 2013 10:33 am

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by castalla »

LMS on spqOS - help needed!

I am having a strange problem using the qobuz plugin on LMS running on sqpOS.

The plugin works BUT the album artwork is missing (only the default radio beacon is shown).

I think it's a qobuz+sqpOS problem because the Spotty plugin shows images, and Qobuz on a pi LMS also works.
okay.

Is anybody out there with sqpOS and LMS who could confirm the Qobuz issue?

castalla
Posts: 857
Joined: Wed May 29, 2013 10:33 am

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by castalla »

Solved this by using chill's jivelite for joggler image

https://forums.slimdevices.com/showthre ... post963249

chill is producing a new improved image ... check it out!

User avatar
roobarb!
Posts: 1558
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by roobarb! »

Cool, been out of the loop on here recently, though I'm happy to see the automated builds are running okay. :)

I've been doing a lot in video production tech recently, so everything else has been squeezed out. Fired up the Joggler on my desk today and it's still working; I remember I was part way through patching up the SqueezePlay installer. I've also noticed this thing called Volumio which looks interesting.
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

User avatar
hawsey
Posts: 1967
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by hawsey »

Welcome back Roobarb I've just looked at Volumino , it looks very promising . Would it , could it work ok on the Joggler ?

Sent from my Moto G (4) using Tapatalk

Happy Joggling

User avatar
roobarb!
Posts: 1558
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by roobarb! »

hawsey wrote:
Sat Mar 07, 2020 11:40 pm
Welcome back Roobarb Image I've just looked at Volumino , it looks very promising . Would it , could it work ok on the Joggler ?
Well, it could, but they're being a bit cryptic - they seem to push their pre-rolled images and devices over a DIY user interface. There were some guides out there, but they've largely vanished. It's basically a front end to mpd so far as I can tell.
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

grb
Posts: 1
Joined: Fri Oct 28, 2016 4:22 pm

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by grb »

Hi all,

Just tested moving from the O2 interface (yes, we still use it) to an internal Squeezeplay OS install. All good, aside from the unsupported sample rate errors on anything 48Khz.

These files play fine elsewhere, and even through squeezeplay via twonkymedia upnp also running on the same NAS.

Any idea how to allow squeezeplay to cope with 48Khz ?

Thanks,


grb.

User avatar
roobarb!
Posts: 1558
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: SqueezePlay for Joggler (Native, Ubuntu & SQPOS)

Post by roobarb! »

grb wrote:
Thu Mar 19, 2020 6:24 pm
Any idea how to allow squeezeplay to cope with 48Khz ?
As there's no other response so far I'll post something useless - I don't know, I'm afraid! I don't remember having a problem with 48 kHz audio, but perhaps the server was transcoding it? I'm really just guessing.
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

Post Reply