BBC iPlayer/Live/Podcast/Categories Player - UPDATED June 15

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
gegs
Posts: 1143
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by gegs » Mon Aug 15, 2011 1:52 pm

Don't install the P'n'P version iPlayer; the new one from spoyser is much, much better.

Firstly, uninstall iPlayer using P'n'P then install spoyser's version using instructions at the beginning of this thread (you have to scroll down quite a bit for the telnet/SSH instructions).

I followed his instructions up till he mentioned using vi - it's a venerable but clunky old editor. Instead I edited the applications.xml file using WinSCP, which is a heck of a lot easier but isn't cross-platform.

Avman
Posts: 34
Joined: Wed Aug 03, 2011 12:57 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Avman » Tue Aug 16, 2011 2:13 pm

thanks,

I did all of the above several time before on several jogglers all with the same outcoome (live streams show xxxx is unavailable).

I know the pnp gets a few bad posts so I tried it on a joggler going back under warranty to find out about it rather than break one of my working ones :-). I noticed that the iplayer install does show the live feeds where the spoyser version works great but doesn't allow the live feeds. I am assuming it is down to my connection if no one else has ever suffered these symptoms. I will try swapping out the router next.

gegs
Posts: 1143
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by gegs » Tue Aug 16, 2011 2:30 pm

Avman wrote:thanks,

I did all of the above several time before on several jogglers all with the same outcoome (live streams show xxxx is unavailable).

I know the pnp gets a few bad posts so I tried it on a joggler going back under warranty to find out about it rather than break one of my working ones :-). I noticed that the iplayer install does show the live feeds where the spoyser version works great but doesn't allow the live feeds. I am assuming it is down to my connection if no one else has ever suffered these symptoms. I will try swapping out the router next.
Is any residual crud being left over from a previous install? Stuff that might screw up a new install? Try deleting the iPlayer folder in its entirety and installing again. I only have problems streaming live channels when they are either unavailable (e.g. before 7pm for BBC3 etc.) or when the content showing on TV isn't licensed for iPlayer use (e.g. some films or internationally syndicated stuff).

The only reason I'm thinking a previous install might be screwing things up is because I installed iPlayer on my brother-in-law's Joggler last week without problems. It had never been hacked or pimped before.

Avman
Posts: 34
Joined: Wed Aug 03, 2011 12:57 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Avman » Tue Aug 16, 2011 3:26 pm

hmm,

the screen i get is the one you would expect when there is no stream but it happens on all channels at all times. I'll try a delete and fresh install to see what happens.

Avman
Posts: 34
Joined: Wed Aug 03, 2011 12:57 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Avman » Tue Aug 16, 2011 6:09 pm

Avman wrote:hmm,

the screen i get is the one you would expect when there is no stream but it happens on all channels at all times. I'll try a delete and fresh install to see what happens.
Same thing, I would normally point the blame at my broadband connection but its the same result on another joggler at a different porperty (different exchange and ISP).

spoyser
Posts: 134
Joined: Mon Mar 07, 2011 6:45 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by spoyser » Tue Aug 16, 2011 8:14 pm

@avman

If you are getting the message channel is not available at this time then it isn't down to connection.

Can you confirm you are UK based.

Have you edited the iplayer.cgi file at all?

At the top of the iPlayer.cgi file there are 3 lines that start with #echo, can you remove the hashes then try and launch the live bbc one stream, then post the contents of the file iPlayer.log here.

Avman
Posts: 34
Joined: Wed Aug 03, 2011 12:57 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Avman » Tue Aug 16, 2011 11:11 pm

I haven't edited the iplayer.cgi.

just made the alterations you suggested but there is no iplayer.log in the iPlayer folder or in the log folder.

Also noticed there are 2 iPlayer folder with contents

media/iPlayer
media/appshop/iPlayer

is this correct?. This is on the joggler I have NOT installed the alternative "live only" app on. Just a couple attempts of this version.

spoyser
Posts: 134
Joined: Mon Mar 07, 2011 6:45 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by spoyser » Wed Aug 17, 2011 11:33 am

@Avman

1) What are the contents of the 2 folders you listed?

2) Can you confirm you are UK based?

3) Can you confirm that you installed the iPlayer files into the /media/iPlayer folder (NOT /media/appshop/iPlayer)?

4) Can you confirm the message (word for word) you get when trying to play a live stream?

5) After you have edited the iPlayer.cgi file it should look like this:

#!/bin/sh
#Joggler iPlayer script by Sean Poyser

app=$1
type=$2
param=$3

echo "app=$app" >> /media/iPlayer/iPlayer.log
echo "type=$type" >> /media/iPlayer/iPlayer.log
echo "param=$param" >> /media/iPlayer/iPlayer.log

etc etc

If you do not then get a iPlayer.log file when you start the live stream can you try an on demand stream and see if you get log file?

Avman
Posts: 34
Joined: Wed Aug 03, 2011 12:57 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Avman » Wed Aug 17, 2011 6:16 pm

1)
contents of folder media/iPlayer:-
icon.swf
iPlayer.cgi
iPlayer.log (now visible)
iPlayer.tgz
language.xml
main.swf
manage.swf
sqp.sh

contents of media/appshop/iPlayer:-
icon.swf
iPlayer.cgi
language.xml
main.swf
manage.swf

2) yes I'm uk based

3) I installed into media/iPlayer

4) I can't at the moment as the live stream has returned to the white screen, usually I get "BBC One is not currently available" with a BBC One background

5) contents of the log file which is now present below:-

pp=bbc_one_london
type=TV
param=
app=closebtn
type=
param=
app=closeapp
type=
param=
app=bbc_one_london
type=TV
param=
app=closebtn
type=
param=
app=closeapp
type=
param=
app=bbc_one_london
type=TV
param=
app=closebtn
type=
param=
app=closeapp
type=
param=

from what I understand its just showing me open and close the app.

spoyser
Posts: 134
Joined: Mon Mar 07, 2011 6:45 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by spoyser » Thu Aug 18, 2011 11:33 am

@avman

iPLayer.log file looks correct (you can put the hashes back in the iPLayer.cgi file, otherwise the log file with grow and grow!)

White screen indicates poor connectivity (usually caused due to wifi dropping out on the jogger try rebooting).

Can you try again and confirm the error message you get.

Is there any chance you can connect joggler to router via cable and try?

darrenkellum
Posts: 35
Joined: Thu May 19, 2011 11:40 am

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by darrenkellum » Thu Aug 25, 2011 9:19 am

Hi
Could someone detail the steps to modify the sleep value in iPlayer.cgi in order to try to get the cross in the corner to appear more often?
I use putty to telent into my joggler. Could you write the script to paste in order to edit the file?
appreciate it, im very new to this telnet stuff. Thanks!

spoyser
Posts: 134
Joined: Mon Mar 07, 2011 6:45 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by spoyser » Thu Aug 25, 2011 11:55 am

@darrenkellum

Telnet in then:

cd media\iPlayer
vi iPlayer.cgi
press the i on the keyboard, this enters insert mode

scroll to bottom and change sleep 3 to sleep 10 (you can try different numbers until you get one that works okay for you, this is the delay before the close button appears)

Then hit ESC followed by :x return (save and exit)

Hope that helps

Avman
Posts: 34
Joined: Wed Aug 03, 2011 12:57 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Avman » Fri Aug 26, 2011 9:55 am

spoyser wrote:@avman

iPLayer.log file looks correct (you can put the hashes back in the iPLayer.cgi file, otherwise the log file with grow and grow!)

White screen indicates poor connectivity (usually caused due to wifi dropping out on the jogger try rebooting).

Can you try again and confirm the error message you get.

Is there any chance you can connect joggler to router via cable and try?
Sorry for the delay, I haven't been able to replicate the message as its just a white screen at the moment. I know this is due to the connection so I'll keep trying and report back.
On another joggler at another property I'm getting 404 errors on all the podcasts. Has anyone else experienced this?.

J

spoyser
Posts: 134
Joined: Mon Mar 07, 2011 6:45 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by spoyser » Fri Aug 26, 2011 5:30 pm

@avman

Just checked podcasts and they seem fine, any in particular that didn't work?

westiebj
Posts: 2
Joined: Mon Sep 12, 2011 4:31 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by westiebj » Mon Sep 12, 2011 4:38 pm

Hi, just installed this .. very impressed. thanks for all the hard work.

Some comments from myside. I have noticed that after watching iPlayer for a period of time , the brightness dims.

This is the default action when the joggler is left idle i believe, but i couldnt get the brightness to return to normal by touching the screen etc

Is there something that can be done? .. I have switched off screensaver .. not sure if this will resolve but is not ideal anyway

Also the response to pressing buttons/ icons when the iplayer is running can be very slow .. to the point you keep retrying as you are not sure it has worked.

Can this be changed ? When not using iPlayer the response is fine

Thanks in advance and agin great work, many thanks

gegs
Posts: 1143
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by gegs » Mon Sep 12, 2011 5:02 pm

If you have Plug'n'Pimp installed it has a tool to disable screen dimming. Very easy to use.

I think the delays you are experiencing when selecting icons is just the player fetching the streams. I don't notice a greater delay than I do on my XBMC iPlayer plugin but other users might have a different slant on this.

westiebj
Posts: 2
Joined: Mon Sep 12, 2011 4:31 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by westiebj » Mon Sep 12, 2011 6:39 pm

Ok thanks for the reply. I dont have plug'n'pimp installed .. i will look at this now
Thanks again

gegs
Posts: 1143
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by gegs » Tue Sep 13, 2011 11:57 am

There should be a command to disable dimming that you can apply using SSH but I don't know what it would be. Plug'n'Pimp is just an easy way to execute commands using a webserver.

Maybe somebody else on the forum would know which command would disable dimming - gforums might be the person to ask.

Mx560
Posts: 45
Joined: Sun Sep 25, 2011 12:08 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Mx560 » Wed Sep 28, 2011 1:05 pm

Where do I put IPLAYER.TGZ to install it , do I just drop it onto a USB stick ??

Mx560
Posts: 45
Joined: Sun Sep 25, 2011 12:08 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Mx560 » Wed Sep 28, 2011 3:47 pm

Ok tried this a few times now everything goes well until right at the end , cant seem to save settings, cant get out of the vi applications.xml

Post Reply