Ubuntu Bionic for OpenFrame

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
HarmlessSaucer
Posts: 5
Joined: Sat Dec 08, 2018 10:41 pm

Re: Ubuntu Bionic for OpenFrame

Post by HarmlessSaucer »

Yea, so strange! I flashed the image with the same thing, used the same sticks, same imager, same ports, same Mac to image... and yet for some reason now it’s working fine! Only thing that’s different is I TRIED installing using the internal memory, which I quickly found was too small. Oh well, thanks everyone! 😊

spants
Posts: 1
Joined: Tue Jun 30, 2020 5:02 pm

Re: Ubuntu Bionic for OpenFrame

Post by spants »

Thanks for building this. I resurrected my 2 O2 Jogglers for a project but I am stuck..... I have the boot USB working for bionic but I would like it to just load up a web browser (will show a NodeRed dashboard).
Does anyone know how to do this?
Thanks!

User avatar
hawsey
Posts: 1984
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu Bionic for OpenFrame

Post by hawsey »

spants wrote:Thanks for building this. I resurrected my 2 O2 Jogglers for a project but I am stuck..... I have the boot USB working for bionic but I would like it to just load up a web browser (will show a NodeRed dashboard).
Does anyone know how to do this?
Thanks!
@Spants are you just wanting a desktop environment ?

Sent from my VOG-L29 using Tapatalk

Happy Joggling

User avatar
roobarb!
Posts: 1628
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: Ubuntu Bionic for OpenFrame

Post by roobarb! »

Funnily enough, installing a kiosk browser is one of the things I have on my list! I'm setting up some home automation and will be using a Joggler for exactly the same purpose.

Okay, from the top of my head:

Code: Select all

sudo of-expand
sudo of-install xserver
sudo apt upgrade
sudo apt install chromium-browser
sudo of-settings autologin of
sudo of-settings autoxrun of "<path to chromium i can't remember where it gets installed>"
sudo reboot
That'll get you somewhere. You may need to:

Code: Select all

sudo apt install matchbox-window-manager
To get Chromium to full screen properly, and you'll need to figure out the kiosk mode switches, but all of that is just the same as any Debian / Ubuntu system.

Good luck!

User avatar
roobarb!
Posts: 1628
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: Ubuntu Bionic for OpenFrame

Post by roobarb! »

BTW, folks, the 3.16 kernel was made end-of-life recently, so I think I'll be switching up to 5.4 in the future. This will break automatic detection of a plug in the output socket on the OpenFrame 1 / Joggler due to the fun way they wired in the chip and me not being able to work out a patch (despite many hours trying).

alxscott
Posts: 3
Joined: Tue Jul 07, 2020 5:27 pm

Re: Ubuntu Bionic for OpenFrame

Post by alxscott »

roobarb! wrote:
Sun Jul 05, 2020 12:50 am
Funnily enough, installing a kiosk browser is one of the things I have on my list! I'm setting up some home automation and will be using a Joggler for exactly the same purpose.

Okay, from the top of my head:

Code: Select all

sudo of-expand
sudo of-install xserver
sudo apt upgrade
sudo apt install chromium-browser
sudo of-settings autologin of
sudo of-settings autoxrun of "<path to chromium i can't remember where it gets installed>"
sudo reboot
That'll get you somewhere. You may need to:

Code: Select all

sudo apt install matchbox-window-manager

To get Chromium to full screen properly, and you'll need to figure out the kiosk mode switches, but all of that is just the same as any Debian / Ubuntu system.

Good luck!
I dit a VERY quick write up here for setting up Joggler with this Ubuntu Image and Chromium :) :

https://community.home-assistant.io/t/j ... ace/145500

EDIT: This post helped me get Chromium running fullscreen!

User avatar
hawsey
Posts: 1984
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu Bionic for OpenFrame

Post by hawsey »

Tonight I tried to build this image for my joggler but failed so far.
I have replaced the internal wireless card with the one suggested and input the wireless variables using notepad but so far it has not brought up an ip address like it should.
Should the ezicast dongle work out of the box on this image so to speak?
Tomorrow I'll try ethernet set up I think.
All I need is a basic desktop environment with a full screen browser and WiFi on the home screen if possible.

Sent from my VOG-L29 using Tapatalk

Happy Joggling

User avatar
roobarb!
Posts: 1628
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: Ubuntu Bionic for OpenFrame

Post by roobarb! »

hawsey wrote:
Wed Jul 08, 2020 9:53 pm
Should the ezicast dongle work out of the box on this image so to speak?
Yes, that dongle is plug-and-play, no special configuration needed. If you're not getting an IP address, double check the format of your network.yaml file. Don't lose the semicolon from the end of the SSID, it's required!

Code: Select all

network:
  version: 2
  renderer: networkd
  ethernets:
    eth0:
      dhcp4: true
      macaddress: 02:15:c2:61:19:a0
  wifis:
    wlan0:
      dhcp4: true
      access-points:
        YOURWIFINAME:
          password: YOURWIFIPASSWORD
Where it says

Code: Select all

YOURWIFINAME:
it needs changing to

Code: Select all

MySnazzySSID:
keeping the semicolon. Then reboot or just

Code: Select all

sudo of-netplan
to apply.

In the 3.16 kernel the RTL8821CU drivers have to be compiled separately and copied in at build time; the log says they compiled just fine.

User avatar
hawsey
Posts: 1984
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu Bionic for OpenFrame

Post by hawsey »

Thank you Roobarb, I'll give this another go today.

Sent from my VOG-L29 using Tapatalk

Happy Joggling

alxscott
Posts: 3
Joined: Tue Jul 07, 2020 5:27 pm

Re: Ubuntu Bionic for OpenFrame

Post by alxscott »

@roobarb!

Firstly, thank you!

I've just started looking at automatic screen dimming and by chance noticed your of-backlight script.

When using the 999 value for automatic; should the script continue to run as opposed to exit? Mine does until I Ctl+C!

If so; should I run this as service. / daemon?

Thanks :)

User avatar
roobarb!
Posts: 1628
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: Ubuntu Bionic for OpenFrame

Post by roobarb! »

alxscott wrote:
Fri Jul 10, 2020 11:00 am
When using the 999 value for automatic; should the script continue to run as opposed to exit? Mine does until I Ctl+C!
Yes, it's not a particularly sophisticated script. Just run it with a '&' at the end and it will background.

User avatar
hawsey
Posts: 1984
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu Bionic for OpenFrame

Post by hawsey »


roobarb! wrote:
hawsey wrote:
Wed Jul 08, 2020 9:53 pm
Should the ezicast dongle work out of the box on this image so to speak?
Yes, that dongle is plug-and-play, no special configuration needed. If you're not getting an IP address, double check the format of your network.yaml file. Don't lose the semicolon from the end of the SSID, it's required!

Code: Select all

network:
  version: 2
  renderer: networkd
  ethernets:
    eth0:
      dhcp4: true
      macaddress: 02:15:c2:61:19:a0
  wifis:
    wlan0:
      dhcp4: true
      access-points:
        YOURWIFINAME:
          password: YOURWIFIPASSWORD
Where it says

Code: Select all

YOURWIFINAME:
it needs changing to

Code: Select all

MySnazzySSID:
keeping the semicolon. Then reboot or just

Code: Select all

sudo of-netplan
to apply.

In the 3.16 kernel the RTL8821CU drivers have to be compiled separately and copied in at build time; the log says they compiled just fine.
I tried again tonight but with no joy unfortunately , I did as suggested and replaced the MySnazzySSID: part and still no wireless log in . I also swapped the wireless dongle from internal to external with same result .

I will try tomorrow using the ethernet cable to get to the point where I have a desktop and hopefully I can then get a standard desktop type wireless log in .
Is this achievable ? So I could put in my wireless details like on Xubuntu .

Sent from my VOG-L29 using Tapatalk

Happy Joggling

alxscott
Posts: 3
Joined: Tue Jul 07, 2020 5:27 pm

Re: Ubuntu Bionic for OpenFrame

Post by alxscott »

roobarb! wrote:
Sun Jul 12, 2020 6:55 pm
alxscott wrote:
Fri Jul 10, 2020 11:00 am
When using the 999 value for automatic; should the script continue to run as opposed to exit? Mine does until I Ctl+C!
Yes, it's not a particularly sophisticated script. Just run it with a '&' at the end and it will background.
Thank you!

User avatar
hawsey
Posts: 1984
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu Bionic for OpenFrame

Post by hawsey »

Still struggling to get to a minimal desktop with my ethernet cable plugged in , I've done the expand command which worked fine but it's crashing out at the xorg part .
I have a green @openframe log in at the moment .
Is that what I'm supposed to have after log in of " OF / Joggler "

Sent from my VOG-L29 using Tapatalk


Happy Joggling

microwax
Posts: 4
Joined: Wed Jul 22, 2020 11:17 am

Re: Ubuntu Bionic for OpenFrame

Post by microwax »

@roobarb,

You mentioned that you're considering moving Bionic up to kernel 5.4 in the future. From my own perspective, that would be really welcomed - or at least a 4.x kernel.

I've just migrated my little collection of Jogglers from the older Xubuntu image to Bionic (and I appreciate the effort and great job you've done with making Bionic available for OpenFrame). I was hoping that the upgrade would allow me to run LXC containers with overlayfs and to make more efficient use of memory with zram-config (by compressing /var/log and swap). So I was a little dismayed to find I still can't do that due to missing zram and overlayfs support in kernel 3.16. A more recent kernel would be wonderful.

And as for the ALSA issue with the speakers/jack - well, to be honest, I don't feel that's something that should hold up proceedings. It's quite apparent that you've tried hard to resolve this issue, but I guess some things just won't budge. At the end of the day, the speakers in the Joggler aren't exactly brilliant - I for one don't use them, and I'd be quite content to disable them (either though software or by snipping their wires).

Would you be able to give an indication of when a Bionic image with a more recent kernel might become available? Obviously, not looking to hold you to this - but I'd rather use one of your expertly prepared images than create a mess by attempting to roll my own!

Cheers.

User avatar
hawsey
Posts: 1984
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu Bionic for OpenFrame

Post by hawsey »

I've fallen down the Linux rabbit hole, so at this point I can log in with either of /joggler on startup or my hawey / ****** one I created.
To install desktop what do I do please? Where should I be logged in to when I install it.
At the moment I get
" command not found". When logged in to of / joggler.
Help please

Sent from my VOG-L29 using Tapatalk

Happy Joggling

User avatar
hawsey
Posts: 1984
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu Bionic for OpenFrame

Post by hawsey »

Am I in trouble Image ( with @roobarb! ) Image

Sent from my VOG-L29 using Tapatalk

Happy Joggling

User avatar
hawsey
Posts: 1984
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu Bionic for OpenFrame

Post by hawsey »

Going in circles ImageImage

Sent from my VOG-L29 using Tapatalk

Happy Joggling

microwax
Posts: 4
Joined: Wed Jul 22, 2020 11:17 am

Re: Ubuntu Bionic for OpenFrame

Post by microwax »

@hawsey,

Instead of

Code: Select all

usermod -aG sudo hawsey
try

Code: Select all

sudo usermod -aG sudo hawsey
The following links might also help:
https://help.ubuntu.com/community/AddUs ... mmand-line
https://help.ubuntu.com/community/RootSudo

User avatar
hawsey
Posts: 1984
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu Bionic for OpenFrame

Post by hawsey »

microwax wrote:@hawsey,

Instead of

Code: Select all

usermod -aG sudo hawsey
try

Code: Select all

sudo usermod -aG sudo hawsey
The following links might also help:
https://help.ubuntu.com/community/AddUs ... mmand-line
https://help.ubuntu.com/community/RootSudo
Thank you @microwax I have tried that sudo at the start as well, I'll look at that link cheers.
I've been trying on and off for almost a year to get to a desktop environment on this bionic build believe it or not Image.
I'll get there eventually.

Sent from my VOG-L29 using Tapatalk

Happy Joggling

Post Reply