Fixing Jogglers

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
Post Reply
User avatar
hawsey
Posts: 1938
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Fixing Jogglers

Post by hawsey » Mon Jul 29, 2019 10:48 pm

I set out to go through my Jogglers to see what worked and what did not .
Joggler 1
I have one that seems to power on as the green light in the back flashes and also an efi boot build of XP seems to be booting but the screen seems dead unfortunately , I tried swapping the motherboard to LCD cable but just the same .
Next I need to swap the whole screen to see if it's that or the motherboard .
I notice the screen has two boards stuck to it , one looks like the power board , has anyone tried changing that ? .

Joggler 2

One of my Jogglers seems to boot up with the whole display raised maybe 1cm , has anyone experienced that ?
I have yet to swap the display but it's a strange one , all looks ok apart from this issue .

Also I seem to have two motherboards without screens :-)


Sent from my Moto G (4) using Tapatalk

Happy Joggling

User avatar
hawsey
Posts: 1938
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Fixing Jogglers

Post by hawsey » Wed Jul 31, 2019 7:03 am


hawsey wrote:
Joggler 2

One of my Jogglers seems to boot up with the whole display raised maybe 1cm , has anyone experienced that ?
I have yet to swap the display but it's a strange one , all looks ok apart from this issue .




Sent from my Moto G (4) using Tapatalk
Ok so I have now swapped the LCD screen out with another Joggler and the issue is still there . So the fault is to do with the main mother board which is weird .
So like I say , everything is shifted up about 1cm from the bottom , so you lose a bit off the top icons on your desktop .
I had two mother boards spare but both of these are faulty unfortunately .

Sent from my Moto G (4) using Tapatalk

Happy Joggling

User avatar
pete
Posts: 2745
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Fixing Jogglers

Post by pete » Fri Aug 02, 2019 12:55 pm

For Joggler #1: I have never changed the power board on one.

For Joggler #2:

I had one Joggler with the shifted screen up a bit a while ago. For me it appeared that the long multiwire LCD connector was loosey goosey a bit at the LCD end.

I pushed it in to place (thinking it was on a a little bit of an angle and that worked for me.
- Pete

Auto mater

Post Reply