Bricked it....

Everything relating to hacking, expanding and modifying the Joggler hardware.
User avatar
Posts: 2823
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Bricked it....

Post by pete » Wed Dec 04, 2013 10:06 pm

Experimenting today with a experimental GPS board that quit working a couple of years ago. I had the board in the attic connected to a GPS antenna. The GPS board talks via RS-232, TTL, USB and Bluetooth.

Before it quit working totally; it was working intermittently. That said one day I decided to replace it and while looking at it the mini USB power input fell off of it.

I tested it again afterwards with a direct 5VDC to the board; but the LED's only indicated that the 5VDC was up on the board but the 3.3 VDC led wouldn't come on and the GPS wouldn't start.

Today I looked at it again and didn't see anything wrong with it. I was going to try using the hot air workstation on it but decided to try something else.

I googled baking a circuit board and decided to give it a try.

I baked the board at some 485 F for maybe 5 minutes. Note this is a last resort "fix".

It worked and I have a working development GPS board again.

BTW the "baking" the circuit board thing is very low on the WAF scale. The weather was nice such that I did open all of the windows on the main floor of the home due to the somewhat toxic gases. Today you do not see or smell anything different in the kitchen.
- Pete

Auto mater

Posts: 1
Joined: Tue Jan 21, 2014 7:38 pm

Re: Bricked it....

Post by moll » Tue Jan 21, 2014 7:43 pm

hey people, did anyone have any luck with the fuse issue. i think i have bricked my board using an incorrect power supply I have been testing the board and the component C267 appears to be misbehaving when testing it with the multimeter.

Although, i don't know what that is. any help would be much appreciated

I use the joggler for my nan (a kind of smart picture frame) and she misses it ever so much :(.

Posts: 1
Joined: Sun Nov 02, 2014 10:54 pm

Re: Bricked it.... POSSIBLE FIXED

Post by shaun2029 » Sun Nov 02, 2014 11:15 pm

I was gifted a O2 Joggler that had a 19 volt power supply plugged in.

After removing the zenor diode used to protect the Joggler from voltage spikes etc it started working again.

If you remove the protection zener diode it will work, but the joggler will probebly fry the next time it gets too much voltage.
Possible Fix: Remove protection zener diode
Possible Fix: Remove protection zener diode

Posts: 105
Joined: Sat Jul 16, 2011 11:18 am

Re: Bricked it....

Post by jkn » Thu Nov 13, 2014 12:25 pm

Sorry, this perhaps should be a new thread, but I didn't want to start a new 'unbricking my Joggler' Thread...

I broke my stalwart Joggler a week or so ago - it seems to be prone to hanging when running iPlayer/YouTube, and I may have reconnected the power too few seconds after powering it down; this is the major cause I have had of Jogglers then failing to boot.

Anyway, it is now stuck on the OpenPeak logo. I have a pair of 'golden' USB drives, one with Rhubarb's boot loader work (thanks!) and one with the PNPIII firmware (thanks!). These pendrives have always worked in the past, certainly on this Joggler. However no joy this time ;-(.

I have also tried with a powered hub; I'm not 100% sure I got the command sequence right but I have ended up with a situation where the pendrive access light flashed merrily away for minutes/hours, but nothing seems to occur on the screen and nothing successfully reboots etc.

I have some other Jogglers I can use, with a few mods (I have a USB DAC fitted and a few other HW mods, to this one), but I'm wondering what could cause these symptoms, given that this Joggelr has been reflashed several times with the same pendrives. I did try the flash loader with other pendrives with the same lack of results. I also swapped the EFI flash memory with another known good joggler; same thing (and the other joggler still works)

Have I fried the USB interface? seems unlikely...

Any other thoughts/suggestions welcome.

Jon N

Posts: 105
Joined: Sat Jul 16, 2011 11:18 am

Re: Bricked it....

Post by jkn » Thu Nov 13, 2014 9:32 pm


Scratch all the above, I've got it going now. Looks like I was following some old/out of date instructions on using a powered hub (which I haven't had to do very often), and as a result was getting the typed commands slightly wrong.

Anyway, I seem to be back up with PnP III. Hurrah!

As penance for my lack of application I have made a small donation to Roobarb's beer fund via the birdslikewires website.

Cheers, jon N

Post Reply