Plug'n'Pimp - Opera, Squeezplay, ...easy way

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
Jarv_77
Posts: 92
Joined: Fri Mar 04, 2011 9:55 am

Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by Jarv_77 »

Hi all, am I the first to start the Gforums Plug N Pimp thread?
http://www.gforums.de/juggler/
http://www.joggler.info/forum/viewtopic ... &start=670

I've just installed R11 Squeezeplay and Server - still having trouble getting it to find the music on my USB stick through My Music/Albums or Artists but also seem to have lost the button that let me re-start squeezeserver from inside Squeezeplay.

Can someone confirm if they have got a Joggler up and running smoothly with Plug N Pimp Squeezeserver, Squeezeplayer and local USB hard drive/ or USB stick with Mp3 files? Mine is never working quite right!

Thanks

:D
gegs
Posts: 1146
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by gegs »

I don't think Roobarb's build had the "re-start squeezeserver" option that gforums' previous build had. I miss that function too.
gegs
Posts: 1146
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by gegs »

gegs wrote:
dwl99 wrote:
Dunno, I've installed Squeezebox Server on the Joggler but haven't had any reason to use it.


I'm surprised that you don't use it if you use Squeezeplay. Without Squeezebox Server I can't install addtional plugins like the Spotify and BBC iPlayer ones.
[...]


Sure, you can! There's a "register" tap to create or login using an mysqueezebox.com account. Using this, you can install plugins without the need of squeezeserver to install.
Sorry gforums, I beg to differ; you can only download the authorised plugins from mysqueezebox.com.

I can't find anywhere on mysqueezebox.com to download 3rd party plugins. The official Spotify plugin wouldn't work the last time I tried it; I have to use the Triode 3rd party Spotify plugin from Squeezeserver. The BBC plugin on mysqueezebox.com doesn't work for me either, I have to use the BBC iPlayer plugin from Squeezeserver. The fabulous "iPlayer Extras" plugin is also unavailable on mysqueezebox.com.
If anybody knows if this stuff is hidden somewhere on the site, please let me know

Plugins, including some very useful 3rd party ones, are available from a tab when you click through from "settings" (on the bottom of the Squeezeserver web interface).
User avatar
dwl99
Posts: 765
Joined: Fri Mar 04, 2011 7:38 am
Location: Glasgow

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by dwl99 »

That's my experience too
Regor
Posts: 25
Joined: Fri Mar 04, 2011 6:03 pm
Location: Scotland

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by Regor »

Hi

Took the plunge to install SqueezeServer via Plug'n'Pimp. I find now that I can't install Plugins with the Squeezeserver interface. Everything appears to go ok but the install of the plugin fails.

I am aware of the installation procedure but it would appear that the requested mods are not allowed. Are there any file write protections that should be removed?

I have attempted to install iPlayer plugin mainly but others have also failed.

:?
Horatio
Posts: 32
Joined: Fri Mar 04, 2011 6:35 pm

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by Horatio »

Regor wrote:Hi

Took the plunge to install SqueezeServer via Plug'n'Pimp. I find now that I can't install Plugins with the Squeezeserver interface. Everything appears to go ok but the install of the plugin fails.

I am aware of the installation procedure but it would appear that the requested mods are not allowed. Are there any file write protections that should be removed?

I have attempted to install iPlayer plugin mainly but others have also failed.

:?

You need to follow the short instructions in the install apps/install squeezeserver section on the webinterface, this had me stumped for a while too.

Many thanks to gforums for your excellent work on this (donation will follow).
gegs
Posts: 1146
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by gegs »

Horatio wrote

You need to follow the short instructions in the install apps/install squeezeserver section on the webinterface, this had me stumped for a while too.
You have to SSH into your joggler. Use Putty - default u/name is 'letmeinssh' p/w is 'joggler1234' (without quotes).

The command to run is:

chown -R squeezeboxserver:squeezeboxserver /media/gforums/apps/squeezeboxserver-7.6.0-31297
Regor
Posts: 25
Joined: Fri Mar 04, 2011 6:03 pm
Location: Scotland

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by Regor »

Hi

I did issue the command:

chown -R squeezeboxserver:squeezeboxserver /media/gforums/apps/squeezeboxserver-7.6.0-31297 since the server did not startup.

After a Reboot squeezebox Server started but I was unable to install Plugins But other features do function.

Thanks for your comment.

:)
gegs
Posts: 1146
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by gegs »

Regor wrote:
After a Reboot squeezebox Server started but I was unable to install Plugins But other features do function

:)
Keep trying. I had to do it a few times before the plugins were recognised.
You have to choose to install the plugin, when installed select it to activate it, then apply to re-start the server. I had to do this several times before getting BBC streams to work.
Regor
Posts: 25
Joined: Fri Mar 04, 2011 6:03 pm
Location: Scotland

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by Regor »

Have tried at least ten times with no success.

Using the Plug'n'Pimp file explorer I have established that the Plugins are downloaded to:


/media/gforums/apps/squeezeboxserver-7.6.0-31297/Cache/DownloadedPlugins

This contains the selected plugins in .zip format eg BBCiPlayer.zip

However following this path:

/media/gforums/apps/squeezeboxserver-7.6.0-31297/Cache/InstalledPlugins

I have established this is empty.

The downloaded version of Squeezebox Server is not unzipping the Plugins and installing them.

Any forum user familiar with the process?

Again thanks for comment.
:?
gegs
Posts: 1146
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by gegs »

It's working fine for me. I can only suggest uninstalling the server and re-installing, but maybe you have. Other than that, I don't know.

Can't you use SCP to download the files, unzip them locally and then copy the unzipped files to the correct location?
Horatio
Posts: 32
Joined: Fri Mar 04, 2011 6:35 pm

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by Horatio »

I tried to get the iplayer plugin to work for ages, but after the 3rd (!) fresh install of 02 software (for all sorts of reasons), i noticed the chown command and it worked first time. All i could suggest is checking free space with 'df' in putty, and then yeh maybe unistalling squeezeplay and squeeze server and reinstalling after a reboot, squeezeplay first.

Incidentally, the last time i had to reflash i think it was because i booted up the joggler without the usb soundcard attached while having it running on the usb soundcard option. Just mention it as a warning really, dont know if anyone else has had the same thing?? Dont want to try it again to find out for sure!
pog
Posts: 2
Joined: Fri Mar 04, 2011 9:36 am

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by pog »

Thanks to gforums and roobarb for all their hard work on this - it's meant I've finally found a use for the joggler, but I couldn't register on the old forum to say cheers.
I'm running latest version of PnP, which plays fine through an Rdac when mixer is enabled. When I change Joggler settings to USB external without mixer, I can't get squeezeplay to start when Joggler is attached to the dac. And no other applications will output sound to the dac. Any ideas what the problem might be here?
Thanks for any suggestions.
Regor
Posts: 25
Joined: Fri Mar 04, 2011 6:03 pm
Location: Scotland

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by Regor »

:D :D :D

Hi

Success, at last, I have managed to install and remove plugins from Squeezebox Server. The whole program seems to be functioning ok.

I had already tried installing the package of Server and Perl 'n' times and issued through ssh the command:

chown -R squeezeboxserver:squeezeboxserver /media/gforums/apps/squeezeboxserver-7.6.0-31297

with no success.

This was how it was resolved:

1. Removed Perl on its own via the Plug'n'Pimp Install Tools web interface.
2. Rebooted the joggler.
3. Installed Perl on its own, again from the Install Tools menu.
4. Rebooted the Joggler.

At this point I found that the Squeezebox Server would not start.

5. Issued the ssh command above again and rebooted the Joggler.

The Server was running and plugins could be installed.

Hope this helps any other user who comes across this problem.

Thanks for advice given.

:D :D :D
NS1
Posts: 4
Joined: Mon Mar 07, 2011 10:33 am

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by NS1 »

--------------------------------------------------------------------------------

Can anyone help me start the Squeezebox Server on my Joggler?

I have 1 SB3 & 2 SB Touches running on a wired network, using one of the Touch's as the server.
I bought a Joggler to use as a touch screen controller for the SB3 & to run Squeezebox Server.
I have been using the Joggler as a controller with Squeezeplay for a while, but have recently tried to luanch Squeezebox server on it without any success.

I am running Plug'N Pimp on the Joggler & have all the latest firmware / apps etc. I have tried uninstalling / re-installing the SB Server & Squeezeply several times, tried registering the Joggler on MySqueezebox several times, rebooting etc but still no joy.

The Joggler seems to be still looking to connect to my Touch for the server, i have disconnected all SB's in an attempt to force it to use the Server on the Joggler but this does not work & there is not an option on the Squeezeplay menus to start the SB Server on the Joggler.
I am sure the Server has not started as i cannot connect to it / acces the web interface on Port 9000 & have tried turning off all firewalls & anti-virus to see if they were blocking access.
Is there a way to start the Squeezebox Server using SSH into the Joggler??

Any help would be much appreciated.

Thanks
Horatio
Posts: 32
Joined: Fri Mar 04, 2011 6:35 pm

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by Horatio »

Great to hear you got it working Regor, its a cool plugin, i dont think i could live without 6 music anymore!

@ Pog, I have exactly the same problem, squeezplay wont start with 'usb no mixer', Im using a creative xmod wireless. It seems to me the 'internal sound no mixer' is very stable so its a shame I cant get the usb equivalent to work. Would be interested to hear if it works for others.
Jarv_77
Posts: 92
Joined: Fri Mar 04, 2011 9:55 am

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by Jarv_77 »

NS1 wrote:--------------------------------------------------------------------------------

Can anyone help me start the Squeezebox Server on my Joggler?

I have 1 SB3 & 2 SB Touches running on a wired network, using one of the Touch's as the server.
I bought a Joggler to use as a touch screen controller for the SB3 & to run Squeezebox Server.
I have been using the Joggler as a controller with Squeezeplay for a while, but have recently tried to luanch Squeezebox server on it without any success.

I am running Plug'N Pimp on the Joggler & have all the latest firmware / apps etc. I have tried uninstalling / re-installing the SB Server & Squeezeply several times, tried registering the Joggler on MySqueezebox several times, rebooting etc but still no joy.

The Joggler seems to be still looking to connect to my Touch for the server, i have disconnected all SB's in an attempt to force it to use the Server on the Joggler but this does not work & there is not an option on the Squeezeplay menus to start the SB Server on the Joggler.
I am sure the Server has not started as i cannot connect to it / acces the web interface on Port 9000 & have tried turning off all firewalls & anti-virus to see if they were blocking access.
Is there a way to start the Squeezebox Server using SSH into the Joggler??

Any help would be much appreciated.

Thanks
Hi,
I'm not an expert but....

1 make sure squeezeplay is installed before server.
2 you need the Perl (sp?) Install on the joggler through plug n pimp before installing server (might need it for the player too, can't remember),
3 try the 'force install' option for server in one of the plug n pimp menus.

I had the same issues but eventually could log in via port 9000 then entered my details and it all started up.

Cheers
NS1
Posts: 4
Joined: Mon Mar 07, 2011 10:33 am

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by NS1 »

Managed to get SB server up & running now thanks, by uninstalling the Server & Perl, then installing Perl then SB Server.

Thanks verry much for your help.
NS1
Posts: 4
Joined: Mon Mar 07, 2011 10:33 am

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by NS1 »

I have another problem now :-
i cannot get the SB Server to scan the music library on my USB HDD, the first scan took about 12 hours and looked like it had loaded all the music, but none was visible from any of my SB's.
I have tried scanning again a few times, but it takes agaes & then hangs.
Looking at the forums there seems to ne a problem with SB Server 7.60 & scanning files on a NAS - i guesss this is what i am experiencing on my Joggler.
Does anyone have a solution or work around that i could try??

Is there any way to roll back the SB Server to an earlier version ie. 7.50 on my Joggler, as all suggestions are pointing to the scan problem being an issue in version 7.51, 7.60 etc. ??
User avatar
offbeatdave
Posts: 1041
Joined: Wed Mar 09, 2011 10:43 pm

Re: Plug'n'Pimp - Opera, Squeezplay, ...easy way

Post by offbeatdave »

Regor wrote::D :D :D

Hi

Success, at last, I have managed to install and remove plugins from Squeezebox Server. The whole program seems to be functioning ok.

I had already tried installing the package of Server and Perl 'n' times and issued through ssh the command:

chown -R squeezeboxserver:squeezeboxserver /media/gforums/apps/squeezeboxserver-7.6.0-31297

with no success.

This was how it was resolved:

1. Removed Perl on its own via the Plug'n'Pimp Install Tools web interface.
2. Rebooted the joggler.
3. Installed Perl on its own, again from the Install Tools menu.
4. Rebooted the Joggler.

At this point I found that the Squeezebox Server would not start.

5. Issued the ssh command above again and rebooted the Joggler.

The Server was running and plugins could be installed.

Hope this helps any other user who comes across this problem.

Thanks for advice given.

:D :D :D
Thanks for the post! I'd not been able to install iplayer plugins since updating Squeezebox but this set of instructions did the trick! Ta!
"EVERY DAY I'M JOGGLERING!"
Jogglering since Dec '09;
Tinkering with Jogglers since Feb '10 thanks to PMJ, Jogtools, PnP & sqpOS;
Gave something back Feb '12 to Apr '14 with PnP Mk II & PnP III;
Finally 'completed' PnP III Apr '15!
Post Reply