Page 7 of 7

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Sat Aug 25, 2018 8:23 pm
by roobarb!
JonB wrote:
Sat Aug 25, 2018 5:06 pm
I still have a problem with the wifi on my devices. I wonder if the new firmware will fix it...? Anyway, thanks for persevering with it. I'm flashing now after several false starts, probably caused by Safari opening the .gz and me not realising it had uncompressed it in situ. With the image uncompressed the boot fails and / or you can't copy it to the USB stick. All my fault - more haste less speed etc.
Yes, Safari tries to be helpful, but the decompressed file won't write because it not match the checksum file, or it'll just be too big for the stick!
JonB wrote:
Sat Aug 25, 2018 5:06 pm
The reflash appears to have gone well and it is rebooting. Got O2 splash screen then OpenPeak, followed by Tango home screen. So far so good, but it cannot see my wireless network. Locked up with a wired connection on acquiring IP address. On a reboot I have an IP address! Time to go nosing about I guess..
Good luck with it; if you boot the reflash system without an image to write and have a keyboard plugged in, you can boot to a command line. Then you can list all of the interfaces available with:

Code: Select all

ifconfig -a
That way you should at least be able to see if the card is being recognised.

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Sat Aug 25, 2018 9:43 pm
by JonB
Pete - as you can see I have just got both of them working thanks to your advice and roobarb's latest SqueezeOS.

I'm glad there's still some activity on the forum and that people are still using the Joggler.

Once again, thanks to you and roobarb for helping me. Really happy to have the Jogs up and running again. :)

Cheers
JonB

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Sun Aug 26, 2018 12:52 am
by pete
Good news JonB.

Here still utilize main Jogglers for Home automation touchscreens and a few running Squeezeplayer ~ 20 around the house now. While old these continue to run 24/7. The screens are shut off at night.

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Wed Sep 05, 2018 10:46 am
by roobarb!
My server is receiving heartbeats (yeah, that's what OpenPeak called them in the code!) from about 8 different devices now; I'm assuming nobody's having trouble with their icons vanishing with v30301? If you are, please post here and I'll investigate.

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Mon Nov 05, 2018 3:05 am
by BigT
Wow.. Found my old bookmarks backup and found this forum still alive.
Time to get my little joggler out of storage and have another play.

Mainly looking to watch my door CCTV ideally. Or as a NAS media player if you can point me in the right direction?

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Tue Nov 06, 2018 5:07 pm
by pete
CCTV works well using SD but is a bit slow using HD. Ultimate with least amount of changes is to convert your Joggler to a Squeezebox player running off of the 1Gb internal eMMC.

Never tried a NAS on the Joggler. I have modded them here with small ZIF SSD drives for use with Windows (and new BIOS).

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Tue Nov 06, 2018 11:21 pm
by hawsey
Nearest I have is Plex server running for my music collection in the background with Squeezeplay os running off usb efi boot .

Sent from my Moto G (4) using Tapatalk


Re: Updated OpenPeak Firmware (Version 30301)

Posted: Mon Jan 21, 2019 6:39 pm
by rd07
Apologies for the stupid question but I'm hoping someone can help. I've followed the instructions and downloaded the latest version and the MD5, extracted the image, used Win32DiskImager to write the image to the USB, however, after removing the USB and plugging it back into the computer again, I still can't see a 'reflash' folder which the instructions say the .img.gz and .img.gz.md5 need to be moved to. All I can are 5 files -

boot.efi
initrd
startup.nsh
sum0
vmlinux0

Any ideas on what I'm doing wrong? Thanks

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Tue Jan 22, 2019 3:33 pm
by pete
Yeah the reflash image puts in a regular dos seen directory on the USB stick. Then you copy over the img and md5 files over to it.

If you do not see a directory using your computer file manager then rewrite the stick.

Try:

1 - first format the stick with told HP USB stick formatting program:

2 - then write the reflash image to the stick using Win32DiskImager

3 - then copy the two image files over to the reflash directory.

For me writing to the USB stick works better in Windows than Linux using GParted.

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Wed Jan 23, 2019 10:45 am
by rd07
** EDIT - sorted now, USB stick is ready, however, Joggler (which I've not used for a while) is not powering on! I can see a small green flashing light coming from just below the headphone jack but screen is not coming on at all. Different problem to solve now!

Thanks for the reply. I tried the steps you mentioned using the HP USB stick and still have the same issue in that I can't see any folders, just the files I mentioned in my previous post. I've tried 2 different USB sticks too. Any ideas what else I could try? Thanks

Re: Updated OpenPeak Firmware (Version 30301)

Posted: Wed Jan 23, 2019 2:08 pm
by pete
Yeah the stick has a fat partition and that is the only one you can see with a windows PC. There in the fat partion is the reflash directory where you copy the base build two files. What OS are you using to do this? Windows xp, 7 or 10? You should see it find with all three OS's.

The USB boot stick created only works on the O2 Joggler or Openpeak 1 and 2 devices.

IE: here is a picture from my Linux computer showing two partitions on the USB stick.
1 - partition 1 - fat - this is the only one you see in windows
2 - partition 2 - Linux EXT4 - this one you cannot see in windows

You just copy the two files over to the reflash directory.
reflash2.jpg
When writing to the 1 or 2 Gb eMMC partition using the Squeezeplayer firmware you will see this sshing to your new Joggler Squeezeplayer device.

Code: Select all

oot@ICS-Jog-SQP-17:~# df -l
Filesystem     1K-blocks   Used Available Use% Mounted on
udev              250616      4    250612   1% /dev
tmpfs              50692    648     50044   2% /run
/dev/mmcblk0p2   1944208 645912   1199532  36% /
none                   4      0         4   0% /sys/fs/cgroup
none              196608     24    196584   1% /tmp
none                5120      0      5120   0% /run/lock
none              253452      0    253452   0% /run/shm
none              102400      0    102400   0% /run/user
none              262144    396    261748   1% /var/cache/apt
none              262144      0    262144   0% /var/lib/apt/lists
none               16384    444     15940   3% /var/log
/dev/mmcblk0p1     31168  11234     19934  37% /boot
ICS-Jog-SQP-17:~# uname -a
Linux ICS-Jog-SQP-17 3.18.2op4 #4 SMP Thu Jan 15 16:26:27 GMT 2015 i686 i686 i686 GNU/Linux

ICS-Jog-SQP-17:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty