[RELEASE] XBMC for O2 Joggler (discontinued)

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
gegs
Posts: 1143
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: [RELEASE] XBMC for O2 Joggler

Post by gegs » Thu Jun 06, 2013 1:37 pm

ilovemyjoggler wrote:
gegs wrote:There's a 1channel fix in the Maintenance Tool. It worked for me recently (unless things have changed again since then).
Yes. Youtube is full of happy people as the fix worked for them too. An update is now available for 1channel and the fix seems to update to the new version. Neither method worked on my joggler but i'm using gotham and maybe that's why?...
I never use pre-release or even brand new stable releases of XBMC because too many addons get broken. I do update to new versions but usually after a couple of months have passed, the dust has settled and most addons have been updated. The only exception would be if a new release fixed a major bug (and it would have to be a biggie).

ilovemyjoggler
Posts: 706
Joined: Sun May 13, 2012 4:42 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by ilovemyjoggler » Fri Jun 07, 2013 2:21 pm

Well yes, of course you're right. Only an idiot would upgrade to a pre-release unless they're capable of fixing things themselves. However at the time, for this said idiot, it was either that or nada as my addons were broken in Eden. I couldn't find a guide to update to Frodo and managed to break it in quite a spectacular way.

Now in my (and xbmc 13's) defence I'll say that it had been working great since I did upgrade in Marchish? It's just this very recent issue with 1channel (and to a certain extent icefilms) which has proved to be a bit of a mess for me. But to be fair, I don't seem to be only person who can't get the recent fixes to work. ;)

User avatar
BuZz
Site Admin
Posts: 1450
Joined: Fri Mar 04, 2011 1:15 am

Re: [RELEASE] XBMC for O2 Joggler

Post by BuZz » Sat Jun 08, 2013 3:48 pm

to have a working 1channel plugin you need to closely follow the forum over at xbmchub.com. 1channel site has changed domain name 3 times recently, and the extension will need an update (and possibly urlresolver too).

rivergo1d
Posts: 37
Joined: Thu Jul 07, 2011 12:34 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by rivergo1d » Mon Jun 10, 2013 10:32 am

I had problems with the 0.9 release as provided - it was a little slow and kept crashing when selecting menu items, occasionally. I release that I am in a minority and, probably like ilovemyjoggler, this is peculiar to my particular joggler setup.

Also like ilovemyjoggler, following the advice to do a dist-upgrade worked for me - speed improved and stability was excellent. However, I cannot play videos from an FTP source (topfield) for longer than about 10 seconds.

XBMC forums seem to indicate the video problem may be specific to Frodo, so I would like to keep my upgraded ubuntu backbone, but manually install the XBMC version included in the 0.9 release.

Can anyone advise either how to install the exact same XBMC as included in that distribution (front page of this thread), or alternatively, if I rewrote the entire image, how I could upgrade then everything apart from XBMC itself?

User avatar
pete
Posts: 2814
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: [RELEASE] XBMC for O2 Joggler

Post by pete » Mon Jun 10, 2013 5:25 pm

Here I started with the original image. I then updated it to the builds that BuZz mentioned in his XBMC posts.

That said though I have it running on the 2 Gb MMC built into the OpenFrame2 box. I am able to stream live TV, recorded via MythTV, recording on the NAS stuff. But really only 720 and 480 resolution stuff. 1080 stutters major.

I trashed the build yesterday updating it. The update messed with the xorg video stuff and now when it loads it crashes.

Not a big deal to start again.
- Pete

Auto mater

rivergo1d
Posts: 37
Joined: Thu Jul 07, 2011 12:34 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by rivergo1d » Mon Jun 10, 2013 5:34 pm

If I use the very latest "test" build, the video performance changes. Instead of cutting out after a few seconds, the video screen keeps flickering green.

I am trying to stream a "rec" file (transport stream) from a topfield PVR via a remote ftp server on my LAN.

rivergo1d
Posts: 37
Joined: Thu Jul 07, 2011 12:34 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by rivergo1d » Mon Jun 10, 2013 10:46 pm

OK, I've found the cause of the "dropping" problem when using the released Frodo (I don't know about the test Frodo green screen). It is because my FTP device was not streaming fast enough - once I put the topfield into turbo FTP mode, it streamed fine.

So Frodo release works for me and is very stable and fast, but FYI the test release has green screen flickering.

rivergo1d
Posts: 37
Joined: Thu Jul 07, 2011 12:34 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by rivergo1d » Fri Jun 14, 2013 7:53 am

Has anyone had issues with radio playback stuttering occasionally, particularly when the joggler is under heavier load but also when idle?

User avatar
pete
Posts: 2814
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: [RELEASE] XBMC for O2 Joggler

Post by pete » Fri Jun 14, 2013 6:58 pm

Here yesterday rebuilt a bit the original XBMC box. I had issues updating XBMC so instead removed it. I then did an upgrade of the OS. It took a while as there were some 150 upgraded files. I then installed XBMC from BuZz's stuff. It is running well. Just looking to update / install the TV PVR stuff. This morning left it streaming an HD movie and radio and it behaved just fine. Found my issue to be related to the Wireless dongle/card. I removed it and used the internal NIC. That said the start up XBMC file was looking for the WLAN0 port. Edited the file and all was good to go. I am running about 1.7 Gb of 2.0 Gb and its doing OK. (a bit tight). I added some more sleep stuff to it such that it shuts off the LCD or suspends the machine after a period of time.
- Pete

Auto mater

ilovemyjoggler
Posts: 706
Joined: Sun May 13, 2012 4:42 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by ilovemyjoggler » Mon Jun 17, 2013 11:53 pm

BuZz wrote:to have a working 1channel plugin you need to closely follow the forum over at xbmchub.com. 1channel site has changed domain name 3 times recently, and the extension will need an update (and possibly urlresolver too).
Not sure how i missed this post. But nope. No fix or update works on my build of 13 and i've followed the instructions very closely indeed. Also checked in misc settings to make sure it's pulling from the correct source but still all i get is script error. I have it working on my laptop so it's ok. Thanks though :)

User avatar
BuZz
Site Admin
Posts: 1450
Joined: Fri Mar 04, 2011 1:15 am

Re: [RELEASE] XBMC for O2 Joggler

Post by BuZz » Tue Jun 18, 2013 12:51 am

Please post a debug log - found in home directory/.xbmc/temp/xbmc.log (via http://xbmclogs.com/ or pastebin)

I'll be able to advise further.

ilovemyjoggler
Posts: 706
Joined: Sun May 13, 2012 4:42 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by ilovemyjoggler » Tue Jun 18, 2013 12:23 pm

BuZz you are kind. I really wasn't expecting you to want to help as this is the wrong forum! But I gratefully accept your offer :)

In an effort to make sure it's as untampered as possible, I've completely reinstalled 1channel and applied the hub fix. The strange thing is now it won't show me the miscellaneous settings so I can't check or change the source (which I could do before).

Anyway, for what it worth, here's the link

I've never uploaded a log before so I'm a little nervous about what you'll get. Hopefully it's the right thing and there's nothing too sensitive in there!

EDIT: old link removed
Last edited by ilovemyjoggler on Sun Jul 06, 2014 12:44 am, edited 1 time in total.

User avatar
pete
Posts: 2814
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: [RELEASE] XBMC for O2 Joggler

Post by pete » Tue Jun 18, 2013 1:53 pm

Wow; here I was amazed with what I saw at XBMCHub. Guess here I was so used to just using the PVR interface never really bothered with the on live video streaming stuff. I am starting to see some trending here with paid for subs off of the larger TV networks even with subchannel HD over the air stuff lately...doing much a la carte stuff....

I have though now configured the MythTV box to record a bunch of old (from the 60's) Star Trek shows.

That said mostly everything I tried worked from here in the US. It also filled up my XBMC 2Gb setup in a day. (100%).

I did try a manual PVR setup and had some issues with it...that said though I have now shut off XBMC for the time being; saved the build and gone back to PnP3 and SP 2Gb builds.
- Pete

Auto mater

User avatar
BuZz
Site Admin
Posts: 1450
Joined: Fri Mar 04, 2011 1:15 am

Re: [RELEASE] XBMC for O2 Joggler

Post by BuZz » Tue Jun 18, 2013 2:03 pm

ilovemyjoggler wrote:BuZz you are kind. I really wasn't expecting you to want to help as this is the wrong forum! But I gratefully accept your offer :)
couple of things to rule out / test -

You should probably stick with 12.0 release. Stuff could have changed in 13 (which is still in alpha - hence not ready for everyday use).

You should also try with the default skin (confluence lite) rather than re-touched. the error is a "non existant control" error which is skin related (it relies on a specific id of a control in confluence lite)

ilovemyjoggler
Posts: 706
Joined: Sun May 13, 2012 4:42 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by ilovemyjoggler » Tue Jun 18, 2013 2:44 pm

BuZz, thanks so much for taking a look. I started with the easy option of changing the skin and it's done the trick. Thanks again!

ilovemyjoggler
Posts: 706
Joined: Sun May 13, 2012 4:42 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by ilovemyjoggler » Thu Jul 18, 2013 10:11 pm

Today I watched a programme using the itv plugin. Got a pleasant surprise when I realised that adverts seem to be edited out (unlike the itv player app on the iphone). I've always had this plugin on my xbmc but have never used it before, partly because itv is mostly dross and partly because adverts annoy me. Sadly I had dinner ready too soon and never got to find out who did it!

cminion
Posts: 1
Joined: Sun Sep 01, 2013 9:58 am

Re: [RELEASE] XBMC for O2 Joggler

Post by cminion » Sun Sep 01, 2013 10:00 am

Is there any sign of a new XMBC for o2 joggler. I know there are ubuntu builds i can load one up on but I want to keep a simple experience.

User avatar
pete
Posts: 2814
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: [RELEASE] XBMC for O2 Joggler

Post by pete » Sun Sep 01, 2013 11:00 am

Welcome to the forum cminion!

Here I have been using one centralized mysql database for all of the xbmc machines. More doing so to coordinate each of them.
- Pete

Auto mater

User avatar
BuZz
Site Admin
Posts: 1450
Joined: Fri Mar 04, 2011 1:15 am

Re: [RELEASE] XBMC for O2 Joggler

Post by BuZz » Sun Sep 01, 2013 7:14 pm

cminion wrote:Is there any sign of a new XMBC for o2 joggler. I know there are ubuntu builds i can load one up on but I want to keep a simple experience.
You can update this distro to the latest xbmc by just doing apt-get update; apt-get dist-upgrade afaik. It uses my xbmc packages which has the latest stable release.

ilovemyjoggler
Posts: 706
Joined: Sun May 13, 2012 4:42 pm

Re: [RELEASE] XBMC for O2 Joggler

Post by ilovemyjoggler » Tue Dec 10, 2013 12:37 am

I tried to move to frodo using the sudo apt-get command. 2 and a half hours later it's still updating. Seems rather a long time to me. Is that normal or should I be concerned about what i'll find in the morning?

Post Reply