Debian Bullseye for OpenFrame

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
Man in a van
Posts: 486
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bullseye for OpenFrame

Post by Man in a van »

Encoraged by the return of Pete (I hope all is well, Pete :) )
I sallied forth with the latest ;
bul-ext2-1028-43-bullseye-5.10.190op.img.gz 12-Aug-2023 06:01 186M
Installed Squeezeplay

Playback was successful on the internal speaker (Internal Direct)

Selected the (External Direct) option, plugged in a usb dac (Khadas Toneboard) and rebooted

As soon as I select something to play, the screen defaults to a blank (bin?) screen

I reboot and select (External Mixer), restart Squeezeplay and some music plays through the Dac (but everything is at 44.100Hz)
of@openframe:~$ cat /proc/asound/card1/stream0
Khadas Tone1 at usb-0000:00:1d.7-4.4, high speed : USB Audio

Playback:
Status: Running
Interface = 1
Altset = 1
Packet Size = 72
Momentary freq = 44099 Hz (0x5.8328)
Feedback Format = 16.16
I return to (External Direct), restart Squeezeplay, the splash screen flashes and the screen remains dark with a $ in the top left corner

I have to repower the Joggler to get the screen back

I realise that I can change the asound.conf to 48000 which would likely give me BBC and fip Radio but it has all previously worked without all this messing around :? :roll:

When I now power on the Joggler I get the splash screen then the blank black screen :roll:

As an aside; I ran dsmeg and it reported a "dirty bit", which I cleaned :)

Joggler dmesg.zip
(14.8 KiB) Downloaded 1151 times

ronnie
stripwax
Posts: 19
Joined: Sun Dec 29, 2019 12:51 pm

Re: Debian Bullseye for OpenFrame

Post by stripwax »

Been following some of these threads for a while and decided to get back into Joggler. Latest Bullseye (as at writing) is 5.10.197 . Installation seemed relatively smooth (although /usr/local/sbin not in path? or is that normal these days). Weirdly, no Now Playing screen shows up for me. Looking around, that also seems normal, but I'm not sure what I'm missing or how to get it back. Playback seemed good though.

Also tried Bookworm, actually I couldn't get wifi to work at all; the settings in my network.yaml seemed to be ignored entirely. Despite writing the correct network.yaml, all evidence seemed to be that it was still using the default YOURWIFINAME.

What's the recommendation, persist with Bullseye (because it's fairly stable? and I just need to fix my Now Playing screen probably). Or move to Bookworm?
Man in a van
Posts: 486
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bullseye for OpenFrame

Post by Man in a van »

@stripwax

I just ran an install of the last Bullseye and all is well

Playing now screen is working

I ran
sudo apt update, installed the update and rebooted

Then, sudo apt update again and sudo /usr/local/sbin/of-install squeezeplay

I did this using the Wireless connection to the network and the OS installed on a micro sd card in a card reader

Edit: I did not expand the file system on the card

hope this helps

ronnie
Man in a van
Posts: 486
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bullseye for OpenFrame

Post by Man in a van »

stripwax wrote: Tue Oct 10, 2023 12:19 am
Also tried Bookworm, actually I couldn't get wifi to work at all; the settings in my network.yaml seemed to be ignored entirely. Despite writing the correct network.yaml, all evidence seemed to be that it was still using the default YOURWIFINAME.

What's the recommendation, persist with Bullseye (because it's fairly stable? and I just need to fix my Now Playing screen probably). Or move to Bookworm?
Just tried the last vesrion of Bookworm; all is good :)

Used the Wireless connection (did you remenber to retain the : at the end of YOURWIFINAME: ?

Playing Now screen working as default

A bonus seems to be that Settings > Audio Settings > Audio Interface > Internal (Mixer) is working by default (I'm listen on headphones) and does not require resetting to [Internal(direct)]

BBC Sounds also plays without a problem

ronnie
stripwax
Posts: 19
Joined: Sun Dec 29, 2019 12:51 pm

Re: Debian Bullseye for OpenFrame

Post by stripwax »

Thanks for the replies. Hm, I wonder what I could be doing wrong. I'll start over.
In my case, I did expand the file system (first), then I ran of-install squeezeplay, then I ran apt update / apt upgrade. Maybe I'll try it in the other order and see if it works better.

Also - would you recommend Bullseye (5.10.197) or Bookworm (6.1.55) at this point?
Man in a van
Posts: 486
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bullseye for OpenFrame

Post by Man in a van »

I would say, depends on usage

I was surprised to fid that Bookworm image allowed playback through the default audio output without reconfiguration

Both OS use their respective LTS kernels, so it's a bit "evens-Stevens"

Bookworm will also continue with updates for longer I guess

ronnie
stripwax
Posts: 19
Joined: Sun Dec 29, 2019 12:51 pm

Re: Debian Bullseye for OpenFrame

Post by stripwax »

Ok, full reinstall of Bullseye (same version as before) and it seems to be much happier. Must have been something corrupted on the memory stick. Now Playing is working as it should.
Having said that, BBC Sounds is not working for me. Does that work for you on both Bullseye AND Bookworm, or only on Bookworm... ?
Man in a van
Posts: 486
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bullseye for OpenFrame

Post by Man in a van »

stripwax wrote: Tue Oct 10, 2023 1:00 pm Ok, full reinstall of Bullseye (same version as before) and it seems to be much happier. Must have been something corrupted on the memory stick. Now Playing is working as it should.
Having said that, BBC Sounds is not working for me. Does that work for you on both Bullseye AND Bookworm, or only on Bookworm... ?

It what way is BBC Sounds "not working", how are you playing it ?

ronnie
Paul Webster
Posts: 155
Joined: Mon Jul 18, 2011 7:56 am

Re: Debian Bullseye for OpenFrame

Post by Paul Webster »

If getting a complaint about unsupported sample rate then turn on hiding of it in the plugin.
Man in a van
Posts: 486
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bullseye for OpenFrame

Post by Man in a van »

If you do as Mr Webster suggests and you still have playback problems (using the Joggler speakers or headphone jack) then, on the Joggler, go to

Settings > Audio Settings > Audio Interface > and select Internal(Direct) as output.

Then open a terminal and either

sudo reboot

or

sudo systemctl restart startx.service

ronnie

make sure BBC Sounds is up to date (v2.32.1 at time of writing)

It might help to also restart LMS
Last edited by Man in a van on Wed Oct 11, 2023 9:53 am, edited 1 time in total.
stripwax
Posts: 19
Joined: Sun Dec 29, 2019 12:51 pm

Re: Debian Bullseye for OpenFrame

Post by stripwax »

Man in a van wrote: Tue Oct 10, 2023 3:06 pm make sure BBC Sounds is up to date (v2.23.1)
It might help to also restart LMS
My BBC Sounds is reporting 2.32.1 which is newer than the one you mentioned.
I've tried restarting LMS already.
Man in a van wrote: Tue Oct 10, 2023 1:19 pm It what way is BBC Sounds "not working", how are you playing it ?
Ah fair question, I should have said. No sound comes out, and error messages displayed:

"Problem: Can't open file for:
Radio 6 Music Live"

"Problem: Can't open file for:
Radio 1 LIVE"

How I'm playing it - via web interface, navigate to Home -> BBC Sounds -> Stations And Schedules -> Pick a station -> Press the Play button next to 'live'.
Paul Webster wrote: Tue Oct 10, 2023 2:33 pm If getting a complaint about unsupported sample rate then turn on hiding of it in the plugin.
That doesn't fix this problem.
Man in a van wrote: Tue Oct 10, 2023 3:06 pm If you do as Mr Webster suggests and you still have playback problems (using the Joggler speakers or headphone jack) then, on the Joggler, go to

Settings > Audio Settings > Audio Interface > and select Internal(Direct) as output.

Then open a terminal and either

sudo reboot

or

sudo systemctl restart startx.service
Ah, I must have missed this advice. This worked perfectly, thanks! And now I think I understand why you said Bookworm "does not require resetting to [Internal(direct)]"... because Bullseye does require resetting to Internal(direct)...
I used the "sudo reboot" method, because the "restart startx.service" seemed to hang. Not sure if that's expected.

I also noticed that the Quit -> Reboot option doesn't seem to do anything (nor does Quit -> Shutdown). But I'd missed that this was raised previously (Dec 22), so not a new problem. I'll try seeing if I can understand and/or fix that myself

Thanks all!
stripwax
Posts: 19
Joined: Sun Dec 29, 2019 12:51 pm

Re: Debian Bullseye for OpenFrame

Post by stripwax »

So, I worked out how to capture log output, and I've captured something interesting about the Quit -> Reboot and Quit -> Shutdown menu items

Quit -> Reboot logs this:

Code: Select all

Failed to set wall message, ignoring: Interactive authentication required.
Failed to reboot system via logind: Interactive authentication required.
Failed to start reboot.target: Interactive authentication required.
See system logs and 'systemctl status reboot.target' for details.
Quit -> Shutdown logs this (similar, different target):

Code: Select all

Failed to set wall message, ignoring: Interactive authentication required.
Failed to power off system via logind: Interactive authentication required.
Failed to start poweroff.target: Interactive authentication required.
See system logs and 'systemctl status poweroff.target' for details.
Essentially it's just doing the following, but of course failing

Code: Select all

of@openframe:/opt/squeezeplay$ systemctl reboot -i
==== AUTHENTICATING FOR org.freedesktop.login1.set-wall-message ===
Authentication is required to set a wall message
Authenticating as: of
Password:
==== AUTHENTICATION COMPLETE ===
==== AUTHENTICATING FOR org.freedesktop.login1.reboot ===
Authentication is required to reboot the system.
Authenticating as: of
Password:
==== AUTHENTICATION COMPLETE ===

There also seem to be some other steps, not necessarily captured in logs. Not sure of the 'minimal' set of actions required to permission, but creating the following file achieves the necessary to permit both Reboot and Shutdown:

filename: /etc/polkit-1/localauthority/50-local.d/squeezeplay.pkla

Code: Select all

[Permitting reboot, shutdown, etc.]
Identity=unix-user:squeezeplay
Action=org.freedesktop.login1.power-off;org.freedesktop.login1.reboot;org.freedesktop.login1.set-wall-message;org.freedesktop.login1.power-off-multiple-sessions;org.freedesktop.login1.reboot-multiple-sessions
ResultAny=yes
ResultInactive=yes
ResultActive=yes
So probably this should be added to the squeezeplay install scripts
Man in a van
Posts: 486
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Debian Bullseye for OpenFrame

Post by Man in a van »

@stripwax

Thanks for the feedback, I have corrected my typo :oops: :oops:

and can confirm your reboot/shutdown works on Bullseye :)

The old SQpos had a "refresh" button if I remember correctly.

Code: Select all

sudo systemctl restart startx.service
works for me, I see the Squeezeplay restart on the joggler

You are correct that on the terminal window the cursor does not return

I just hit Ctrl+C and it pops back :)

ronnie
stripwax
Posts: 19
Joined: Sun Dec 29, 2019 12:51 pm

Re: Debian Bullseye for OpenFrame

Post by stripwax »

Man in a van wrote: Wed Oct 11, 2023 12:10 pm I just hit Ctrl+C and it pops back :)
Yup, I spotted that too :-) seems ok. Glad the reboot/shutdown thing works for you too.
Post Reply