clean install fails

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
Post Reply
joggy
Posts: 21
Joined: Tue Jan 01, 2019 11:07 pm

clean install fails

Post by joggy »

A clean install of squeezeplay on internal memory (https://birdslikewires.net/download/ope ... 6op.img.gz) seems broken atm.

I did a

Code: Select all

sudo -i
apt update
apt install libio-socket-ssl-perl libnet-libidn-perl libnet-ssleay-perl libcrypt-openssl-rsa-perl lame
of-install squeezeplay
which gave me:

Code: Select all

Unpacking xterm (330-1ubuntu2.2) ...
dpkg: error processing archive /tmp/apt-dpkg-install-qbYd2K/65-xterm_330-1ubuntu2.2_i386.deb (--unpack):
 error creating directory './usr/share/icons/hicolor/48x48': Structure needs cleaning
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/icons/hicolor/48x48': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc-base/xterm-faq': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc-base/xterm-ctlseqs': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/xterm.terminfo.gz': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/xterm.termcap.gz': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/xterm.log.html': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/xterm.faq.html': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/xterm.faq.gz': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/ctlseqs.txt.gz': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/ctlseqs.ms.gz': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/copyright': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/changelog.Debian.gz': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/README.i18n.gz': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/README.Debian': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/doc/xterm/NEWS.Debian.gz': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-installed version of '/usr/share/doc/xterm': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/applications/debian-xterm.desktop': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/share/applications/debian-uxterm.desktop': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/bin/xterm': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/bin/uxterm': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/bin/resize': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/bin/lxterm': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/usr/bin/koi8rxterm': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/etc/X11/app-defaults/XTerm-color': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/etc/X11/app-defaults/XTerm': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/etc/X11/app-defaults/UXTerm-color': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/etc/X11/app-defaults/UXTerm': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/etc/X11/app-defaults/KOI8RXTerm-color': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of '/etc/X11/app-defaults/KOI8RXTerm': Read-only file system
dpkg: error while cleaning up:
 unable to securely remove '/var/lib/dpkg/tmp.ci': Read-only file system
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
dpkg: error processing archive /tmp/apt-dpkg-install-qbYd2K/66-xserver-xorg-legacy_2%3a1.19.6-1ubuntu4.10_i386.deb (--unpack):
 error ensuring '/var/lib/dpkg/reassemble.deb' doesn't exist: Read-only file system
dpkg: error: unable to create new file '/var/lib/dpkg/status-new': Read-only file system
E: Sub-process /usr/bin/dpkg returned an error code (2)
Configuring Xserver defaults.../usr/local/sbin/of-settings: line 321: /etc/X11/app-defaults/XTerm: Read-only file system
/usr/local/sbin/of-settings: line 322: /etc/X11/Xwrapper.config: Read-only file system
 done.
Installation of Xserver completed.
curl: symbol lookup error: /usr/lib/i386-linux-gnu/libcrypto.so.1.1: undefined symbol: , version OPENSSL_1_1_0
wget: symbol lookup error: /usr/lib/i386-linux-gnu/libcrypto.so.1.1: undefined symbol: , version OPENSSL_1_1_0
wget: symbol lookup error: /usr/lib/i386-linux-gnu/libcrypto.so.1.1: undefined symbol: , version OPENSSL_1_1_0
cat: /tmp/.md5: No such file or directory
md5sum: /tmp/: Is a directory



No checksums! Looks like the download failed.
joggy
Posts: 21
Joined: Tue Jan 01, 2019 11:07 pm

Re: clean install fails

Post by joggy »

Just tried with https://birdslikewires.net/download/ope ... 5op.img.gz

Code: Select all

sudo apt update
sudo apt upgrade

which gives:

Code: Select all

Setting up libaudit1:i386 (1:2.8.2-1ubuntu1.1) ...
(Reading database ... 17387 files and directories currently installed.)
Preparing to unpack .../libpam0g_1.1.8-3.6ubuntu2.18.04.3_i386.deb ...
Unpacking libpam0g:i386 (1.1.8-3.6ubuntu2.18.04.3) over (1.1.8-3.6ubuntu2.18.04.1) ...
Setting up libpam0g:i386 (1.1.8-3.6ubuntu2.18.04.3) ...
Can't load '/usr/lib/i386-linux-gnu/perl/5.26/auto/POSIX/POSIX.so' for module POSIX: /usr/lib/i386-linux-gnu/perl/5.26/auto/POSIX/POSIX.so: invalid ELF header at /usr/share/perl/5.26/XSLoader.pm line 96.
 at /usr/lib/i386-linux-gnu/perl/5.26/POSIX.pm line 24.
Compilation failed in require at /usr/share/perl5/Debconf/Template.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: error processing package libpam0g:i386 (--configure):
 installed libpam0g:i386 package post-installation script subprocess returned error exit status 255
Errors were encountered while processing:
 libpam0g:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
of@openframe:~$ 
User avatar
roobarb!
Posts: 1723
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: clean install fails

Post by roobarb! »

Hmm, thanks for this @joggy - I don't immediately spot anything terrible in the build logs, could you try an earlier release?
birdslikewires.net - Upgrade your OpenFrame to Debian Bullseye with the latest 5.10 kernel! 8-)
joggy
Posts: 21
Joined: Tue Jan 01, 2019 11:07 pm

Re: clean install fails

Post by joggy »

https://birdslikewires.net/download/ope ... 5op.img.gz
with
https://birdslikewires.net/download/ope ... _of.img.gz

Code: Select all

sudo apt update
sudo apt upgrade

Code: Select all

Setting up policykit-1 (0.105-20ubuntu0.18.04.6) ...
Removed /run/systemd/system/polkit.service.
polkit.service is a disabled or a static unit not running, not starting it.
polkit.service is a disabled or a static unit not running, not starting it.
Processing triggers for dbus (1.12.2-1ubuntu1.2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for libc-bin (2.27-3ubuntu1.4) ...
Processing triggers for initramfs-tools (0.130ubuntu3.13) ...
ln: failed to create hard link '/boot/initrd.img-3.16.85op.dpkg-bak' => '/boot/initrd.img-3.16.85op': Operation not permitted
update-initramfs: Generating /boot/initrd.img-3.16.85op
fatal error: runtime: out of memory

runtime stack:
runtime.throw(0xb764a11f, 0x16)
        /usr/lib/go-1.10/src/runtime/panic.go:616 +0x77 fp=0xbff515b8 sp=0xbff515ac pc=0xb75b0ce7
runtime.sysMap(0x8dbf8000, 0x9734000, 0xb75af901, 0xb772c698)
        /usr/lib/go-1.10/src/runtime/mem_linux.go:227 +0x121 fp=0xbff515e4 sp=0xbff515b8 pc=0xb759aa61
runtime.(*mheap).mapBits(0xb771cce0, 0x9732c000)
        /usr/lib/go-1.10/src/runtime/mbitmap.go:160 +0x9a fp=0xbff515fc sp=0xbff515e4 pc=0xb759749a
runtime.(*mheap).setArenaUsed(0xb771cce0, 0x9732c000, 0x8712b000)
        /usr/lib/go-1.10/src/runtime/mheap.go:545 +0x2a fp=0xbff51608 sp=0xbff515fc pc=0xb75a870a
runtime.(*mheap).init(0xb771cce0, 0x8712c000, 0x200000)
        /usr/lib/go-1.10/src/runtime/mheap.go:530 +0x3f1 fp=0xbff5161c sp=0xbff51608 pc=0xb75a8461
runtime.mallocinit()
        /usr/lib/go-1.10/src/runtime/malloc.go:392 +0x1f1 fp=0xbff51660 sp=0xbff5161c pc=0xb7595191
runtime.schedinit()
        /usr/lib/go-1.10/src/runtime/proc.go:490 +0x84 fp=0xbff51690 sp=0xbff51660 pc=0xb75b3874
runtime.rt0_go(0xbff517a4, 0x1, 0xb755b900, 0xbff516f0, 0x0, 0x1000000, 0xe97e3e00, 0xa, 0xbff527ba, 0xb735d589, ...)
        /usr/lib/go-1.10/src/runtime/asm_386.s:297 +0x2bd fp=0xbff51694 sp=0xbff51690 pc=0xb75d6f6d
joggy
Posts: 21
Joined: Tue Jan 01, 2019 11:07 pm

Re: clean install fails

Post by joggy »

I tried the above without upgrading and directly running 'sudo of-install squeezeplay' and then it installed without issues.
User avatar
pete
Posts: 2933
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: clean install fails

Post by pete »

Here switched over to using an external USB stick rather than the internal eMMC. Its been fine running Squeezeplayer and I haven't looked at it much relating to upgrading. I did this morning and see the same:

Code: Select all

ln: failed to create hard link '/boot/initrd.img-3.16.85op.dpkg-bak' => '/boot/initrd.img-3.16.85op': Operation not permitted
update-initramfs: Generating /boot/initrd.img-3.16.85op
fatal error: runtime: out of memory

runtime stack:
runtime.throw(0xb769e11f, 0x16)
	/usr/lib/go-1.10/src/runtime/panic.go:616 +0x77 fp=0xbf80d5a8 sp=0xbf80d59c pc=0xb7604ce7
runtime.sysMap(0x8dc46000, 0x9738000, 0xb7603901, 0xb7780698)
	/usr/lib/go-1.10/src/runtime/mem_linux.go:227 +0x121 fp=0xbf80d5d4 sp=0xbf80d5a8 pc=0xb75eea61
runtime.(*mheap).mapBits(0xb7770ce0, 0x9737e000)
	/usr/lib/go-1.10/src/runtime/mbitmap.go:160 +0x9a fp=0xbf80d5ec sp=0xbf80d5d4 pc=0xb75eb49a
runtime.(*mheap).setArenaUsed(0xb7770ce0, 0x9737e000, 0x8717e000)
	/usr/lib/go-1.10/src/runtime/mheap.go:545 +0x2a fp=0xbf80d5f8 sp=0xbf80d5ec pc=0xb75fc70a
runtime.(*mheap).init(0xb7770ce0, 0x8717e000, 0x200000)
	/usr/lib/go-1.10/src/runtime/mheap.go:530 +0x3f1 fp=0xbf80d60c sp=0xbf80d5f8 pc=0xb75fc461
runtime.mallocinit()
	/usr/lib/go-1.10/src/runtime/malloc.go:392 +0x1f1 fp=0xbf80d650 sp=0xbf80d60c pc=0xb75e9191
runtime.schedinit()
	/usr/lib/go-1.10/src/runtime/proc.go:490 +0x84 fp=0xbf80d680 sp=0xbf80d650 pc=0xb7607874
runtime.rt0_go(0xbf80d794, 0x1, 0xb75af900, 0xbf80d6e0, 0x0, 0x1000000, 0x6579c200, 0xa, 0xbf80e7b4, 0xb73b0589, ...)
	/usr/lib/go-1.10/src/runtime/asm_386.s:297 +0x2bd fp=0xbf80d684 sp=0xbf80d680 pc=0xb762af6d
I would always see
failed to create hard link '/boot/initrd.img-3.16.85op.dpkg-bak' => '/boot/initrd.img-3.16.85op': Operation not permitted

But never saw
fatal error: runtime: out of memory
and / or
runtime stack:
- Pete
O2 Jogglers running EFI Ubuntu / Squeezeplayer
OpenPeak Voip Telephony / Zigbee tabletops hardware modded with Seabios / RTC / Ethernet ROM edits / SSD drives running XPe for automation screens

Auto mater
User avatar
pete
Posts: 2933
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: clean install fails

Post by pete »

So see this on boot:

Feb 13 07:53:47 ICS-Jog-SQP-19 kernel: FAT-fs (sda1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
Feb 13 07:53:47 ICS-Jog-SQP-19 kernel: FAT-fs (sda1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

Trying to fix it.

Code: Select all

root@ICS-Jog-SQP-19:/var/log# umount /dev/sda1
root@ICS-Jog-SQP-19:/var/log# fsck.vfat -v /dev/sda1
fsck.fat 4.1 (2017-01-24)
Checking we can access the last sector of the filesystem
0x25: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
1) Remove dirty bit
2) No action
? 1
Boot sector contents:
System ID "MSWIN4.1"
Media byte 0xf8 (hard disk)
       512 bytes per logical sector
      1024 bytes per cluster
         6 reserved sectors
First FAT starts at byte 3072 (sector 6)
         2 FATs, 16 bit entries
     86016 bytes per FAT (= 168 sectors)
Root directory starts at byte 175104 (sector 342)
       512 root directory entries
Data area starts at byte 191488 (sector 374)
     42821 data clusters (43848704 bytes)
32 sectors/track, 64 heads
      2048 hidden sectors
     86016 sectors total
Checking for unused clusters.
Perform changes ? (y/n) y
/dev/sda1: 11 files, 18238/42821 clusters
root@ICS-Jog-SQP-19:/var/log#
Not sure if this is going to fix anything related to the upgrade errors above.

Rebooted and did an update and upgrade again. Since it already upgraded (35 files) with errors this time it showed no errors and no upgrades.

I am running IPv6 now on my internal network these days.

Code: Select all

Fetched 34.4 MB in 36s (965 kB/s)                                                                                                                    
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
root@ICS-Jog-SQP-19:~# apt dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
The other Jogglers here (15) are running with Seabios / embedded Windows from 16Gb SSD running two touchscreen automation interfaces and are doing well via Gb and WLAN interfaces. I do not pay much attention to these anymore. They are managed by the mothership remotely. (IE: screens off at night and typically in a clock screen saver).

Off the subject a bit been tinkering here with a larger wall mounted and modified touchscreen. Very well built with optional POE and WLAN. Using same Joggler image here for said touchscreens (with newer drivers). Found one for $25 USD. It is larger than the Joggler and is meant to be only wall mounted.
visix.jpg
visix2.jpg
- Pete
O2 Jogglers running EFI Ubuntu / Squeezeplayer
OpenPeak Voip Telephony / Zigbee tabletops hardware modded with Seabios / RTC / Ethernet ROM edits / SSD drives running XPe for automation screens

Auto mater
User avatar
pete
Posts: 2933
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: clean install fails

Post by pete »

So after the update above noticed that it would not boot to Squeezeplay.

Then I noticed I had no default users configured except for squeezeplay.

Manually installed squeezeplay script and rebooted.

Boots to a command line prompt.
- Pete
O2 Jogglers running EFI Ubuntu / Squeezeplayer
OpenPeak Voip Telephony / Zigbee tabletops hardware modded with Seabios / RTC / Ethernet ROM edits / SSD drives running XPe for automation screens

Auto mater
User avatar
pete
Posts: 2933
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: clean install fails

Post by pete »

So via command line redid the build...IE: didn't want to build the stick from scratch...

1 - of-install build
2 - of-install squeezeplay

I did not do an update or upgrade after the above.

htop and top show

695 squeeze+ 20 0 8488 3104 2880 S 0.7 0.6 0:01.90 jive_alsa

running.
- Pete
O2 Jogglers running EFI Ubuntu / Squeezeplayer
OpenPeak Voip Telephony / Zigbee tabletops hardware modded with Seabios / RTC / Ethernet ROM edits / SSD drives running XPe for automation screens

Auto mater
User avatar
roobarb!
Posts: 1723
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: clean install fails

Post by roobarb! »

I started looking into this and became "usefully sidetracked". With a little luck I should have some positive image-related news soon.

That "failed to create hard link" error is not a real problem, by the way. The updater tries to link to a backup, but it fails because the boot volume is FAT and does not support linking. Then everything continues as normal. The effort of hiding that message far outweighs the problems caused by the message itself in this instance.
birdslikewires.net - Upgrade your OpenFrame to Debian Bullseye with the latest 5.10 kernel! 8-)
Post Reply