Two Jogglers failed within hours

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
Post Reply
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Two Jogglers failed within hours

Post by Heuer »

One of my Jogglers, running the latest Squeezeplay V7.8 image, froze yesterday on the Now Playing screen. It was totally unresponsive so I plulled the plug to reboot but it came back with an O2/Squeezeplay boot loop. Thinking nothing of it I reflashed it and everything ran perfectly. A few hours later I went into the Kitchen to find another Joggler was frozen and when rebooted showed the same boot loop problem. Reflash fixed it.

I am using LMS V8.1 on a Win 10 machine. Although the Jogglers froze the music and other SB players continued as normal. They were both controlling different players with different radio streams (Radio Paradise and Offshore Music Radio). Squeezeplay is flashed to internal memory on both and they have been working perfectly for months. Any thoughts?
Man in a van
Posts: 340
Joined: Sun Aug 25, 2013 2:39 pm
Location: Staffordshire. UK

Re: Two Jogglers failed within hours

Post by Man in a van »

Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: Two Jogglers failed within hours

Post by Heuer »

Thanks! I was on the 20th Jan nightly and had not spotted the implications of the latest builds. Just updated so hopefully all will be OK.
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: Two Jogglers failed within hours

Post by Heuer »

One of these Joggler failed again today. Crashed to login prompt so I logged in and rebooted and I had the O2/Squeezeplay boot cycle. LMS is up to date. Is this failing internal memory?
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: Two Jogglers failed within hours

Post by Heuer »

I reflashed it and it crashed when I tried to select a different song. Decided the common link could be the USB drive I was using so I have reflashed with a new one and things seem stable. Will report back if anything changes.
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: Two Jogglers failed within hours

Post by Heuer »

Still happening! I can repeat the problem by tapping next track in Now Playing at which point it falls back to the login prompt. Reboot gets me back into Squeezeplay and I can navigate around but I can't get into the Now Playing screen. I can control my SB, select Favourites, search and play music. Looks like something to do with Now Playing as if I do get there it is what causes the crash.

Any ideas?
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: Two Jogglers failed within hours

Post by Heuer »

Second Joggler crashed of its own accord. First Joggler with Squeezeplay, now on USB stick, also crashed to login screen when forwarding to next track. Only common thing I can find is that both were doing Random Song Mix from the NAS library. Re-booting it is producing this scrolling message:
Image
Paul Webster
Posts: 113
Joined: Mon Jul 18, 2011 7:56 am

Re: Two Jogglers failed within hours

Post by Paul Webster »

Perhaps fsck would tidy things up.

Is it left powered up 24*7 ?
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: Two Jogglers failed within hours

Post by Heuer »

Yes, both powered up 24/7. They don't seem to have a problem with Radio Paradise or other internet stations. It is just Random Play/Songs where the problem seems to lie. Basically skipping several songs forwards causes the Joggler to crash in various ways - command prompt, O2 boot loop or scrolling error messages. They have been working fine for weeks. fsck shows nothing but then I just reflashed.
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: Two Jogglers failed within hours

Post by Heuer »

Reverted to earlier LMS 8.1.1 build and the Jogglers are happy again. Looks like whatever was inroduced between 8.1.1 and 8.1.2 causes a catastrophic crash.
Heuer
Posts: 15
Joined: Wed Dec 30, 2020 12:10 pm

Re: Two Jogglers failed within hours

Post by Heuer »

Quick update. LMS 8.1.1 was no better. After about 10 songs the Joggler fell back to the command prompt. Tried both internal and external flash to no avail. I solved the problem by flashing JiveLite for Joggler to internal and it plays perfectly for hours on end. Also no need to modify network.yaml as you can set WiFi up within Jive. Details here: https://forums.slimdevices.com/showthre ... ler/page17
User avatar
roobarb!
Posts: 1662
Joined: Sat Mar 05, 2011 1:30 pm
Location: Salford, UK
Contact:

Re: Two Jogglers failed within hours

Post by roobarb! »

That does look like poorly storage.
Post Reply