Joggler Problems (2 Jogglers, different prblems)

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
Post Reply
DamianS
Posts: 18
Joined: Mon Dec 14, 2020 12:53 pm

Joggler Problems (2 Jogglers, different prblems)

Post by DamianS »

Hi All,

OK, I'm about a week in to owning Jogglers. The 2nd one only arrived today, but I'm already getting serious headaches! :-)

The First Joggler.
This keeps getting a weird problem where I just can't get to the 'Now Playing' screen any more. I press on it, but nothing happens.
A reboot results in the audio auto starting, but still unable to get to 'Now Playing'.

As it's now nice and quick for me to go through the "Install Ubuntu 18.04 to the internal, then add Squeezeplay" procedure, I've done that a couple of times.
Once, all was fine again and then the 'Now playing' issue came back.

The last time, all was going well, and then I got this ...
Image

Trying to reinstall again left me in an infinite loop, so I'm currently in the process of running openpeak-small_12-06-14.img and then trying again.

The Second Joggler.
This one has been behaving very well and doing everything that I wanted it to.
However, no sooner do I get it set up in its final destination than it drops out to a command prompt!

I rebooted, and the same thing happened again.

I read something, somewhere, about temperature issues with Jogglers, so I felt the back of the unit. It just felt mildly warm to me. No level of heat that would concern me.
Any idea if there's anything that I can do about this?

Are the two units just too old to be useful?

Thanks,
Damian
User avatar
hawsey
Posts: 2002
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Joggler Problems (2 Jogglers, different prblems)

Post by hawsey »

DamianS wrote:Hi All,

OK, I'm about a week in to owning Jogglers. The 2nd one only arrived today, but I'm already getting serious headaches! :-)

The First Joggler.
This keeps getting a weird problem where I just can't get to the 'Now Playing' screen any more. I press on it, but nothing happens.
A reboot results in the audio auto starting, but still unable to get to 'Now Playing'.

As it's now nice and quick for me to go through the "Install Ubuntu 18.04 to the internal, then add Squeezeplay" procedure, I've done that a couple of times.
Once, all was fine again and then the 'Now playing' issue came back.

The last time, all was going well, and then I got this ...
Image

Trying to reinstall again left me in an infinite loop, so I'm currently in the process of running openpeak-small_12-06-14.img and then trying again.

The Second Joggler.
This one has been behaving very well and doing everything that I wanted it to.
However, no sooner do I get it set up in its final destination than it drops out to a command prompt!

I rebooted, and the same thing happened again.

I read something, somewhere, about temperature issues with Jogglers, so I felt the back of the unit. It just felt mildly warm to me. No level of heat that would concern me.
Any idea if there's anything that I can do about this?

Are the two units just too old to be useful?

Thanks,
Damian
It could be that the internal memory is failing , try set up using a Usb stick in the side port instead , if that works you can get some very cheap stumpy black usb sticks that are hardly noticeable . Out of 8 I have 2 Jogglers that only boot with a Usb stick .
I doubt there is much wrong with them as they are pretty robust devices .
Good luck Image

Sent from my VOG-L29 using Tapatalk

Happy Joggling
DamianS
Posts: 18
Joined: Mon Dec 14, 2020 12:53 pm

Re: Joggler Problems (2 Jogglers, different prblems)

Post by DamianS »

Thanks hawsey,

I've started running one of them via external USB, and it's not dropped to the command prompt yet.
User avatar
hawsey
Posts: 2002
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Joggler Problems (2 Jogglers, different prblems)

Post by hawsey »

Nice one some people also put a usb stick internally in place of the usb wireless card which isn't the best then fit an external usb WiFi Dongle in the side port .
There is a recommended supported one but I forget what it is at the moment.

Sent from my VOG-L29 using Tapatalk

Happy Joggling
jkn
Posts: 114
Joined: Sat Jul 16, 2011 11:18 am

Re: Joggler Problems (2 Jogglers, different prblems)

Post by jkn »

hawsey wrote: Thu Dec 31, 2020 2:27 pm Nice one Image some people also put a usb stick internally in place of the usb wireless card which isn't the best then fit an external usb WiFi Dongle in the side port .
There is a recommended supported one but I forget what it is at the moment.

Sent from my VOG-L29 using Tapatalk
I think the Netgear WNDA3200 is recommended here (I have just put one away - New Year's day tidying!). Still haven't got around to fitting this, maybe 2021 will be the year...
User avatar
DJWillis
Posts: 5
Joined: Wed Aug 24, 2011 8:39 pm

Re: Joggler Problems (2 Jogglers, different problems)

Post by DJWillis »

DamianS wrote: Tue Dec 29, 2020 3:21 am The First Joggler.
This keeps getting a weird problem where I just can't get to the 'Now Playing' screen any more. I press on it, but nothing happens.
A reboot results in the audio auto starting, but still unable to get to 'Now Playing'.
Seen this loads of times with SqueezePlay/Jive on flash based devices (inc. my Jogglers but also on other similar devices).

It seems SqueezePlay holds a lock on some of the files associated with the now playing setup and anything like a power blip or a crash will lead to corruption on that underlaying part of the FS. Seems to happen more commonly on EXT2/3 based FS's rather than specific flash filesystems. Not seen it on the few devices that are F2FS onto eMMC (or UBIFS onto the RAW NAND flash.

A simple FSCK over SSH will get the FS node sorted and Now Playing working again if you want a quick fix.

It seems to happen fairly regularly on a few with the internal flash (I think the combo of EXT2 and the internal flash over the years is leading to a failures creeping in) but it also happens on the units have that external USB flash roots, especially the ones with cheap flash sticks.

Playing with a more flash friendly filesystem on the Joggler, especially for the internal storage, has been on my list for ages but I normally just FSCK or reinstall and have my SqueezeServer copy the old config back, it's so quick with roobarb's scripts that it has not yet pushed me to sort something else :-).

Edit: I should add this refers to the Now Playing corruption, if your getting worse problems such as what you have seen with the reflash, then your internal storage is dead/dying and you really should just use a tiny USB stick as others have pointed out. A slim stick in the side is really hard to notice.
Post Reply