Ubuntu / Xubuntu for the O2 Joggler.

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
monkeydogcat
Posts: 23
Joined: Sat Aug 27, 2011 6:39 pm

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by monkeydogcat » Fri Jul 29, 2016 10:16 pm

pete wrote:You are right monkeydogcat.
There's a sentence you never thought you're write. ;) What a bloody stupid username it looks when I see someone else write it…
pete wrote: Best you heed Jool's last post...Joggler Obi Wan extraordinaire
Indeed. All hail Jools, he who puts things I'm not entirely clear on in to Ubuntu builds and makes our Jogglers useful.

My problems with kodi are 1] It has pretty much no command line options. 2] No apparent way to make it start up, play video, exit when video ends, 3] It takes so, very, long to actually play a video. I just timed it launching to play a 1280x720 video and it took 11 seconds from my hitting Enter to the video actually starting to play. mplayer took 1.5 seconds. mplayer, yes mplayer, for I have a working mplayer binary that uses vaapi. :D

I decided to try rebuilding Jool's mplayer-vaapi package for 14.04. It was quite an adventure because I've never built a deb package before. Also I decided to do the build on the Joggler. Partly because it seemed easier than creating another Xubuntu build in a VM to use, and partly just to see how long it would take. As I mentioned, there was insufficient space in / to install all the requried build depdendencies. There was plenty of empty space on the flash drive I'm using though, so I deleted the / partition with fdisk and recreated it bigger, then resized the filesystem. Then I installed all the build dependencies. Then I throttled the CPU out of fear that running it at 1.3Ghz for long enough to compile something, combined with the not entirely adequate CPU cooling capabilities of the Joggler, may melt it. In a sudo shell:

Code: Select all

$ echo powersave |tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
And here's what I did to try and build the .deb. I say try, because I failed twice then gave up. But maybe someone else wants to try and this will save them a bit of time.

I figured out I needed to download mplayer-vaapi_1.0~rc5.git20111027.orig.tar.gz mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.dsc mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.debian.tar.gz from https://launchpad.net/~jools/+archive/u ... /+packages I stuck them all in a directory by themselves, then

Code: Select all

$ dpkg-source -x mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.dsc
$ cd mplayer-vaapi-1.0~rc5.git20111027/
$ time dpkg-buildpackage -rfakeroot -b 
After about 11 minutes the build process bombed. With an error relating to liblivemedia. (http://mplayerhq.hu/pipermail/mplayer-u ... 86407.html) I don't care about RTSP streaming so rather than try the patch mentioned in that email thread I editted the control file to remove the reference to liblivemedia. The next build attempt ran for 51 minutes before exiting with an error about mencoder. I couldn't figure out what was wrong, but I did figure out I do not care about mencoder, so I edited the rules file to add --disable-mencoder to the list of configure options. The next build attempt failed in the same way though, so evidently more is required that I did to disable mencoder in the build.

At this point I decided I didn't really care about having a .deb package. So I decided to just try building mplayer.

Code: Select all

$ time  ./configure  --prefix=/home/joggler/mplayer-vaapi  --confdir=/home/joggler/etc/mplayer --enable-xvmc  --enable-vaapi  --disable-arts  --disable-mencoder
It took 42 minutes.

I now have an mplayer binary that will play http://download.blender.org/peach/bigbu ... p_h264.mov fullscreen using no more than 15% CPU. Which is something glorious to behold.

Code: Select all

joggler@joggler:~$ mplayer-vaapi/bin/mplayer -fs -vo vaapi big_buck_bunny_1080p_h264.mov 
If I specify -nosound it uses less than 10% CPU. I know it's not the latest and greatest version of mplayer, but it seems to work more than adequately for my purposes and I'm really rather pleased with it.

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Sat Jul 30, 2016 2:13 am

Great news MDC!

I have left the cover off of the CPU for hours when doing that hot swap of the EFI boot rom chip and never paid attention to the heat.

So now you got me trying over here to update mplayer.

So in recap you download (wget)

Code: Select all

1 - mplayer-vaapi_1.0~rc5.git20111027.orig.tar.gz
wget hxxps://launchpad.net/~jools/+archive/ubuntu/joggler/+files/mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.debian.tar.gz
2 - mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.dsc
wget hxxps://launchpad.net/~jools/+archive/ubuntu/joggler/+files/mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.dsc
3- mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.debian.tar.gz
wget https://launchpad.net/~jools/+archive/ubuntu/joggler/+files/mplayer-vaapi_1.0~rc5.git20111027.orig.tar.gz
4 - apt-get install dpkg-dev
5 - dpkg-source -x mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.dsc
6 - cd mplayer-vaapi-1.0~rc5.git20111027/
7 - time dpkg-buildpackage -rfakeroot -b 
At this point it bombed like you wrote above.

Code: Select all

dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)
real	0m4.657s
user	0m4.216s
sys	0m0.300s
Yeah here do use RTSP...but want to try your stuff.

Went to the control file.

Code: Select all

root@joggler:~/mplayer-vaapi-1.0~rc5.git20111027/debian# ls
changelog       gbp.conf                 mplayer-doc.doc-base.es  mplayer.examples  patches
clean           mplayer.conf             mplayer-doc.doc-base.fr  mplayer-gui.menu  prefs
compat          mplayer-dbg.links        mplayer-doc.doc-base.hu  mplayer-gui.mime  README.Debian
control         mplayer-doc.doc-base.cs  mplayer-doc.doc-base.pl  mplayer.install   README.source
copyright       mplayer-doc.doc-base.de  mplayer-doc.doc-base.ru  mplayer.mime      rules
daily-build.sh  mplayer-doc.doc-base.en  mplayer-doc.docs         mplayer.preinst   source
root@joggler:~/mplayer-vaapi-1.0~rc5.git20111027/debian# cd ..
root@joggler:~/mplayer-vaapi-1.0~rc5.git20111027# cd debian

Code: Select all

root@joggler:~/mplayer-vaapi-1.0~rc5.git20111027/debian# ls
changelog       gbp.conf                 mplayer-doc.doc-base.es  mplayer.examples  patches
clean           mplayer.conf             mplayer-doc.doc-base.fr  mplayer-gui.menu  prefs
compat          mplayer-dbg.links        mplayer-doc.doc-base.hu  mplayer-gui.mime  README.Debian
control         mplayer-doc.doc-base.cs  mplayer-doc.doc-base.pl  mplayer.install   README.source
copyright       mplayer-doc.doc-base.de  mplayer-doc.doc-base.ru  mplayer.mime      rules
daily-build.sh  mplayer-doc.doc-base.en  mplayer-doc.docs         mplayer.preinst   source
root@joggler:~/mplayer-vaapi-1.0~rc5.git20111027/debian#
editted the control file to remove the reference to liblivemedia

nano control

Code: Select all

libgl1-mesa-dev,
 libgtk2.0-dev,
 libjack-dev,
 liblircclient-dev,
==> remove this ==> liblivemedia-dev,
 liblzo2-dev,
 libmp3lame-dev,
 libmpcdec-dev,
 libmpeg2-4-dev,
 libncurses5-dev,
 libopenal-dev,
 libpng12-dev | libpng-dev,
 libpulse-dev,
 libschroedinger-dev,
 libsmbclient-dev,
 libspeex-dev,
Tried again.

Code: Select all

time dpkg-buildpackage -rfakeroot -b
Error as you got above.

Code: Select all

dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)
real	0m3.150s
user	0m2.924s
sys	0m0.208s
root@joggler:~/mplayer-vaapi-1.0~rc5.git20111027# 
as you did above I then decided to just try building mplayer.

Code: Select all

time  ./configure  --prefix=/home/joggler/mplayer-vaapi  --confdir=/home/joggler/etc/mplayer --enable-xvmc  --enable-vaapi  --disable-arts  --disable-mencoder
Here got another error...a bit different this time.

Code: Select all

Checking for yasm ... 
Error: yasm not found, use --yasm='' if you really want to compile without
Check "config.log" if you do not understand why it failed.
real	0m5.430s
user	0m3.176s
sys	0m1.332s
Did it again with --yasm=''

Code: Select all

time  ./configure  --prefix=/home/joggler/mplayer-vaapi  --confdir=/home/joggler/etc/mplayer --enable-xvmc  --enable-vaapi  --disable-arts  --disable-mencoder --yasm=''


This time it looked like it worked.

Code: Select all

Config files successfully generated by ./configure --prefix=/home/joggler/mplayer-vaapi --confdir=/home/joggler/etc/mplayer --enable-xvmc --enable-vaapi --disable-arts --disable-mencoder --yasm= !

  Install prefix: /home/joggler/mplayer-vaapi
  Data directory: /home/joggler/mplayer-vaapi/share/mplayer
  Config direct.: /home/joggler/etc/mplayer

'config.h' and 'config.mak' contain your configuration options.
Note: If you alter theses files (for instance CFLAGS) MPlayer may no longer
      compile *** DO NOT REPORT BUGS if you tweak these files ***

'make' will now compile MPlayer and 'make install' will install it.
Note: On non-Linux systems you might need to use 'gmake' instead of 'make'.

Please check MTRR settings at /proc/mtrr (see DOCS/HTML/en/video.html#mtrr)

Check config.log if you wonder why an autodetection failed (make sure
development headers/packages are installed).

NOTE: The --enable-* parameters unconditionally force options on, completely
skipping autodetection. This behavior is unlike what you may be used to from
autoconf-based configure scripts that can decide to override you. This greater
level of control comes at a price. You may have to provide the correct compiler
and linker flags yourself.
If you used one of these options (except --enable-menu and similar ones that
turn on internal features) and experience a compilation or linking failure,
make sure you have passed the necessary compiler/linker flags to configure.

If you suspect a bug, please read DOCS/HTML/en/bugreports.html.


real	0m31.262s
user	0m17.249s
sys	0m8.801s
Now to test.

I am only doing an SSH here as my Joggler is in a different part of the house and I am still waking up.

Curious here about the time of doing this seemed a bit faster. Why is that?

Code: Select all

1 - wget hxxp://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_1080p_h264.mov
This is taking a while to download.
- Pete

Auto mater

monkeydogcat
Posts: 23
Joined: Sat Aug 27, 2011 6:39 pm

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by monkeydogcat » Sat Jul 30, 2016 3:03 pm

pete wrote: I am only doing an SSH here as my Joggler is in a different part of the house and I am still waking up.
I do all interaction with the Joggler over SSH, unless it requires actually touching the screen.

Code: Select all

joggler@joggler:~$ export ICEAUTHORITY=/home/joggler/.ICEauthority 
joggler@joggler:~$ export DISPLAY=:0
joggler@joggler:~$ xeyes
pete wrote: Curious here about the time of doing this seemed a bit faster. Why is that?
Looking back at my post I realise that I show the configure command and then say it took 42 minutes. Which is nonsense. The 42 minutes it how long it took to do the actual build. i.e. this

Code: Select all

$ ./configure  --prefix=/home/joggler/mplayer-vaapi  --confdir=/home/joggler/etc/mplayer --enable-xvmc  --enable-vaapi  --disable-arts  --disable-mencoder
$ time make -j 2
If you don't throttle the CPU to 800Mhz you'll probably find it takes less than 42 minutes.

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Sat Jul 30, 2016 3:25 pm

Thank you MDC.

Yeah here still have not ventured downstairs (3 levels). Did download the video file. See / smell that wife is making breakfast.

Did the following and see an error.

Code: Select all

root@joggler:~# xeyes
No protocol specified
Error: Can't open display: :0
Logged out as root and logged in as Joggler.

j

Code: Select all

oggler@joggler:~$ export ICEAUTHORITY=/home/joggler/.ICEauthority 
joggler@joggler:~$ export DISPLAY=:0
joggler@joggler:~$ xeyes
Just get a blinking cursor here. I am guessing that it is working??
- Pete

Auto mater

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Sat Jul 30, 2016 4:14 pm

OK went downstairs to being in front of the Joggler.

testing this line:

joggler@joggler:~$ mplayer-vaapi/bin/mplayer -fs -vo vaapi big_buck_bunny_1080p_h264.mov

Ahh...

Where is the directory mplayer-vaapi/bin at? I cannot find it under the mplayer-vaapi* directory.

I see now where I messed up. Did everything in root and it should have been done using Joggler.

Not an issue, will do it again.
- Pete

Auto mater

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Sat Jul 30, 2016 9:16 pm

OK did it again using username joggler.

Still stuck here at:

joggler@joggler:~$ mplayer-vaapi/bin/mplayer -fs -vo vaapi big_buck_bunny_1080p_h264.mov

-bash: mplayer-vaapi/bin/mplayer: No such file or directory
- Pete

Auto mater

monkeydogcat
Posts: 23
Joined: Sat Aug 27, 2011 6:39 pm

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by monkeydogcat » Sat Jul 30, 2016 10:18 pm

pete wrote:OK did it again using username joggler.

Still stuck here at:

joggler@joggler:~$ mplayer-vaapi/bin/mplayer -fs -vo vaapi big_buck_bunny_1080p_h264.mov

-bash: mplayer-vaapi/bin/mplayer: No such file or directory
Did you run "make install"? I know I didn't mentioned the need to do that. I've been posting sort of half arsed instructions without bothering to think about what I'm doing or whether people will be able to fill in the missing bits.

There's three steps to building something, configure, building it, then installing it to wherever you specified

Code: Select all

$ ./configure  --prefix=/home/joggler/mplayer-vaapi  --confdir=/home/joggler/etc/mplayer --enable-xvmc  --enable-vaapi  --disable-arts  --disable-mencoder
$ make -j 2
$ make install

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Sat Jul 30, 2016 11:34 pm

Thank you MDC.

Yup originally just tried make and make install.

Redid build with make -j 2 and make install

I see my issue. Forgot to install yasm. Never installed it from the beginning issue I saw.

Frustrating it is still an issue here...

I see this at the end of make -j 2

Code: Select all

l[i]ibvo/vo_xvmc.c:31:22: fatal error: X11/Xlib.h: No such file or directory
 #include <X11/Xlib.h>
                      ^
compilation terminated.
make: *** [libvo/vo_xvmc.o] Error 1[/i]
and this with make install

Code: Select all

root@joggler:~/mplayer-vaapi-1.0~rc5.git20111027# make install
cc -MD -MP -Wundef -Wall -Wno-switch -Wno-parentheses -Wpointer-arith -Wredundan                                                                              t-decls -Wstrict-prototypes -Wmissing-prototypes -Wdisabled-optimization -Wno-po                                                                              inter-sign -Wdeclaration-after-statement -std=gnu99 -Werror-implicit-function-de                                                                              claration -O4 -march=native -mtune=native -pipe -ffast-math -fomit-frame-pointer                                                                               -fno-tree-vectorize -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_S                                                                              OURCE -Ilibdvdread4 -I. -Iffmpeg  -D_REENTRANT -c -o libvo/vo_xvmc.o libvo/vo_xv                                                                              mc.c
libvo/vo_xvmc.c:31:22: fatal error: X11/Xlib.h: No such file or directory
 #include <X11/Xlib.h>
                      ^
compilation terminated.
make: *** [libvo/vo_xvmc.o] Error 1
Googling installed this:

sudo apt-get install libx11-dev

Nothing yet. I know I am making a mountain out of a mole hill.
- Pete

Auto mater

monkeydogcat
Posts: 23
Joined: Sat Aug 27, 2011 6:39 pm

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by monkeydogcat » Sun Jul 31, 2016 3:35 pm

pete wrote:

Code: Select all

root@joggler:~/mplayer-vaapi-1.0~rc5.git20111027# make install
cc -MD -MP -Wundef -Wall -Wno-switch -Wno-parentheses -Wpointer-arith -Wredundan                                                                              t-decls -Wstrict-prototypes -Wmissing-prototypes -Wdisabled-optimization -Wno-po                                                                              inter-sign -Wdeclaration-after-statement -std=gnu99 -Werror-implicit-function-de                                                                              claration -O4 -march=native -mtune=native -pipe -ffast-math -fomit-frame-pointer                                                                               -fno-tree-vectorize -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_S                                                                              OURCE -Ilibdvdread4 -I. -Iffmpeg  -D_REENTRANT -c -o libvo/vo_xvmc.o libvo/vo_xv                                                                              mc.c
libvo/vo_xvmc.c:31:22: fatal error: X11/Xlib.h: No such file or directory
 #include <X11/Xlib.h>
                      ^
compilation terminated.
make: *** [libvo/vo_xvmc.o] Error 1
Googling installed this:

sudo apt-get install libx11-dev

Nothing yet. I know I am making a mountain out of a mole hill.
Well building stuff from source can be a painful cycle of "try to build, oh something needs to be installed, try to build, oh something needs to be installed, repeat N times". It's my experience that sometimes the configure script will display clear error messages until such time as you run it will all the dependencies required to get a working build are installed. I like those experiences. It's much nicer when configure tells you there's something wrong than waiting for make to. It's also my experience that sometimes the configure script will not display any warnings, so I invoke make then look back at it later and find it's quit with an error because there's a missing dependency.

Here's a way to get all the required dependencies for Jool's mplayer-vappi installed in one go

Code: Select all

$ cd /path/to/directory/with/the/control/file/in/
$ sudo apt-get install $(sed  -n '/Build-Depends/ ,/^$/p'  control | grep -v "Build-Depends" | tr ',' ' ' | tr ' ' '\n' | grep ^[a-z] | grep -v livemedia |tr '\n' ' ' )
It's a ridiculous command that relies on there being an empty line after the list of packages. There's surely a better way. I know there is a better way if you have installed the source for a .deb from an src-deb repo, but Jool's mlayer-vappi is for an older version of Xubuntu so doesn't who up in the repos for 14.04.

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Sun Jul 31, 2016 8:45 pm

Thank you MDC for helping me understand this stuff.

I will not give up until it is working.

That said today has been a "princess" day from the early morning. None stop. Just fixed one little issue with her auto mobile; which really wasn't much of a big deal until I spent the time to look. None of this stuff though relates to computers and it will consume my day.
- Pete

Auto mater

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Mon Aug 01, 2016 12:38 pm

Thank you MDC! Tried this again late last night. Looks like it worked!!!

Here's a way to get all the required dependencies for Jool's mplayer-vappi installed in one go

Looks like this worked for me.

I walked away as it appears to have ran for much time and this morning tried it and it seems to have worked.
Documenting this for others.
1 - cd /home/joggler/mplayer-vaapi-1.0~rc5.git20111027
2 - sudo apt-get install $(sed -n '/Build-Depends/ ,/^$/p' control | grep -v "Build-Depends" | tr ',' ' ' | tr ' ' '\n' | grep ^[a-z] | grep -v livemedia |tr '\n' ' ' )
3 - dpkg-source -x mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.dsc
4 - cd mplayer-vaapi-1.0~rc5.git2011102
5 - time dpkg-buildpackage -rfakeroot -b
6 - time ./configure --prefix=/home/joggler/mplayer-vaapi --confdir=/home/joggler/etc/mplayer --enable-xvmc --enable-vaapi --disable-arts --disable-mencoder
7 - time make -j 2 * I walked away at this point and do not know how long it took
8 - make install
9 - noticed that the mplayer-vaapi directory was created this time around. It has not done this previously.

Code: Select all

joggler@joggler:~$ ls
big_buck_bunny_1080p_h264.mov      mplayer-vaapi                                                        Pictures
Desktop                            mplayer-vaapi-1.0~rc5.git20111027                                    PlayOnLinux's virtual drives
Documents                          mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.debian.tar.gz  Public
Downloads                          mplayer-vaapi_1.0~rc5.git20111027-1ubuntu1~lucid~ppa2.dsc            Templates
etc                                mplayer-vaapi_1.0~rc5.git20111027.orig.tar.gz                        Videos
10 -

Code: Select all

joggler@joggler:~$ cd mplayer-vaapi
joggler@joggler:~/mplayer-vaapi$ ls
bin  lib  share
joggler@joggler:~/mplayer-vaapi$ 
- Pete

Auto mater

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Mon Aug 01, 2016 12:57 pm

Still cannot get it to play video. Here is what I see:

joggler@joggler:~/mplayer-vaapi/bin$ mplayer
mplayer: /usr/lib/i386-linux-gnu/libva.so.1: no version information available (required by mplayer)
MPlayer SVN-r36265-4.8 (C) 2000-2013 MPlayer Team
Cannot test OS support for SSE, disabling to be safe.


Message I keep seeing is Fatal cannot initialize video driver.

Got it. It was defaulting to the old mplayer.

Changed it as above to:

/home/joggler/mplayer-vaapi/bin/mplayer -fo -vo /home/joggler/test.mov

and it played video just fine and very fast.

Next tried:

/home/joggler/mplayer-vaapi/bin/mplayer /home/joggler/test.mov

and that too played video fine.

Code: Select all

joggler@joggler:~/mplayer-vaapi/bin$ /home/joggler/mplayer-vaapi/bin/mplayer -fs -vo vaapi /home/joggler/test.mov
MPlayer UNKNOWN-4.8 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/joggler/test.mov.
libavformat version 53.22.0 (internal)
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x89576a0]Unknown container channel layout.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 2: audio (aac), -aid 0, -alang eng
VIDEO:  [H264]  1920x1080  24bpp  24.000 fps  9282.6 kbps (1133.1 kbyte/s)
Clip info:
 major_brand: qt  
 minor_version: 537199360
 compatible_brands: qt  
 creation_time: 2008-05-27 18:40:35
Load subtitles in /home/joggler/
libva: VA-API version 0.32.1
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/i386-linux-gnu/dri/emgd_drv_video.so
Intel(R) Embedded Media and Graphics Driver 1.18 Build 3398
Using XCB based dispatch table.
libva: va_openDriver() returns 0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 53.39.1 (internal)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 6 ch, s16le, 437.6 kbit/9.50% (ratio: 54700->576000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Next steps......how to I default to this version of mplayer?

Just copy all of the files to the root?
- Pete

Auto mater

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Mon Aug 01, 2016 5:32 pm

BTW using MPlayer faster than using VLC. Here do calls from my automation touchscreens (press a button) to external programs and have been using mostly VLC for this type of stuff.
- Pete

Auto mater

Error
Posts: 243
Joined: Wed Sep 18, 2013 2:13 pm

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by Error » Tue Aug 02, 2016 9:07 pm

on the squeezeplay version via Ubuntu, how is this reachable via IP-address?
ip-address:9000 won't work...

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Wed Aug 03, 2016 1:11 am

I think it is running SqueezePlayer only. That said you can install it if you wanted to. The default Squeezeplayer OS does include this option.
- Pete

Auto mater

Andrew1971
Posts: 75
Joined: Tue Oct 30, 2012 12:49 pm

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by Andrew1971 » Wed Aug 03, 2016 6:52 pm

Hi All
Is there any chance on getting the ubuntu netbook remix interface on the joggler
if so how.
Andrew

monkeydogcat
Posts: 23
Joined: Sat Aug 27, 2011 6:39 pm

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by monkeydogcat » Wed Aug 03, 2016 11:28 pm

pete wrote: Changed it as above to:

/home/joggler/mplayer-vaapi/bin/mplayer -fo -vo /home/joggler/test.mov

and it played video just fine and very fast.
Seems unlikely, given that -fo is not a valid option and /home/joggler/test.mov is not a valid argument for -vo ;)

pete wrote: Next tried:

/home/joggler/mplayer-vaapi/bin/mplayer /home/joggler/test.mov

and that too played video fine.
That wouldn't have used hardware decoding though.
pete wrote:
Next steps......how to I default to this version of mplayer?

Just copy all of the files to the root?
You copy the mplayer binary to a directory which is in $PATH

Code: Select all

joggler@joggler:~$ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
joggler@joggler:~$ 
Usual convention is to put your own stuff in to /usr/local/bin. If you look in /usr/local/bin you'll see that there's only two things in there. They're there because Jools put them there.
https://en.wikipedia.org/wiki/PATH_(variable)
http://unix.stackexchange.com/questions ... n-on-linux

If you only ever want to use mplayer as the joggler user, you could put it in the joggler user's ~/bin directory which will be included in $PATH if it exists.

Code: Select all

joggler@joggler:~$ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
joggler@joggler:~$ ls bin
ls: cannot access bin: No such file or directory
joggler@joggler:~$ mkdir bin
joggler@joggler:~$ exit
logout
Connection to 192.168.1.105 closed.
me@mine:~>ssh joggler@192.168.1.105
Welcome to Ubuntu 14.04.4 LTS (GNU/Linux 3.2.80joggler1 i686)

 * Documentation:  https://help.ubuntu.com/

Last login: Wed Aug  3 22:51:25 2016 from mine.home
echo joggler@joggler:~$ echo $PATH
/home/joggler/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
joggler@joggler:~$ which mplayer
joggler@joggler:~$ cp mplayer-vaapi/bin/mplayer ~/bin
joggler@joggler:~$ which mplayer
/home/joggler/bin/mplayer
joggler@joggler:~$ 

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Thu Aug 04, 2016 5:51 am

Thank you MDC.

Seems unlikely, given that -fo is not a valid option and /home/joggler/test.mov is not a valid argument for -vo

Yeah what I was doing was typing on the Joggler and just copying what I typed on another computer logged in to the forum.

Testing on the Joggler now and while in a firefox session. I was reading with my left eye and typing here with my right eye such that I fat fingered what I posted.
eye.gif
eye.gif (18.25 KiB) Viewed 3225 times
joggler@joggler:~$ mplayer-vaapi/bin/mplayer -fs -vo vaapi test.mov

Code: Select all

joggler@joggler:~$ mplayer-vaapi/bin/mplayer -fs -vo vaapi test.mov
MPlayer UNKNOWN-4.8 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing test.mov.
libavformat version 53.22.0 (internal)
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x89576a0]Unknown container channel layout.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 2: audio (aac), -aid 0, -alang eng
VIDEO:  [H264]  1920x1080  24bpp  24.000 fps  9282.6 kbps (1133.1 kbyte/s)
Clip info:
 major_brand: qt  
 minor_version: 537199360
 compatible_brands: qt  
 creation_time: 2008-05-27 18:40:35
Load subtitles in ./
libva: VA-API version 0.32.1
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/i386-linux-gnu/dri/emgd_drv_video.so
Intel(R) Embedded Media and Graphics Driver 1.18 Build 3398
Using XCB based dispatch table.
libva: va_openDriver() returns 0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 53.39.1 (internal)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 6 ch, s16le, 437.6 kbit/9.50% (ratio: 54700->576000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Unsupported PixelFormat 61
Unsupported PixelFormat 81
Unsupported PixelFormat 61
[VD_FFMPEG] Trying pixfmt=0.
Unsupported PixelFormat 61
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
[VD_FFMPEG] Trying pixfmt=1.
Movie-Aspect is undefined - no prescaling applied.
VO: [vaapi] 1920x1080 => 1920x1080 H.264 VA-API Acceleration  [fs]
[VD_FFMPEG] XVMC-accelerated MPEG-2.
[ASPECT] Warning: No suitable new res found!
[ASPECT] Warning: No suitable new res found!
A:   0.4 V:   0.1 A-V:  0.351 ct:  0.004   0/  0 ??% ??% ??,?% 1 0 
[h264 @ 0x89c20c0]Increasing reorder buffer to 1
A:   9.4 V:   9.4 A-V: -0.004 ct:  0.052   0/  0 22% 35%  4.5% 43 0 


MPlayer interrupted by signal 2 in module: sleep_timer
A:   9.5 V:   9.4 A-V:  0.048 ct:  0.056   0/  0 22% 36%  4.5% 43 0 
That wouldn't have used hardware decoding though.

Understood.

You copy the mplayer binary to a directory which is in $PATH

Thank-you.

Here looking to call mplayer from a mono touchscreen interface. I can define scripts to run in Linux via the push buttons.

I am also streaming live television using MythTV. Works a bit better than KODI right now.

Curious what you are using mplayer for?
- Pete

Auto mater

User avatar
hawsey
Posts: 1881
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by hawsey » Thu Aug 04, 2016 9:44 am

Andrew1971 wrote:Hi All
Is there any chance on getting the ubuntu netbook remix interface on the joggler
if so how.
Andrew
Andrew , I think its called the Unity desktop now , I have tried but failed to get it working before .
There was an ancient version of netbook remix on a stand alone website but that will be too old now I think .

http://www.stephenford.org/joggler/

It would be best if we could get this working on Buzz's build here :-)


Sent from my Smart Ultra 6 using Tapatalk
Happy Joggling

User avatar
pete
Posts: 2654
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Thu Aug 04, 2016 1:31 pm

@Gary,

Is it that time?

Just a
no or yes
answer will suffice.

Google is really slow here this morning.
- Pete

Auto mater

Post Reply