Page 36 of 39

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Sun Sep 10, 2017 12:39 am
by castalla
Very strange ... several reports that triode's spotify still works, despite the announcement that it would die.

So many variables that'll be difficult to pin down!

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Mon Sep 11, 2017 9:10 am
by hawsey
Hi Castalia how is the Squeeze play Alexa going , have you had a play with it yet.
I had a look and it seemed just for developers at that time .

Sent from my Moto G (4) using Tapatalk


Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Mon Sep 11, 2017 11:33 am
by castalla
Hi

It works well - the final step is to allow for selecting favourites & playlists .... that seems to be stalled for some reason.

Otherwise all the usual LMS commands work.

regards

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Mon Sep 11, 2017 3:03 pm
by hawsey
Thanks , time to give it another try .
Cheers

Sent from my Moto G (4) using Tapatalk


Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Wed Sep 20, 2017 8:57 pm
by jeremyroebuck
I bought a v2 with front speakers version (OpenFrame 7E) from eBay. I've attempted to flash it numerous times using different USB sticks and redownloading both the v2 image and the flashing image. The flashing process seems to run smoothly but when I restart it freezes at the OpenPeak splash screen, Before flashing it booted up fine. I'm running out of ideas and would welcome any suggestions

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Thu Sep 21, 2017 4:13 am
by pete
Maybe try booting with Buzz's Ubuntu and try using GParted to clean up the eMMC partition. Format it. Clean it and see if that works.

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Thu Sep 21, 2017 8:16 am
by Man in a van
jeremyroebuck wrote:
Wed Sep 20, 2017 8:57 pm
I bought a v2 with front speakers version (OpenFrame 7E) from eBay. I've attempted to flash it numerous times using different USB sticks and redownloading both the v2 image and the flashing image. The flashing process seems to run smoothly but when I restart it freezes at the OpenPeak splash screen, Before flashing it booted up fine. I'm running out of ideas and would welcome any suggestions

Is this the image you'r are trying to flash?

http://birdslikewires.uk/openpeak-firmware

Ronnie

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Thu Sep 21, 2017 8:58 am
by jeremyroebuck
Thanks Pete, will give it a try

Ronnie - I'm using v3.03 but the V2 from here http://birdslikewires.co.uk/squeezeplay-os - correct?

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Thu Sep 21, 2017 9:59 am
by pete
Here just redid two of the Openpeak 2 devices. One was an Openpeak7e and the other a Cisco.

The original Openpeak 2 devices here have telco (Verizon/Avaya) or energy (utility company betas) here.

The original new Openpeak 2 devices came from Openpeak in nice boxes with one Openpeak DECT telephone.

Here utilized the SqueezePlay OS for internal memory (2Gb eMMC).

Initially did write a Seabios ROM, updated Realtek NIC chip then write the Avaya ROM.

Note too that the Openpeak 2 devices has a tiny battery. I know that this does work and saves time fine.

I put the Avaya boot EFI bios on both of them as I have had the best luck with this EFI boot ROM.

Thing is that I cannot do that modprobe fh thing today with current buntu builds.

I am currently using the audio out jack on these two devices as I could not get a USB audio digital stick to work.

One other thing here is that I have gone to utilizing PFSense here with multiple interfaces. Internally have test networks for playing with iOT. I do not these days open up any ports on the firewall for use of Squeezeserver / squeezeplayer Internet stuff.

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Thu Sep 21, 2017 10:48 am
by Man in a van
jeremyroebuck wrote:
Thu Sep 21, 2017 8:58 am
Thanks Pete, will give it a try

Ronnie - I'm using v3.03 but the V2 from here http://birdslikewires.co.uk/squeezeplay-os - correct?
I used the one for internal memory

Code: Select all

http://birdslikewires.co.uk/download/openframe/squeezeplay/os/v3/sqpos303_of2.img.gz
I seem to remember that both operations took quite a time to complete.

The unit might be trying to dial home and preventing the flash completing, there is a workaround for this in a PNP thread I think

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Thu Sep 21, 2017 7:52 pm
by pete
Also do not forget to change the /etc/apt/sources.list with:

sudo sed -i.bak 's/ubuntu.datahop.net/archive.ubuntu.com/g' /etc/apt/sources.list

Here now updating an original O2 Joggler (virginal). Looking here to update realtek nic while playing.

Wrote the Squeezebox OS on the O2 Joggler. Works great. Then wrote the original OS to update the ROM. Worked fine.

Went to update the rom to the coreboot.rom and bricked it with a bad file. So now doing the hot swap rewrite thing to update the MAC.

Sort of PITA and time consuming.

Did the hot swap efi boot rom chip thing. IE: booted another Joggler, swapped out boot rom while on, wrote to bad rom, tested it to boot fine.

Wrote coreboot.rom to new O2 Joggler. Booted to realtek nic rom writer, wrote a new mac address. Changed rom back to O2 rom.

Wrote squeezeplayer OS to O2 Joggler. SSH'd to box and updated OS.

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Thu Oct 05, 2017 4:17 am
by pete
Changed the NAS music share to public and now the SQP on the OP2 works fine.

The NAS box took a dive with a bad power supply. That said when I rebooted it the RAID 5 and drives had errors and had to do a fix. Fixed all and all is good now.

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Sun Oct 08, 2017 5:18 pm
by JoggingOn
jeremyroebuck wrote:
Wed Sep 20, 2017 8:57 pm
I bought a v2 with front speakers version (OpenFrame 7E) from eBay. I've attempted to flash it numerous times using different USB sticks and redownloading both the v2 image and the flashing image. The flashing process seems to run smoothly but when I restart it freezes at the OpenPeak splash screen, Before flashing it booted up fine. I'm running out of ideas and would welcome any suggestions
Hi All,
Been lurking for a while after successfully managing to get SqueezeplayOS installed and running perfectly on 3 O2 Jogglers. Took a punt on eBay for a OpenFrame 7EZ and tried to install Squeezeplay. I cannot, however, get SqueezeplayOS to boot either from internal MMC or from USB. I have managed to flash the latest v3.03 firmware, and boot Xubuntu 14.04 from a USB stick. Squeezeplay works fine running from the Xubuntu image. Like jeremyroebuck, I've tried several different USB sticks and downloaded the image several times and used MacOS and Linux to write the images to the USB stick. All have the same result, freezing at the OpenPeak splash screen. What differences between the SqueezeePlayOS build and the Xubuntu build could be the cause of this and how would I go about getting sqpos to boot from internal MMC?
TIA,
Jonathon

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Sun Oct 08, 2017 9:24 pm
by pete
Welcome to the Joggler forum Jonathon.

What differences between the SqueezeePlayOS build and the Xubuntu build could be the cause of this and how would I go about getting sqpos to boot from internal MMC?

Nothing really. You can just utilize your reflash USB stick and remove the firmware from the reflash directory and replace it with the SQP firmware (sqpos303_of2.img.gz and sqpos30)3_of2.img.gz.md5

I have used the reflash system to flash SQP on the O2 Joggler eMMC and the OpenPeak 7EZ and it's worked fine.

I have also used GPARTED to copy the partitions from a USB stick to the eMMC by hand.

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Sun Oct 08, 2017 10:59 pm
by JoggingOn
Hi Pete,
That's the nub of the problem, really. I've tried copying the sqp files to the reflash folder, the reflash seems to proceed OK but the OP7 freezes at the splash screen. This happens both when I use reflash to copy sqp to the internal memory and when I try to boot the sqp image from the USB drive. I only wondered about the differences since I read that the SQP base Linux uses a different kernel to the Xubuntu one, and does not use the Intel EMGD drivers. Should I try to reflash the EFI? If so, which EFI version are you using? (I seem to recall reading somewhere on the forum that you recommend the Avaya EFI.)
Cheers,
Jonathon

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Sun Oct 08, 2017 11:14 pm
by JoggingOn
Enabling verbose logging, it seems to hang up with the message
random: nonblocking pool is initialized

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Sun Oct 08, 2017 11:42 pm
by hawsey
JoggingOn wrote:Enabling verbose logging, it seems to hang up with the message
random: nonblocking pool is initialized
Welcome Jonathon

Sent from my Moto G (4) using Tapatalk


Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Sun Oct 08, 2017 11:48 pm
by hawsey
Make sure show hidden files is ticked in the properties field on your rom file .That had been the issue for me more than once on windows pc , there was an added file extension that I couldn't see until I ticked the box , I just had to rename it and voila it worked after that .
Hope that makes sense .
I'm correct in thinking your reflash stick does boot up , is that right ?
It's just the Rom won't stick .

Sent from my Moto G (4) using Tapatalk


Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Mon Oct 09, 2017 7:38 am
by JoggingOn
Hi Hawsey,
I’ve been using dd on MacOS and latterly Linux to write the images, so the “show extensions” Windows setting shouldn’t be relevant?

The USB stick works fine in the following situations:
updating the stock firmware to version 3.3 using roobarb's flashing tool;
booting up BuZz’s Xubuntu 14.04;
installing and running SqueezePlay from the USB stick Xubuntu.

What does not work:
installing SqueezePlay on the standard OpenPeak firmware;
writing roobarb’s SqueezeplayOS to internal memory - freezes at OpenPeak splash screen;
booting roobarb’s SqueezeplayOS from USB stick - freezes at OpenPeak splash screen. With verbose logging during boot, the last message displayed on screen is
random: nonblocking pool is initialized

I’ve tried 4 or 5 different USB sticks and two different OS to write the images to the USB stick - same result.

Re: SqueezePlay OS (Version 3) for OpenFrame

Posted: Mon Oct 09, 2017 9:29 am
by hawsey
JoggingOn wrote:Hi Hawsey,
I’ve been using dd on MacOS and latterly Linux to write the images, so the “show extensions” Windows setting shouldn’t be relevant?

The USB stick works fine in the following situations:
updating the stock firmware to version 3.3 using roobarb's flashing tool;
booting up BuZz’s Xubuntu 14.04;
installing and running SqueezePlay from the USB stick Xubuntu.

What does not work:
installing SqueezePlay on the standard OpenPeak firmware;
writing roobarb’s SqueezeplayOS to internal memory - freezes at OpenPeak splash screen;
booting roobarb’s SqueezeplayOS from USB stick - freezes at OpenPeak splash screen. With verbose logging during boot, the last message displayed on screen is
random: nonblocking pool is initialized

I’ve tried 4 or 5 different USB sticks and two different OS to write the images to the USB stick - same result.
Hmm that's beyond me , I'm afraid , I'm pretty certain Roobarb himself has one of those devices , he's not on here much recently though ( not many posts :-) )
@roobarb is their anybody there ;-)
Maybe a PM
Good luck .

Sent from my Moto G (4) using Tapatalk