SqueezePlay OS (Version 3) for OpenFrame

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
User avatar
roobarb!
Posts: 1529
Joined: Sat Mar 05, 2011 1:30 pm
Location: Manchester, UK
Contact:

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by roobarb! » Tue Nov 18, 2014 3:36 pm

Okay, just to let you know that I've totally lost track of all this. Icky-what-player now? Players being identified as SqueezeJoggler? What the fudge! ;)

Version 3.01 will contain only stuff that I've tested, ie. the predictable MAC address, package roll-ups and a few extra packages added by default. Anything else I'll be letting the dust settle on. :)
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

castalla
Posts: 849
Joined: Wed May 29, 2013 10:33 am

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by castalla » Tue Nov 18, 2014 4:42 pm

roobarb! wrote:Okay, just to let you know that I've totally lost track of all this. Icky-what-player now? Players being identified as SqueezeJoggler? What the fudge! ;)

Version 3.01 will contain only stuff that I've tested, ie. the predictable MAC address, package roll-ups and a few extra packages added by default. Anything else I'll be letting the dust settle on. :)
Briefly, ickStream doesn't recognise Openframe1 as a valid device (added via the 1.59 update?).

ickStream (what an awful name!) is a LMS plugin which adds a few music and radio services (mainly pay-to-listen).

What is more interesting is the current discussion on slimdevices forum about MAC addresses (and UUIDs) for registering on mysb.com. AFAIK, a recent change at mysb.com means only players with unique MACs and UUIDs will register,

User avatar
palindrom
Posts: 67
Joined: Mon Jan 27, 2014 4:14 pm

Re: Access Point issues

Post by palindrom » Tue Nov 18, 2014 9:08 pm

jogglerhase wrote:Hi Palindrom;
very bizarre...
I followed exactly the steps from the post above - on a freshly flashed Joggler (w/ SPOS3)

The script executed ok (installing the packages, creating the files aso)

But: It just does not work. Not the n mode and also not the g mode.

(Note: The Joggler & SPOS3 itself work fine: I can access access my network via LAN as well via WLAN...

Any ideas how to trouble shoot this?


Heiner
Can you see the WLAN-AP (with a phone and/or tablet)?
What exactly is not working?

check the devices

Code: Select all

iwconfig
are they wlan0 and eth0?

You could try to debug hostapd by issuing:

Code: Select all

# propbably not needed
sudo /usr/bin/killall hostapd

# should give you some hints...
# sometimes you needed to retry it...
sudo hostapd -d /etc/hostapd/hostapd.conf
try tuning parameters:

Code: Select all

sudo nano /etc/hostapd/hostapd.conf
See German help: http://wiki.ubuntuusers.de/WLAN_Router Viel Erfolg :)

jogglerhase
Posts: 141
Joined: Wed Aug 08, 2012 3:02 pm

Re: Access Point issues

Post by jogglerhase » Wed Nov 19, 2014 10:11 am

palindrom wrote: Can you see the WLAN-AP (with a phone and/or tablet)?
What exactly is not working?
check the devices

Code: Select all

iwconfig
are they wlan0 and eth0?
You could try to debug hostapd by issuing:

Code: Select all

# propbably not needed
sudo /usr/bin/killall hostapd
# should give you some hints...
# sometimes you needed to retry it...
sudo hostapd -d /etc/hostapd/hostapd.conf
...
Hi Palindrom;
thanks for your continued feedback on this.
I really would like to get this working.
However, I would like to start a new thread, where we can continue this w/o cluttering the SPOS v3 thread.
OK?

Hope to see you there!
Heiner

DJ le Roi
Posts: 3
Joined: Sun Jun 15, 2014 12:25 pm

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by DJ le Roi » Thu Nov 20, 2014 3:26 pm

roobarb! wrote:Okay, just to let you know that I've totally lost track of all this. Icky-what-player now? Players being identified as SqueezeJoggler? What the fudge! ;)

Version 3.01 will contain only stuff that I've tested, ie. the predictable MAC address, package roll-ups and a few extra packages added by default. Anything else I'll be letting the dust settle on. :)
Will Squeezelite be included in version 3.01?

Thanks for Joggler OS, it's very good.

User avatar
palindrom
Posts: 67
Joined: Mon Jan 27, 2014 4:14 pm

Re: Access Point issues

Post by palindrom » Fri Nov 21, 2014 9:19 am

jogglerhase wrote: Hi Palindrom;
thanks for your continued feedback on this.
I really would like to get this working.
However, I would like to start a new thread, where we can continue this w/o cluttering the SPOS v3 thread.
OK?

Hope to see you there!
Heiner
Yes OK. But my feedback will be slow...
I hope we can move the old AP posts to that new one.

User avatar
roobarb!
Posts: 1529
Joined: Sat Mar 05, 2011 1:30 pm
Location: Manchester, UK
Contact:

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by roobarb! » Fri Nov 21, 2014 3:30 pm

DJ le Roi wrote:Will Squeezelite be included in version 3.01?
Nope, but you can still install it yourself if you need it.

Sorry it isn't sorted yet, but after a failure of my build VM, a very busy week and a darn cold, things are rather behind schedule. :)
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

DJ le Roi
Posts: 3
Joined: Sun Jun 15, 2014 12:25 pm

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by DJ le Roi » Fri Nov 21, 2014 7:50 pm

I want to install squeezelite on Squeezeplay OS.

Can I use these instructions (which are made for Ubuntu OS)? http://www.jogglerwiki.com/forum/viewto ... f=2&t=1978

User avatar
roobarb!
Posts: 1529
Joined: Sat Mar 05, 2011 1:30 pm
Location: Manchester, UK
Contact:

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by roobarb! » Fri Nov 21, 2014 10:49 pm

DJ le Roi wrote:I want to install squeezelite on Squeezeplay OS.

Can I use these instructions (which are made for Ubuntu OS)? http://www.jogglerwiki.com/forum/viewto ... f=2&t=1978
Yeah, that'll probably do it.
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

Rakanishu
Posts: 2
Joined: Wed Nov 26, 2014 10:49 am

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by Rakanishu » Wed Nov 26, 2014 11:06 am

Hi There,

Very nice build, reminds me of tricking together my old pogoplug squeezeboxserver/headless player, with original logitech remote ;)
This (Version3) is now running on 2 Jogglers (#1: 24/7 as alarmclock with 2x25 watt Class-D amp next to my bed, #2: with external usb/spdif->Dac->Hifi connection in the livingroom).

For those who might be interested in letting the Joggler run at a lower speed (same like stock firmware=800Mhz),

as cpufrequtils and sysfsutils are not installed by default:

Code: Select all

sudo apt-get update
sudo apt-get install cpufrequtils sysfsutils
sudo update-rc.d ondemand disable 
sudo rm /etc/sysfs.conf
Generate new /etc/sysfs.conf :

Code: Select all

sudo nano /etc/sysfs.conf
add the following entries:

Code: Select all

devices/system/cpu/cpu0/cpufreq/scaling_max_freq = 800000
devices/system/cpu/cpu1/cpufreq/scaling_max_freq = 800000
devices/system/cpu/cpu0/cpufreq/scaling_governor = powersave
devices/system/cpu/cpu1/cpufreq/scaling_governor = powersave
..and after a reboot you are running on fixed 800Mhz, plus the joggler won't run "hot" that way, for my alarm clock 800Mhz (WLAN Flac play) is enough.

User avatar
roobarb!
Posts: 1529
Joined: Sat Mar 05, 2011 1:30 pm
Location: Manchester, UK
Contact:

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by roobarb! » Mon Dec 01, 2014 1:31 pm

I am honestly still alive. Silly busy at the moment; I'll get the next version out sometime! x)
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

User avatar
palindrom
Posts: 67
Joined: Mon Jan 27, 2014 4:14 pm

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by palindrom » Mon Dec 01, 2014 5:21 pm

Rakanishu wrote:
..and after a reboot you are running on fixed 800Mhz, plus the joggler won't run "hot" that way, for my alarm clock 800Mhz (WLAN Flac play) is enough.
Hi Rakanishi, thank you for sharing.
Seems working well, but I cannot "feel" a temperature difference of my device.
Is it an indicator for malfunction or is the difference just not big enough to recognise a significant temperature drop (in stand by mode).

fraserm
Posts: 33
Joined: Thu Apr 28, 2011 12:25 pm

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by fraserm » Tue Dec 02, 2014 12:33 am

Hello All -

Have been running SqueezePlay on the base Joggler OS for some time now, but wanted to get SqueezeOS on there. I booted a USB Stick with the sqpos300_of1.img image on, and it installed just fine. I upgraded to the latest SqueezePlay through the app itself. However:

1) I don't get any sound when I play music and no UI clicks around the menus.
2) I don't have a wireless option available to configure - I thought this was part of the newer updates from Roobarb (could be wrong though!).

Any ideas? Oddly enough the UI sound was working when I first did the upgrade, but stopped working either after a reboot or after the SqueezePlay upgrade.

I`ve got two other Jogglers lined up and waiting for this update but don't want to take the plunge until this one is back up and running :-)

Is there a way to do a clean-clean-clean install of the whole thing? I thought that because this was an image that it would be as good as clean, so maybe there is something else I can try.

Cheers
Fraser

User avatar
roobarb!
Posts: 1529
Joined: Sat Mar 05, 2011 1:30 pm
Location: Manchester, UK
Contact:

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by roobarb! » Wed Dec 03, 2014 1:16 pm

palindrom wrote:Is it an indicator for malfunction or is the difference just not big enough to recognise a significant temperature drop (in stand by mode).
In my experience, most of the heat comes from the display, not the processor. The display also uses more than half of the power of the device.
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

User avatar
palindrom
Posts: 67
Joined: Mon Jan 27, 2014 4:14 pm

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by palindrom » Wed Dec 03, 2014 1:19 pm

Applet recommendation
If you have problems displaying Artists (and other Information) with CJK characters try
fontreplacer 1.1 (by: mcstayinskool@yahoo.com).
Screenshot
Screenshot
fontreplacer is a Lua applet for Squeezebox.
It replaces the default FreeSans font file in Squeezeplay with a merged font file that uses FreeSans + DroidSansFallback.
The merged font contains e.g. CJK characters for a fuller set of available characters on the Squeezebox products

URL:
http://fontreplacer.googlecode.com/
LMS Plugin Setup:
http://fontreplacer.googlecode.com/svn/trunk/repo.xml

Tested and working well with OS V3.

User avatar
roobarb!
Posts: 1529
Joined: Sat Mar 05, 2011 1:30 pm
Location: Manchester, UK
Contact:

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by roobarb! » Wed Dec 03, 2014 1:20 pm

fraserm wrote:1) I don't get any sound when I play music and no UI clicks around the menus.
2) I don't have a wireless option available to configure - I thought this was part of the newer updates from Roobarb (could be wrong though!).
Are you using the internal or an external sound card? If it was working, but now isn't go to the Audio Settings menu and change from internal to external and back again (or vice-versa) then Quit > Reload.

As for wireless, just go to Settings > Network and all of the options should be there.
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

fraserm
Posts: 33
Joined: Thu Apr 28, 2011 12:25 pm

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by fraserm » Wed Dec 03, 2014 6:44 pm

All my fault, got a bit confused with the re-flashing instructions so in fact I wasn't re-flashing it at all :-) Ran through it again properly today, and it worked a treat. Thanks a lot for your ongoing support Roobarb!

User avatar
roobarb!
Posts: 1529
Joined: Sat Mar 05, 2011 1:30 pm
Location: Manchester, UK
Contact:

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by roobarb! » Thu Dec 04, 2014 4:20 pm

fraserm wrote:All my fault, got a bit confused with the re-flashing instructions so in fact I wasn't re-flashing it at all :-) Ran through it again properly today, and it worked a treat. Thanks a lot for your ongoing support Roobarb!
No problem - but you'll probably kick me now, because I've just uploaded v3.01! :P
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

User avatar
roobarb!
Posts: 1529
Joined: Sat Mar 05, 2011 1:30 pm
Location: Manchester, UK
Contact:

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by roobarb! » Thu Dec 04, 2014 4:28 pm

Version 3.01
CHANGELOG

I'm not going to repeat the changelog, but the things discussed on here recently have pretty much all been rolled into this. New kernel, fixed backlight, updated packages (with SSL support for Perl) and the nicely predictable MAC address stuff as well. As usual with the OS updates, it's a wipe-and-reinstall job, I'm afraid.

Because of the issues with mysqueezebox.com and generated MAC addresses, I'd recommend updating to this one - or you can visit the GitHub page and pull the script from the overlays if you're that way inclined. It's fired from /etc/network/if-pre-up.d - just remember to delete /etc/init/openframe-eth if you do.

If that last bit didn't make any sense, just download the whole thing and install it properly. ;)
birdslikewires.net - home of the Reflash System, SqueezePlay (OS) and various tools for the Joggler!

kazan
Posts: 15
Joined: Tue May 17, 2011 11:13 am

Re: SqueezePlay OS (Version 3) for OpenFrame

Post by kazan » Sun Dec 07, 2014 2:58 pm

I've just installed new ver of SqueezePlay OS (ext ver.) on o2 joggler but I'm having some problems to run it. At the first start I can chose language, wired connection but it doesn't connect to mysqueezebox.com. It says "We couldn't connect to ..."
My internet is fine. I can see joggler on network but no idea why it doesn't connect to mysqueezebox.com. Any ideas?

Edit1: after playing with menu and going back and forwards it finally allowed me to go to main menu and register to my account on mysqueezebox.com but when I check what players I've on mysqueezebox.com it shows me "SqueezePlay" but doesn't display icon:
Image
If I click on "open img in new tab" it shows me:

Code: Select all

"Error reading file docroot/static/images/players/OpenFrame1.png: read_file '/opt/sn/docroot/static/images/players/OpenFrame1.png' - sysopen: No such file or directory at /opt/sn/script/../lib/SDI/SqueezeNetwork/Controller/Public/ImageProxy.pm line 104"
Also, "Type:" for this joggler on mysqueezebox.com shows as "Squeezebox Controller", where my other joggler with buzz distro is shown as "Squeezeplay, Squeezebox Controller". Does it make any difference?
That is not a big problem, just would like to know what is going on with this :?: ;)

Edit2: I think there is a problem with this new image. If I will remove USB WiFi from my joggler (I want to have USB memory inside) then wired connection doesn't work even if I will setup static IP address in /etc/network/interfaces. It just shows "no network address has been assigned to the eth0" where I have actually set static IP. Any ideas?

Thanks.

Post Reply