BBC iPlayer/Live/Podcast/Categories Player - UPDATED June 15

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
spoyser
Posts: 134
Joined: Mon Mar 07, 2011 6:45 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by spoyser » Thu Jun 16, 2011 3:26 pm

@Utakos
I have PMed you

gegs
Posts: 1142
Joined: Fri Mar 04, 2011 3:22 pm
Location: Edinburgh

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by gegs » Thu Jun 16, 2011 5:44 pm

spoyser wrote:@gegs

Thanks for finding that, turned out to be a bug in the JogTools scroll panel libray, if you notice all the scroll panels show the same behaviour.

I have now fixed the bug and there is a new version available to download (in fact the main.swf is the only file changed)
spoyser, you never cease to amaze me. I can't believe you've fixed this so quickly.

Whatever device I use iPlayer on, it's the categories I usually access content from. The 'music', 'films' and 'children's' categories are going to be very well used in my house.

My wife is a bit of a technophobe and doesn't embrace new gadgets easily but even she would have to admit that your iPlayer program and roobarb's implementation of Squeezeplay have made our kitchen Joggler indispensable. As much as I like (and use) the linux distros, it is continued work on the stock OS that has won my wife over; she finds it much easier to use.
Last edited by gegs on Fri Jun 17, 2011 11:25 pm, edited 2 times in total.

stephen m
Posts: 33
Joined: Fri Mar 04, 2011 6:47 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by stephen m » Thu Jun 16, 2011 8:05 pm

[/img]
spoyser wrote:@Utakos
To update simply install over the top of the previous version.

@nigelh
The icon in the top right (looks like a power off button), should go back.

@stephen m
Sounds like you entered the tag contents incorrectly, can you post the output of this command:
cat media/appshop/applications.xml
spoyser. Trying to upload the screen shot but it's saying it's too big ? Any ideas why this could be as you're most likely correct re the tag contents

dnwilson01
Posts: 1
Joined: Fri Jun 17, 2011 2:16 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by dnwilson01 » Fri Jun 17, 2011 2:22 pm

I've just started using the app and it's fantastic!

Just one request. Is there any chance of a guide to customising /changing the radio stations (being in Scotland, I would rather have radio scotland)

Ben
Posts: 15
Joined: Tue Apr 12, 2011 12:23 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Ben » Fri Jun 17, 2011 8:52 pm

The app is great, but I need to feed back that the last two versions (Jun 15 update and the one prior) have given me problems with the exit/power soft button. The prior version (the one *before* when exit was top-left of the viewing screen) worked well for exiting. But the last two versions, Jun 15th and also the one prior - have given me issues with exiting TV and also iPlayer menus. The exit button just isn't appearing for me. The last version (before Jun 15th) did show the exit button - apart from after having entered full screen (couldn't get out of that at all) - so was OK. But the Jun 15th version isn't showing the exit/power button at all. What could I be doing wrong? Or has the functionality changed in some way I'm not figuring out how to use?

thanks : -) (and sorry for moaning ;-) )

Ben
Posts: 15
Joined: Tue Apr 12, 2011 12:23 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Ben » Fri Jun 17, 2011 10:40 pm

I've tried purging all the iPlayer files, rebooting and reinstalling - but the server appears to be offline :-(

spoyser
Posts: 134
Joined: Mon Mar 07, 2011 6:45 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by spoyser » Sat Jun 18, 2011 11:22 am

@Ben

I have just looked in the iPlayer.cgi file and there appears to be a duplicated line in it (although it doesn't seem to affect my install), can you delete the very last line, the line that starts

.tango -w:30 -h:30

and ends &

(If there is only 1 line like this DO NOT delete it)

Then try increasing the sleep 3 to say sleep 10

This controls the delay before the close button appears, if it is too quick I suppose there is a chance it will appear below the iPlayer and therefore be unaccessible.
Last edited by spoyser on Tue Jun 21, 2011 9:30 pm, edited 1 time in total.

Midnight Tbot
Posts: 5
Joined: Fri Jun 17, 2011 8:02 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Midnight Tbot » Sat Jun 18, 2011 11:37 am

Hi there,

I also have the issue where sometimes the close button won't appear (forcing reboot).

The description spoyser just gave sounds like it could be the culprit.

Are we able to change this setting manually in telnet, or would we need to reinstall?

Other than that, a fantastic program. Is it feasable to also get other iplayer content? Such as tv episode catchup stuff?

nigelh
Posts: 27
Joined: Mon Jun 13, 2011 10:05 am

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by nigelh » Sat Jun 18, 2011 2:19 pm

I had the same issue with the close button and spoysers fix works a charm. Thank you.

Ben
Posts: 15
Joined: Tue Apr 12, 2011 12:23 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Ben » Sat Jun 18, 2011 3:19 pm

Sorted. Good work :-) I've even got the power/close soft button when displaying full screen (a good thing!) - so this is the first time I can exit from full screen reliably, too. Thanks! :-)

Midnight Tbot
Posts: 5
Joined: Fri Jun 17, 2011 8:02 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Midnight Tbot » Sat Jun 18, 2011 4:08 pm

hmmmm, doesn't seem to be working for me.

I changed sleep to 10.

I removed the .tango -w:30 -h:30 line (at the very end - but saying that I couldn't see a 2nd line of this which was mentioned?)

I then rebooted the joggler and went straight to cbeebies.......first attempt.....no exit button in the corner.

FWIW this is editing the cgi file AFTER its been installed already....not before...if it makes any difference?

Any ideas? Maybe have to put that .tango line back in? (what does it do)

Midnight Tbot
Posts: 5
Joined: Fri Jun 17, 2011 8:02 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by Midnight Tbot » Sat Jun 18, 2011 4:39 pm

problem fixed (I think)

The last line was only duplicated in the cgi file before installing (checked by downloading it on the pc). After its been installed it only has (for me at least) the one line.

So me removing that line had removed it altogether.

Putting the line back in fixed it (he hopes)

darrenkellum
Posts: 35
Joined: Thu May 19, 2011 11:40 am

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by darrenkellum » Mon Jun 20, 2011 9:39 am

Not sure if this was just me but I seemed to have issues over the weekend accessing this BBC app. Streams were not playing, just black screen with the spinning wheel. After exiting the app (and im not 100% sure if this really was happening) but it seemed like it was making my internet connection on the joggler drop or slow right down as I wasnt able to access other apps until i reboot. havnt tried again today but will see if its back working after work tonight. Anyone else have issues?

Working fine last night so must have been problems my end.

spoyser
Posts: 134
Joined: Mon Mar 07, 2011 6:45 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by spoyser » Tue Jun 21, 2011 7:59 pm

@darrenkellum

To be honest what you decribe is usually due to the joggler dropping the internet connection, I believe this is a known issue with the Jogglers wifi drivers.

The driver pack installed by gforums pnp is supposed to update the wifi driver to overcome this, although in my experience it still happens.

bloggsey
Posts: 6
Joined: Sun Jul 17, 2011 3:12 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by bloggsey » Sun Jul 17, 2011 3:16 pm

Hey guys,
Would appreciate some help, I tried to follow instructions but they were the old ones which did not work. I have tried the new but now have no icons on joggler. Can I get back to basic Joggler as I don't think I am upto making it work?
Thanks

Now FIXED :D thanks to Spoyser and Yugo great to get help when needed.
Last edited by bloggsey on Mon Jul 18, 2011 7:22 pm, edited 1 time in total.

yugo
Posts: 32
Joined: Fri Mar 04, 2011 8:43 am
Location: N Ireland

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by yugo » Sun Jul 17, 2011 6:02 pm

bloggsey wrote:Hey guys,
Would appreciate some help, I tried to follow instructions but they were the old ones which did not work. I have tried the new but now have no icons on joggler. Can I get back to basic Joggler as I don't think I am upto making it work?
Thanks
You must have made a mistake when editing applications.xml
If you followed the instructions you will have created a backup of it.

To restore:
Telnet in
cd media/appshop
ls

This lists the files in that directory,make sure there is one called applications.original before doing the following

cp applications.original applications.xml
reboot
Last edited by yugo on Sun Jul 17, 2011 8:07 pm, edited 1 time in total.

bloggsey
Posts: 6
Joined: Sun Jul 17, 2011 3:12 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by bloggsey » Sun Jul 17, 2011 7:05 pm

Thanks for the quick response Yugo but the early script didn't backup so applications is not there!

yugo
Posts: 32
Joined: Fri Mar 04, 2011 8:43 am
Location: N Ireland

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by yugo » Sun Jul 17, 2011 7:58 pm

Oh, well you may try and fix the existing version. Its probably just a small error in it.

bloggsey
Posts: 6
Joined: Sun Jul 17, 2011 3:12 pm

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by bloggsey » Sun Jul 17, 2011 8:04 pm

Okay Yugo, thanks for your help.

yugo
Posts: 32
Joined: Fri Mar 04, 2011 8:43 am
Location: N Ireland

Re: BBC iPlayer/Live/Podcast/Categories Player - UPDATED Jun

Post by yugo » Sun Jul 17, 2011 8:06 pm

i've just noticed an error in my post.
its should have read

cd media/appshop

That would explain why the backup wasn't listed

Post Reply