Ubuntu / Xubuntu for the O2 Joggler.

General discussion relating to the O2 Joggler, from the default O2 setup, to alternative operating systems and applications.
User avatar
pete
Posts: 2652
Joined: Mon Aug 01, 2011 6:33 am
Location: Time Traveler

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by pete » Mon Nov 20, 2017 5:00 pm

Yup noticed that the settings for brightness do not stick on a reboot. That said went to power manager / screen settings and set the screen to dim after XX seconds. This works fine on a reboot.

You could also edit the

sudo -H gedit /etc/rc.local

file and insert a brightness level there.
- Pete

Auto mater

Andrew1971
Posts: 75
Joined: Tue Oct 30, 2012 12:49 pm

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by Andrew1971 » Mon Nov 20, 2017 9:10 pm

Well got another issue got xubuntu booting and running from usb flash drive on the joggler. So got my main's powered usd hdd with xubuntu on it plugged into the usb hub connected to the joggler and Does not show any drive's connected but show's in gparted. I have tried another flash drive with film/music on it no problem. Have I missed a setting somewhere.
Andrew

User avatar
BuZz
Site Admin
Posts: 1443
Joined: Fri Mar 04, 2011 1:15 am

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by BuZz » Mon Nov 20, 2017 9:17 pm

Andrew1971 wrote:Hi All
Thank's for the reply's. I have tried every usb flash drive I have , every usb hub I have , every hdd in an enclosure to usb I have main's powered,
I have downloaded the image several time's now. The error's are the same no matter what combo of hardware I use. But it does boot and work.
The screen brightness is alway's on maximum brightness every time I boot up even though I alway's put on minimum.
I thought it wasn't booting sorry. Those messages can be ignored. It's normal.

Sent from my XT1092 using Tapatalk


cszhy
Posts: 107
Joined: Sun Apr 24, 2011 5:25 am

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by cszhy » Tue Nov 28, 2017 1:06 pm

hi Buzz:

Got following error message when I tried to install LMS, did I choose the wrong version of LMS? thanks

root@joggler:~# dpkg -i logitechmediaserver_7.9.1~1511211491_all.deb
(Reading database ... 137877 files and directories currently installed.)
Preparing to unpack logitechmediaserver_7.9.1~1511211491_all.deb ...
Unpacking logitechmediaserver (7.9.1~1511211491) over (7.9.1~1511211491) ...
dpkg-deb (subprocess): decompressing archive member: internal gzip read error: '<fd:4>: incorrect data check'
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive logitechmediaserver_7.9.1~1511211491_all.deb (--install):
subprocess dpkg-deb --fsys-tarfile returned error exit status 2
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
logitechmediaserver_7.9.1~1511211491_all.deb

User avatar
BuZz
Site Admin
Posts: 1443
Joined: Fri Mar 04, 2011 1:15 am

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by BuZz » Tue Nov 28, 2017 1:12 pm

Corrupted deb ?

It's unrelated to the Joggler Xubuntu - I don't have time to offer general linux advice sorry.

JonTheNiceGuy
Posts: 16
Joined: Sat Jun 25, 2011 6:14 pm

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by JonTheNiceGuy » Fri Dec 01, 2017 11:33 am

cszhy wrote:
Tue Nov 28, 2017 1:06 pm
dpkg-deb (subprocess): decompressing archive member: internal gzip read error: '<fd:4>: incorrect data check'
Looks like you've got a corrupted deb. Redownload and give it another try!

trumee
Posts: 4
Joined: Tue Feb 25, 2014 5:57 am

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by trumee » Sun Feb 11, 2018 9:18 pm

Please would you build Kodi-17.6 and its plugins. I tried to install from the xbmc ppa, but got this

Code: Select all

# apt-cache madison kodi
      kodi | 2:17.6+git20171114.2125-final-0trusty | http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/ trusty/main i386 Packages
      kodi | 16.1~git20160425.2147-c6f6e0b-0 | http://ppa.launchpad.net/jools/joggler/ubuntu/ trusty/main i386 Packages
      kodi | 16.1~git20160425.2147-c6f6e0b-0 | http://ppa.launchpad.net/jools/joggler/ubuntu/ trusty/main Sources
root@joggler:~# apt-get install kodi=2\*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Selected version '2:17.6+git20171114.2125-final-0trusty' (Kodi stable:14.04/trusty [all]) for 'kodi'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 kodi : Depends: kodi-bin (>= 2:17.6+git20171114.2125-final-0trusty) but 16.1~git20160425.2147-c6f6e0b-0 is to be installed
E: Unable to correct problems, you have held broken packages.

User avatar
BuZz
Site Admin
Posts: 1443
Joined: Fri Mar 04, 2011 1:15 am

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by BuZz » Mon Feb 12, 2018 2:14 am

I looked into it, but it requires code changes to work with our ancient vaapi library. I don't know if I am that interested in sorting it, at least not currently. I have a lot on. Also the Joggler is pretty old now, and I cannot support it with updates forever.

User avatar
hawsey
Posts: 1878
Joined: Sun May 22, 2011 11:23 pm
Location: Northumberland

Re: Ubuntu / Xubuntu for the O2 Joggler.

Post by hawsey » Mon Feb 12, 2018 10:28 am

BuZz ahh man , you are not bowing out are you ha ha , we've had a good run over the years with yours mainly and others work on the Joggler .
You are a star .
I live in hope of you having a look at getting Retropie working for older 8 bit systems on the joggler , it's still a fantastic device and I'm sure it would do this well .
I could only get it to boot .
Also thanks again for all the Retropie work you do as well as hosting this forum .

Cheers

Sent from my Moto G (4) using Tapatalk

Happy Joggling

Post Reply