Page 1 of 1

Cisco Cius/OpenPeak OpenTablet 7

Posted: Tue Mar 26, 2019 7:58 pm
by D4rk4
I have 2 Cisco Cius, and i found way how I can upgrade in from Android 2.2 to something more fresh. Any suggestions how I can do it?

I'm also has cius-opensource924-3.tgz from Cisco Inc with GPL code and Android build instructions, but I don't have idea how I can build with it android ICS and flash into device.

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Thu Apr 04, 2019 2:50 pm
by roobarb!
Looks like an interesting device, but without someone here having one to hand it's not easy to advise.

The first trick would be to try and get command line access to it. Have you tried using telnet or ssh to connect to see if it gives you a command prompt? Is there a USB port on it? Are you prepared to open it and fish around for a test port?

There are lots of ways for it to be done, but if nobody else has one then your best bet is to get to grips with these initial steps and trying them. Google is definitely your friend on this - have a search for "jtag serial interface" and the like if you're prepared to open it up, otherwise it's a case of trial and error. Download the reflash tool (linked below) and just see if that will boot - you never know, you might be lucky!

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Fri Apr 05, 2019 12:59 pm
by hawsey
I think Pete might have had one .

Sent from my Moto G (4) using Tapatalk

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Sun Apr 14, 2019 3:57 pm
by pete
I do not have one but do see a bunch of them on Ebay with cradle and hand set these days.

Not a good deal right now here in the US at over $50 USD. They are old and used and worth maybe $30 such that I am waiting.
Over the years here have not been impressed with consumer Cisco labeled hardware (all junk to me) being used to old commercial enterprise Cisco devices.

I agree with Andy relating to these devices.

Open one up for us, show us the motherboard. I am curious whether the boot OS is socketed or soldered in to place, what eMMC it is using or if it has an SSD card in it and maybe a combo wireless/bluetooth card and maybe an RTC with battery....and if it was mfg in China or India. The ones made in China can be easily modified. The ones made in India (well Verizon did this) were not modifiable and very cheap but functional.

Here currently tinkering with those el cheapo Android TV boxes ...specifically an octocore ARM with 3Gb of DDR4 RAM, bluetooth, WLAN and Gb NIC for $50 USD. Runs circles around my Pine64. Boots to an SD card OS then I write the OS to the internal 32Gb eMMC card (easy peasy stuff).

And makes for the ultimate el cheapo KODI box that plays HD 4K with no issues.

It makes for the ultimate micro server here running:

1 - Mono
2 - Homeseer 3
3 - Node Red (docker)
4 - Home Assistant (docker)
5 - MQTT (and Mosquitto server)
6 - Squeezebox server

Hate Android here so replaced the Android OS with Armbian Ubuntu 18.04 64 bit. Tiny thing runs circles around a RPI.

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Sun Nov 17, 2019 7:37 am
by pete
Purchased a new open box Cisco Cius docking station to tinker with it. It has better specs than the Openpeak devices. Prices are way down now for device.

Total purchase price with shipping was $25 for a new one openbox with docking media station with no PS which is not a big deal.

These are really just bricks today similiar to the Openpeak 2 which is still being sold.

Will take it apart and post pictures of it. This was a tablet shown by Openpeak many years ago as the next steps to the Joggler / Openpeak 1 and 2.

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Wed Nov 20, 2019 10:16 pm
by pete
I am impressed. Product is new. Two boxes. One "media" dock and the other tablet.

It is the Openpeak tablet announced at some show a few years back. Note these are sold new on some current sites for around $800.

It boots up to Android. There is a SIM card slot and a SD card slot.

Mini USB port. The docking base has two NIC ports and two USB ports and a display port adapter. One NIC is marked regular and the other NIC shows a computer. Guessing that it is a passthru port or two NIC ports.

Only the tablet came with a PS. The docking station appears to be using a 48V power supply with a special cisco barrel connector.

OK can utilize POE. Downloaded manual:

Cisco Cius is powered with external power by the supplied direct current (DC) charger, or with Enhanced Power over Ethernet (PoE+ 802.3at) or CP-PWR-CUBE 4 through the media station. Cisco Cius may also be powered by a removable battery.

Testing media base today with a TP-Link 48V power injector and ordered a cheapo CP-PWR-Cube4 (clone).

Writing Ubuntu base to stick to see if it boots up.

Will take pictures.

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Sat Nov 23, 2019 8:01 pm
by pete
Looks like Cisco locked this tablet down. Googling see that no one ever rooted it. It is a different chip set than the O2, Openpeak1-2 devices.

Will not boot off of the SD card or USB stick. I can use the USB cable to telnet to the device (via Cisco docs) and configure the tablet to work with SSH.

There are tiny torx screws that hold it together and will take it apart this week.

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Sat Nov 23, 2019 8:34 pm
by Paul Webster
Glad you said that as I was getting twitchy when I saw a cheap one in UK.
Will hold off at least until you announce breakthrough ;)

I have absolutely no compelling need but still ...

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Sun Nov 24, 2019 12:12 am
by pete
Have to find a tiny torx screwdriver.

I looked at the FCC ID pictures of the internals and they are way too blurry. So best to just take it apart.

Specs indicated 8 hours up time on the rechargable battery. Real experience indicates maybe an hour of up time on battery.

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Sun Nov 24, 2019 1:27 am
by pete
Wow got the rear of the case off. It is all metal, thin and some sharp edges to it. There are four tiny torx screws that you can see. One tiny Philips screw that holds the upper part of the back of the case that covers the camera. Tricky part is that there is a hidden torx screw under the SIM cover (no SIM socket though).

Once the hidden screw (hidden in that there was a tiny piece of black tape over the head of the screw) the back of the case came right off.

There is a metal shield cover most of the rear of the motherboard. The board is labeled CIUS Tablet Board. No Openpeak markings. There is a CMOS battery and what appears to be a non populated tiny cmos socket on the back. There is a ZIF clip marked bottom contact on the back of the board. There is a multiple purpose antenna on the top left of the board (externally attached). I could not get the GPS to work via Android. There are 8 screws holding the motherboard to the surrounding plastic. I do not see anything here that resembles the O2, Openpeak 1 or 2 motherboards.

Reading docs you can reset the device hitting a combo of buttons. I am wondering if it will see the SD card boot if I do this. I have done something similiar cooking a new Android ROM for an android tablet. Will post pictures in the next few days.

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Tue Dec 17, 2019 3:29 pm
by pete
17th of December, 2019

Tinkering a bit. No luck yet. I have not removed the motherboard cuz of all of the ribbon cables so I just have the back side open.

Tried installing software via the Google store and no luck yet. Googling for rooting device and nobody every has rooted this device.

Tried to boot from the SD card and no luck yet.

Seems that the serial port via USB is open from what I am reading. Will have a look see here. So far it doesn't look too promising and is way differently made than the O2 Joggler, Openpeak 1 and 2 devices.

Re: Cisco Cius/OpenPeak OpenTablet 7

Posted: Sun Jan 03, 2021 4:33 pm
by Cheburator2
I have Cisco Cius and I found some useful things:
1. Flash drive device is readable by any user, so you can dump whole flash just by "adb pull /dev/block/mmcblk0";
2. Last partition on this drive is used as temporary firmware storage, so you can extract last flashed firmware;
3. I found test firmware with root rights for ADB!
Firmware: ... =103206616
To download it you need 4pda account.
Unfortunally, all components of firmware is signed by RSA-2048 signature, but with this test firmware it should be possible to load custom OS.
2 D4rk4:
Can you please share your cius-opensource924-3.tgz file?