Page 1 of 1

Openpeak 7e - British Gas / OpenEnergy

Posted: Sun May 06, 2018 9:18 pm
by Paul Webster
I picked up one of these on Ebay this week.
I have not yet let it have an Internet connection just to be sure that it does not find a remote update that breaks something (although it is possible that a previous owner has done that).

Anyway - it boot up into a British Gas branded Tango UI.
The About screen showed software version 28xxx (I did not write down the number and lost the telnet session that I had it in as well).

Booting from a USB image of SQPOS that was working fine on a Joggler did not work. Lights on the USB stick showed it being accessed but the screen stayed on Openpeak logo.

So rebooting with the shipped software/firmware and then plugging in a network cable (but without Internet access) I was able to telnet in with user root and no password.

After a bit of rummaging around I decided to use reflash tool.

Reflash tool booted fine (although I was using a different USB stick for that so I will probably have to retest).
I asked it to write SQPOS for OF1 (I know I should have chosen OF2).
It appeared to work - but subsequent reboot was stuck on Openpeak logo again.
So then I wrote SQPOS for OF2 ... reboot to Openpeak logo again.

So then I wrote Roobarb's variation on stock OS (30300) and this booted into Tango with lots of icons and they work (except if they ask for network access which I still have not given).

Then tried to boot SQPOS from USB ... stuck on OpenPeak again.
Tried reflash to SQPOS for OF2 ... stuck on OpenPeak again.
Reflash back to stock ... reboots without a problem.

So - why would stock work but SQPOS for OF2 not - when written back to device?

Over the years I have used many Jogglers both booting SQPOS from internal memort and from USB and all have (and still) worked fine.

Now with stock loaded I see in Settings/About ...
Firmware 8964 (boardrev: 3) [ID=25786]

Re: Openpeak 7e - British Gas / OpenEnergy

Posted: Sun May 06, 2018 9:35 pm
by pete
So then I wrote Roobarb's variation on stock OS (30300) and this booted into Tango with lots of icons and they work (except if they ask for network access which I still have not given).

This is correct.

When it boots after plugging it in what logo do you see?

Here switched mine to the Avaya Boot. Thinking that they were Openpeak orginally.

Openpeak or Gas company?

Next step of writing Squeezeplayer OS should work fine.

I am currently utilizing two of these (Openpeak labled) with the OF2 Squeezeplayer OS.

Re: Openpeak 7e - British Gas / OpenEnergy

Posted: Mon May 07, 2018 10:54 am
by Paul Webster
I've now risked booting with internet accessible - and it has not changed things.

I can still USB boot from reflash tool.

I can still internal boot with 30300 Openpeak - but cannot get it to boot from SQPOS on internal or USB.

I was using my trusty old USB key for the reflashing - that I have used over the years with the Jogglers.
I had reflash 1.09 on it ... so I made a new USB boot stick with reflash 1.11 ... and tried again with internal SQPOS but still no joy.
The new USB stick boots into reflash 1.11 and appears to work (although does show some ALSA errors but perhaps that is because it was looking for Joggler audio and not OF2 audio).
The Shutdown at the end does not appear to complete (no power down - unlike 1.09 reflash).
Subsequent reboot hangs on Openpeak logo again.

Reflashed to 30300 Openpeak ... and it boots fine.

So, unless there is a way to get a boot log to appear somewhere then I think that the next step is to risk EFI rewite using Avaya perhaps.
I know that this is risky on OF2.


Re: Openpeak 7e - British Gas / OpenEnergy

Posted: Tue May 08, 2018 11:35 am
by Paul Webster
I took the chance ... and wrote the Avaya EFi to it.
I couldn't do it with Roobarb's reflash 1.11 - there was an error message that implied to me it was not able to do the
modprobe fh
So - I did it by hand and ...
it worked
Now boots with Avaya logo - and the USB image of SQPOS that would not run before now does.

Tried it alongside a Joggler and the sound is better. I'd say it is fuller.

Now to sneak it into the bathroom.

Re: Openpeak 7e - British Gas / OpenEnergy

Posted: Tue May 08, 2018 2:07 pm
by pete
Yes noticed that the FH stuff was not included in 1.11 flash / 30300 version such that I booted up with an older USB Buzz build.

Newest Buzz's Ubuntu build also doesn't include FH.

Jog-SQP-17:/dev# modprobe fh
modprobe: ERROR: could not insert 'fh': Exec format error
root@ICS-Jog-SQP-17:/dev# uname -a
Linux ICS-Jog-SQP-17 3.18.2op4 #4 SMP Thu Jan 15 16:26:27 GMT 2015 i686 i686 i686 GNU/Linux

That said the Avaya build is supposed to include some SATA booting stuff which can be utilized with the OP2 at some future date.

Really the only PITA part is the the EFI boot chip is soldered on and you have to be careful when writing to it.

Here have a hardware beta O2 which is really an OP2 with an EFI socket instead of the soldered chip. It is marked O2 on the motherboard and all of the DECT / Zigbee related chips were removed from it. I do not remember where it came from but pretty sure it was a OpenPeak testing for O2 beta hardware device in a OP2 shell. Many of the OP2's I have came in Openpeak black boxes all labeled Openpeak with no telco labels and included one Openpeak labeled DECT phone per box. (this is different than the Cisco, Ayava, Verizon or energy company Openpeak 2 devices I have).

I also have the original Openpeak EFI boot roms here. Very generic. The OP2 is much nicer hardware wise than the OP1 or O2 Joggler. Except for the soldered on ROM and difficulty prying the case apart.

I did the same as you putting the OP2 Squeezeplayer in the bathroom replacing the Amazon Alexa which was really low on the WAF.

Only here have it connected to an amplifier / external speakers. It's been working now this way for months.

For years now have been running the Logitech squeezeserver on the Ubuntu 16.04 server with MythTV. It does mount a remote NAS for music.

Just recently also added the Squeezeplayer plugin to main KODI TV box which is also running Ubuntu 16.04 on a mini PC.

I would suggest also writing to the SROM Realtek NIC chip as the one you have doesn't have a ROM in it.

Here you have to write the seabios rom over the EFI rom. Boot in dos with the SROM writer and update the NIC rom with a MAC address of your choice. Then rewrite the Ayava rom during boot of the Seabios rom. It is easy to do.

Re: Openpeak 7e - British Gas / OpenEnergy

Posted: Tue May 08, 2018 4:28 pm
by Paul Webster
I'll have a look at that - (reprogram NIC) - first though I think I'll investigate updating the Squeeze player.
There are quite a few changes made since the one on SQPOS - in particular a display format that increases the size of cover art.

So - Roobarb ... if you see lots being pulled from your download site at the moment ... it is me.