Page 1 of 1

Help with samba shares please!

Posted: Sat Aug 19, 2017 5:36 pm
by dwl99
I'm hoping some of the nice people on this forum can help with this. My Raspberry Pi2 is running Raspbian Jessie lite with samba server installed this way:

Code: Select all

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install samba samba-common-bin

sudo mkdir -m 1777 /share

sudo nano /etc/samba/smb.conf
I added the dollowing to the smb.conf file:

Code: Select all

Comment = Pi shared folder
Path = /share
Browseable = yes
Writeable = Yes
only guest = no
create mask = 0777
directory mask = 0777
Public = yes
Guest ok = yes
and then:

Code: Select all

sudo smbpasswd -a pi

sudo /etc/init.d/samba restart
The only problem is, Windows 10 refuses to see the samba share. ES File Explorer on Android can see it though. Any pointers?


Re: Help with samba shares please!

Posted: Sun Aug 20, 2017 11:50 am
by pete
Here utilize samba shares for my 1-wire temperature network on the RPi2. It is shared publically.

# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = ICS

[ICS-Znet] ;the share name can be what ever you want
browseable = yes
path = /opt/digitemp
guest ok = yes
read only = no
create mask = 777

I mount the share here on other Linux computers using FSTAB. With Windows (7,8,10) I see the workgroup and share just fine.

I do public shares for my music, pictures and videos on three NAS boxes here.

I am reading now too that the last Windows 10 update discombobulated some of this stuff.

In W10 just go to system properties where you can rename your computer and workgroup name. Match the workgroup name to the Samba workgroup name. Then go to the public share. You should see it fine.

Re: Help with samba shares please!

Posted: Sun Aug 20, 2017 2:37 pm
by dwl99
Thanks Pete - I changed the workgroup name on the Pi to DWL_WORKGROUP in the 2 places in smb.conf (i.e. workgroup = DWL_WORKGROUP and [DWL_WORKGROUP]) and restarted samba. I then changed the Windows 10 machine's workgroup to DWL_WORKGROUP and rebooted but still no success.

ES File Explorer in Android can see the RPi DWL_WORKGROUP so I think it's probably a Windows 10 issue.

Re: Help with samba shares please!

Posted: Sun Aug 20, 2017 3:28 pm
by pete
How is your networking configured in W10 (public or private?). Here mine is public. I let the PFSense firewall do most of the work here.

Typically these days security on W10 is set up onion layer like and not easy to access which is a PITA as it is there but levels and menu's down.

Will test W10 sharing here and have a look see. It is running on this laptop as an Oracle Virtual box.

Got a message to update current W10 build to most current. Basically telling me that I will see errors until it is updated.

Re: Help with samba shares please!

Posted: Sun Aug 20, 2017 4:13 pm
by dwl99
W10 is set to allow file & printer sharing, network discovery is on & there is a Homegroup too.

Re: Help with samba shares please!

Posted: Sun Aug 20, 2017 7:02 pm
by pete did a new W10 Pro (Oracle VB) build to see it from scratch.

I could see the public samba share. I would click on it and it asked me for a user name and password. I typed anonymous and it let me in.

I did not save the login. Next time just typed in public with no password. Guessing if you just type public and save the login you will not have any issues with the future sessions.

Re: Help with samba shares please!

Posted: Sun Aug 20, 2017 8:06 pm
by dwl99
Thanks Pete but the primary problem is that my W10 machine does not see the share in the first place. Nor do any other W10 PCs on the same network :-(

Re: Help with samba shares please!

Posted: Sun Aug 20, 2017 9:00 pm
by pete
Yeah here built a new Oracle W10 Pro virtual box.

When I looked at the network first time before configuring all of the stuff didn't see any devices on the network.

I configured it for a public network and changed the workgroup to my ICS workgroup.

Rebooted it and could see all of my devices and saw the devices with shares.

Reading / googling see an issue with newest Windows 10 samba. I did not have to do this to see my Samba shares on W10 Pro VB.

Disable it and try it again. See here:

Windows 10 will try to negotiate SMB3_11, which Samba4 doesn't yet support except in the current 4.3 release candidate. I suspect for now disabling SMB2/3 on the Windows 10 client is your best, if not ideal, option.

How to enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server ... nd-windows

Re: Help with samba shares please!

Posted: Mon Aug 21, 2017 6:02 am
by dwl99
Thanks again, I'm sure that's the issue. I tried disabling SMBv2&3 and turning on SMBv1 but that still didn't work. SMBv1 also seems to be a security risk. So I guess I'll just have to use WinSCP for file transfers.

Re: Help with samba shares please!

Posted: Mon Aug 21, 2017 11:32 am
by pete
Yes here have turned an old RPi2 back to Wheezy from Jessie. To me it was a bit lighter for my 1-wire temperature stuff and Z-Wave stuff. Personally Jessie was / is too fat for the RPi2 for me. That is me.

While I have a few RPi's have been goofing around with running a Pine64 with 2Gb on it and getting ready to test the Rock64 computer.

Also getting ready to test new multiple NIC Intel SOC based firewall (for PFSense) on a nano ITX board. Amazing stuff.

Z-Wave is just a serial to net tunnel. 1-Wire is using both OWFS and Digitemp. I share the OWFS directory and created a shared Digitemp directory. The NAS boxes are running BSD with password protected access.

The shares I am using on a couple of these are linux to linux and today mostly Ubuntu to Ubuntu except for the couple of Wheezy builds.

I look at the Wheezy build and it is running
ICS-ZNet:~# smbd -V
Version 3.6.6

Current version of Samba on big Ubuntu box is:
smbd -V
Version 4.3.11-Ubuntu

Googing anonymous Windows 10 sharing finding for Wheezy...

editing file:

nano /etc/samba/smb.cnf

workgroup = WORKGROUP
server string = Samba Server %v
netbios name = debian
security = user
map to guest = bad user
dns proxy = no
#============================ Share Definitions ==============================
path = /samba/anonymous
browsable =yes
writable = yes
guest ok = yes
read only = no

mkdir -p /samba/anonymous
service samba restart

to give anonymous read write permissions:

root@server1:~# cd /samba
root@server1:/samba# chmod -R 0755 anonymous/
root@server1:# chown -R nobody:nogroup anonymous/
root@server1:/samba# ls -l
total 4
drwx-xr-x 2 nobody nogroup root 4096 May 27 18:17 anonymous

Typically for the RPi's delete the base user and add myself, one sudo user and change the root password.
I was manipulating files using scripts and ssh logins and copying encryption keys but it was a bit much.

For quick Windows to Linux file manipulations here with groups of files and directories utilize WinSCP more than Putty. Same in Linux using file manage to manipulate files on the RPi boxes. For my new tinker toy Lightning sensor (hand wired to an old original RPi) using samba to share lightning sensor data over to the weather station stuff which is now running WeeWx (Davis using a Meteostick).

Relating to Windows 10 computers mostly going in the direction of creating automation touchconsoles with Windows 10 computers. Tesing one small footprint Windows 10 computer connected to a multiple touch 17" wide screen monitor and using Kinect with multiple voice SAPI an Cortana giving it an Amazon Alexa feel to it. (concurrently playing with Amazon Alexa and now getting ready to play with Google Home stuff). Leaving wife's desktop at W7 as it is the same for her at work. Tablets have been cooked with custom Android and moving them to Windows 10 now. Might switch a couple over to Linux. No dependencies here on smart phones such that I have multiple OS smart phones and multiple SIM cards which I switch around all of the time....mostly using the smartphone to talk on. (SIM cards are all unlimited everything).